You are not logged in.

#51 2016-06-29 06:36:08

hobarrera
Member
From: Amsterdam, NL
Registered: 2011-04-12
Posts: 354
Website

Re: Firefox lag recently

gothmog123 wrote:
fasolt wrote:

Can confirm that running the 4.6 kernel with enable_fbc=0 and xf86-video-intel reverted to the default SNA acceleration also solves the problem for me.

Me too.

I had some light lag issues with this fix. The UXA vs SNA fix worked flawlessly for me.

Offline

#52 2016-06-30 21:22:44

Mathuin
Member
Registered: 2014-04-11
Posts: 16

Re: Firefox lag recently

I had the same issue with anything GTK-based. Removing xf86-video-intel did the trick.

Offline

#53 2016-07-05 21:05:32

juego
Member
Registered: 2015-04-13
Posts: 41
Website

Re: Firefox lag recently

hobarrera wrote:
gothmog123 wrote:
fasolt wrote:

Can confirm that running the 4.6 kernel with enable_fbc=0 and xf86-video-intel reverted to the default SNA acceleration also solves the problem for me.

Me too.

I had some light lag issues with this fix. The UXA vs SNA fix worked flawlessly for me.

Thanks for this info. Could someone point me to the relevant page or info on how to apply this kernel parameter and hom to revert xf86-video-intel to defailt SNA. I'm not sure where I have to look. Thx.

Offline

#54 2016-07-05 21:20:17

jwhendy
Member
Registered: 2010-04-01
Posts: 621

Re: Firefox lag recently

@juego: as listed, you would put this is in /etc/modprobe.d/i915.conf (file name is irrelevant... just something so you know what it's for). The contents would be:

$ cat /etc/modprobe.d/i915.conf 
options i915 enable_fbc=0

You can also pass options via the kernel line. This will depend on your bootloader. I use syslinux, so I'd have:

LABEL arch
    MENU LABEL arch
    LINUX ../vmlinuz-linux
    APPEND i915.enable_fbc=0
    INITRD ../intel-ucode.img,../initramfs-linux.img

I think using xf86-video-intel defaults to SNA, so as long as you have nothing overriding that in /etc/X11/xorg.conf.d/blah.conf, you're set. If you really want to be sure, you'd modify or create a file with the following:

$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "sna"
EndSection

If you're using the modsetting driver (xf86-video-intel is *not* installed), you'd replace "intel" with "modesetting" above.

Hope that helps.

EDIT: as you might not have done kernel options before, if you have other stuff in your bootloader config in the APPEND (or similar) section, you just add the option after what's already there (separated by a space). For example, here's my actual config (with some UUID params stripped off) after adding the fbc option:

APPEND rd.luks.allow-discards i915.enable_fbc=0 rw

Last edited by jwhendy (2016-07-05 21:22:43)

Offline

#55 2016-07-05 21:22:09

juego
Member
Registered: 2015-04-13
Posts: 41
Website

Re: Firefox lag recently

@jwhendy: Thanks a lot for the detailed explanation. Will try all that.

Offline

#56 2016-07-08 00:32:18

juego
Member
Registered: 2015-04-13
Posts: 41
Website

Re: Firefox lag recently

@jwhendy:
Tried all your options but still the same problem for me.
I use Grub and added

GRUB_CMDLINE_LINUX="i915.enable_fbc=0"

to the /etc/default/grub file. Regenerated the main grub config. Restarted. But still have a lagging Firefox.
I do have the latest xf86-video-intel installed.

Offline

#57 2016-07-08 00:33:19

xgdgsc
Member
Registered: 2012-02-03
Posts: 125

Re: Firefox lag recently

After using modesetting driver. I would need to re-login to plasma desktop every time after suspend. Seems I need to come back to xf86-video-intel.

Offline

#58 2016-07-26 02:46:31

jpe30
Member
Registered: 2009-01-02
Posts: 24

Re: Firefox lag recently

Had to switch to the linux-lts kernel to get past this one. None of the other settings worked for me.

model name      : Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
Integrated Graphics Chipset: Intel(R) HD Graphics 5500

Offline

#59 2016-07-31 12:14:19

mic
Member
Registered: 2016-07-31
Posts: 2

Re: Firefox lag recently

As already mentioned by two other users, simply changing SNA acceleration to UXA has fixed that issue for me as well. - Kernel 4.6.4-1 and enable_fbc=1 -

$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "uxa"
EndSection

Offline

#60 2016-07-31 12:20:39

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: Firefox lag recently

No, switching to UXA does not fix it. The *only* real fix is in the intel-drm-nightly kernel, from where it'll make it into a mainline kernel, no idea if the 4.7 kernel will have it, very likely 4.8 will. All the other things (UXA, dropping xf86-video-intel for modesetting) are *not* fixes, they merely avoid the issue.

workaround != fix

Offline

#61 2016-08-10 02:04:38

hendry
Member
From: Singapore
Registered: 2009-09-08
Posts: 151
Website

Re: Firefox lag recently

/etc/modprobe.d$ cat i915.conf
options i915 enable_fbc=0
/etc/modprobe.d$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
   Option      "AccelMethod"  "sna"
EndSection

On a Skylake based T460s and Chrome is still lagging for me despite the above modifications. Not sure how to test if they are having effect.

Offline

#62 2016-08-17 20:56:08

giacecco
Member
Registered: 2016-08-17
Posts: 2

Re: Firefox lag recently

A quick note to share that I've had the same problem on Fedora 24 using i3wm as window manager on a Thinkpad T450s. The problem showed up when using Firefox. Running xcompmgr is a working workaround. My video card is

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

Offline

#63 2016-08-18 01:35:39

hendry
Member
From: Singapore
Registered: 2009-09-08
Posts: 151
Website

Re: Firefox lag recently

I'm just trying `xcompmgr` and it does indeed feel snappier. But why is that?

~$ lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
        Subsystem: Lenovo Device 2234
        Kernel driver in use: i915
--
06:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev ff)
        Kernel modules: nouveau, nvidia_drm, nvidia

Offline

#64 2016-08-19 12:44:38

effae
Member
Registered: 2013-05-07
Posts: 39

Re: Firefox lag recently

giacecco wrote:

A quick note to share that I've had the same problem on Fedora 24 using i3wm as window manager on a Thinkpad T450s. The problem showed up when using Firefox. Running xcompmgr is a working workaround.

Thanks for this tip. I'm on a t450s as well and have been avoiding i3wm because of this problem. This workaround seems to do the trick for now!

Last edited by effae (2016-08-19 12:45:19)

Offline

#65 2016-09-02 09:00:27

biocyberman
Member
Registered: 2015-06-29
Posts: 4

Re: Firefox lag recently

juego wrote:

Same here. Glad to have found this thread. I noticed that this lag was happening with many applications. Even with Terminator and Firefox. Main problem I saw is that the graphics where frozen until I moved the mouse. Very noticable when playing a video for example.

Installing

xcompmgr

did not solve it.
Removing

xf86-video-intel

did solve it.

sudo pacman -R xf86-video-intel

and then reboot solved the problem for me. Very glad I found the simple solution for this irritating problem.

Offline

#66 2016-10-04 17:21:54

thufirhawat
Member
Registered: 2013-06-22
Posts: 14

Re: Firefox lag recently

Hi,

I am running

Linux o 4.7.6-1-ARCH #1 SMP PREEMPT Fri Sep 30 19:28:42 CEST 2016 x86_64 GNU/Linux

with an Intel Graphics Card

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

and indeed, setting

options i915 enable_fbc=0

works around the problem. Otherwise my Firefox and other GTK apps lag as hell. For the record here are my stats

firefox 49.0.1-1
i3-wm 4.12-1
linux 4.7.6-1

And yes, booting th LTS kernel also solves the problem.

Offline

#67 2016-10-23 14:26:07

jpe30
Member
Registered: 2009-01-02
Posts: 24

Re: Firefox lag recently

jpe30 wrote:

Had to switch to the linux-lts kernel to get past this one. None of the other settings worked for me.

model name      : Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
Integrated Graphics Chipset: Intel(R) HD Graphics 5500

Has anyone figured out a fix for the 5500? I installed the LTS kernel, which temporarily solves the issue, but would like to stay with the current kernel if at all possible.

EDIT: Took 5 min and tried the "options i915 enable_fbc=0" fix again with the Intel driver installed, worked like a charm. Not sure if this with the combo of kernel and Intel driver updates solved it, but needless to say something changed since I last tried and now everything is back to working properly.

Last edited by jpe30 (2016-10-23 14:38:51)

Offline

#68 2019-10-13 16:03:25

fugit
Member
Registered: 2019-10-13
Posts: 1

Re: Firefox lag recently

FreeFull wrote:

I have ran into this issue too, with Firefox and sunvox. I kept xf86-video-intel installed, and put xcompmgr & in my .xinitrc, and that seems to have fixed it.

Thanks FreeFull this fixed it for me.

Offline

#69 2019-10-13 16:18:42

jwhendy
Member
Registered: 2010-04-01
Posts: 621

Re: Firefox lag recently

@fugit: please let old threads sit or start a new one vs. necrobumping.

Offline

#70 2019-10-13 18:10:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,813

Re: Firefox lag recently

Indeed.

Closing.

Offline

Board footer

Powered by FluxBB