You are not logged in.

#1 2016-06-09 05:12:17

yanom
Member
Registered: 2013-06-30
Posts: 36

Firefox lag recently

So For the last day and a half (since I rebooted for a kernel update to 4.6.1-2 Monday) all my GTK-based programs are very slow, suffer from keyboard input lag, and experience visual tearing. I'm using Intel integrated graphics with the Xmonad window manager. Anyone else experiencing this problem? What happened?

Last edited by yanom (2016-06-10 13:27:44)

Offline

#2 2016-06-09 10:05:38

Okki
Member
Registered: 2014-09-20
Posts: 4

Re: Firefox lag recently

Same thing here. The tearing is particularly visible with Firefox.

Offline

#3 2016-06-09 10:07:41

bashnev
Member
Registered: 2012-06-11
Posts: 24

Re: Firefox lag recently

Yes I just noticed this too. But in addition to seeing the lag in Firefox and Atom, which are GTK based, I also see it in Calibre which is QT based. I'm using xombrero (GTK) to post this and it has no lag issues. I'm using i3wm.

Last edited by bashnev (2016-06-09 10:08:26)

Offline

#4 2016-06-09 12:14:01

PootisBird
Member
Registered: 2014-04-16
Posts: 120

Re: Firefox lag recently

What's the GPU vendor and driver ?
I see no such issues with my GK104 using nvidia blob.

Offline

#5 2016-06-09 12:43:50

george55
Member
Registered: 2011-08-10
Posts: 58

Re: Firefox lag recently

Same here. Lags most obvious in Firefox. Also using i3wm.

$ egrep -i " connected|card detect|primary dev|Setting driver" ~/.local/share/xorg/Xorg.0.log
[    10.993] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160229

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 08)

Offline

#6 2016-06-09 13:07:30

quyse
Member
Registered: 2016-06-09
Posts: 3
Website

Re: Firefox lag recently

I see lags too since this morning in Sublime Text 3 and Firefox. Chromium works fine, and OpenGL acceleration in general works fine. I'm using Xmonad and Intel integrated graphics too. Looks like it started happening after last system upgrade, which was for me:

[2016-06-08 22:33] [ALPM] upgraded ca-certificates-mozilla (3.23-4 -> 3.24-1)
[2016-06-08 22:33] [ALPM] upgraded nss (3.23-4 -> 3.24-1)
[2016-06-08 22:33] [ALPM] upgraded firefox (46.0.1-1 -> 47.0-1)
[2016-06-08 22:33] [ALPM] upgraded linux-firmware (20160315.deb1d83-1 -> 20160516.80d463b-1)
[2016-06-08 22:34] [ALPM] upgraded linux (4.5.4-1 -> 4.6.1-2)
[2016-06-08 22:34] [ALPM] upgraded openresolv (3.7.2-1 -> 3.8.1-1)
[2016-06-08 22:34] [ALPM] upgraded xorg-server-common (1.18.3-1 -> 1.18.3-2)
[2016-06-08 22:34] [ALPM] upgraded xorg-server (1.18.3-1 -> 1.18.3-2)

My other machine with the exactly the same packages works fine, it uses Xmonad and AMD graphics with open source driver. So is it Intel graphics-specific?

Last edited by quyse (2016-06-09 13:17:54)

Offline

#7 2016-06-09 13:35:48

yanom
Member
Registered: 2013-06-30
Posts: 36

Re: Firefox lag recently

I've got:

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

Offline

#8 2016-06-09 13:46:20

Stormaaja
Member
Registered: 2015-03-26
Posts: 1

Re: Firefox lag recently

Same thing here after upgrade yesterday.

At least Sublime Text and KeepassX lags a lot (GTK and Qt).

Using i3wm.

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
$ uname -r
4.6.1-2-ARCH

Offline

#9 2016-06-09 14:25:23

joanmanel
Member
Registered: 2012-11-06
Posts: 137

Re: Firefox lag recently

Same here, also using i3wm

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

also using kernel 4.6.1-2

Offline

#10 2016-06-09 15:40:22

Monoïde
Member
Registered: 2015-05-19
Posts: 2

Re: Firefox lag recently

Same issues with me (i3wm too, kernel 4.6.1-2), I also experience laggs in okular (I have no idea if it is related)

Firefox is so laggy that it is not usable, but a downgrade fix this problem.

Offline

#11 2016-06-10 06:27:24

NoSuck
Member
Registered: 2015-03-04
Posts: 157
Website

Re: Firefox lag recently

I am also experiencing this issue and will downgrade immediately.  Is 4.5.4-1 the latest known good kernel?

■ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
■ grep -Ei 'setting driver' "$HOME/.local/share/xorg/Xorg.0.log"
[    25.195] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160229
■ uname -a
Linux slim 4.6.2-1-ARCH #1 SMP PREEMPT Wed Jun 8 08:40:59 CEST 2016 x86_64 GNU/Linux
■ openbox --version
Openbox 3.6.1

Affected applications:

  • qutebrowser (Qt)

  • Firefox (GTK... 3?)

  • Smplayer (Qt)

Seemingly unaffected applications:

  • GNOME Charmap (GTK3)

  • ibus-setup (GTK3)

  • Chromium (GTK2)

  • XTerm

Last edited by NoSuck (2016-06-10 06:34:40)

Offline

#12 2016-06-10 07:11:56

pAiN
Member
Registered: 2015-10-05
Posts: 3

Re: Firefox lag recently

Me, too.

4.6.1-2, i3wm and Broadwell-U Gprahics. qutebrowser and telegram-desktop are awful lagging.

Last edited by pAiN (2016-06-10 07:12:06)

Offline

#13 2016-06-10 07:12:25

SubS0
Member
Registered: 2015-02-10
Posts: 32

Re: Firefox lag recently

See Trilby's and The Compiler's posts here : problem doesn't seem to be related to GTK3.

On my laptop, I've got the same graphics controller as The Compiler (rev 09), and the problem is not present with 4.6.1-2-ARCH :

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

On my desktop (and other), with other Intel controller, problem affects qutebrowser as well as firefox.

 lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Firefox 47 is affected, but not the 46 version.
Got firefox-esr-privacy, version 45.1.0-1 (GTK2 ?) installed on both computers, and they don't seem concerned. But qutebrowser is.

Downgrading to 4.5.4-1-ARCH solves the problem.

Last edited by SubS0 (2016-06-10 07:13:42)

Offline

#14 2016-06-10 08:00:28

NoSuck
Member
Registered: 2015-03-04
Posts: 157
Website

Re: Firefox lag recently

Rather than downgrade to 4.5.4-1, I listened to the kind advice of others and rebooted from linux-lts.  This solved the problem.

Yanom:  Please update the title, as this issue is not specific to GTK.

Offline

#15 2016-06-10 08:03:04

cdep.illabout
Member
Registered: 2016-06-10
Posts: 1

Re: Firefox lag recently

yanom wrote:

So For the last day and a half (since I rebooted for a kernel update to 4.6.1-2 Monday) all my GTK-based programs are very slow, suffer from keyboard input lag, and experience visual tearing. I'm using Intel integrated graphics with the Xmonad window manager. Anyone else experiencing this problem? What happened?

I'm on the exact same setup and I'm experiencing the exact same problems.  I'm going to try downgrading to the lts kernel and see if that works.

Edit: After downgrading to the LTS kernel, I can confirm that everything is working properly.

Last edited by cdep.illabout (2016-06-10 10:15:49)

Offline

#16 2016-06-10 17:35:27

andytoshi
Member
Registered: 2016-06-10
Posts: 6

Re: Firefox lag recently

A workaround for current kernels is to use the TearFree X option; see my post at https://bbs.archlinux.org/viewtopic.php … 1#p1633511

Offline

#17 2016-06-13 12:58:53

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,401
Website

Re: Firefox lag recently

A better workaround seems to be just ditching the xf86-video-intel driver.  I couldn't figure out why I had these problems on one computer but not the other until I realized I had tried getting rid of xf86-video-intel on one of them.

Allegedly the intel driver is no longer necessary and there is some debate over whether it or the built in modesetting driver perform better (they each seem to win some battles).  But with this issue, I've ditched the intel driver completely and all is well.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#18 2016-06-13 15:40:54

jwhendy
Member
Registered: 2010-04-01
Posts: 612

Re: Firefox lag recently

Request: @yanom could you update the title to be more descriptive now that the problem(s) seem to be clearer? I experienced this but somehow couldn't find this post initially as I don't use firefox so I didn't think it was related. I saw the issue with sublime-text-dev, atom-editor, and rstudio-desktop-bin. I think something like "applications slow/lag after recent update" or "linux 4.6 update causes lag/slow applications" might be more helpful for others to find this. Just my input!

@trilby I can confirm that removing xf86-video-intel solved this for me (I'm on 4.6.2-1-ARCH and the crazy lag is gone after a reboot). Out of curiosity, how did you learn one doesn't need this driver? I have discrete nvidia and integrated intel, so thought I required both for use with bumblebee. Thanks for posting this, as I much prefer this to downgrading and having to keep a watch out for attempted linux-* updates.

Offline

#19 2016-06-13 16:11:56

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,401
Website

Re: Firefox lag recently

jwhendy wrote:

@trilby ... how did you learn one doesn't need this driver?

https://wiki.archlinux.org/index.php/Intel_graphics

There are now numerous discussions, on these forums and others, comparing performance with and without xf86-video-intel.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#20 2016-06-13 16:33:09

jwhendy
Member
Registered: 2010-04-01
Posts: 612

Re: Firefox lag recently

@trilby: huh. Thanks for that, just had never heard of this before.

I spoke too soon. Removing xf86-video-intel worked for the lag in the various editors, but now libreoffice causes Xorg crashes. There's a link above to this, but I'm a bit out of my league on xorg stuff...
- re-install xf86-video-intel and create /etc/X11/xorg.conf.d/intel.conf
- leave it uninstalled and try the various /etc/modprobe.d and kernel line options
- re-install it and use the xorg.conf options and the module/kernel options

At this point I'm just going to downgrade linux to 4.5.4 and call it a day (assuming that works).

Offline

#21 2016-06-13 20:45:14

quyse
Member
Registered: 2016-06-09
Posts: 3
Website

Re: Firefox lag recently

I found a simple workaround which works for me: running composite manager. Normally I'm going without it.

Simply launching

xcompmgr

immediately solves the lagging problem for Sublime Text 3, Firefox and other programs. No kernel downgrade needed.

Offline

#22 2016-06-13 22:40:21

winnyec
Member
Registered: 2014-01-13
Posts: 6

Re: Firefox lag recently

My situation is even weirder.  I use Notion with Xrandr on two monitors both connected to the motherboard video outputs.  Firefox lags on only one of the monitors (the one connected with DVI), i.e. dragging the very same window to the other monitor (connected via HDMI) makes it work flawlessly.

Unfortunately removing xf86-video-intel does not help, since then the mouse pointer is stuck to the monitor it starts off from (even though both monitors render X). [xorg.conf needed a tiny bit of retouch due to the driver change: now all is fine with removing xf86-video-intel]

So far I have noticed it impacting only Firefox noticeably.

Update:
Windows 8 in VirtualBox is also lagging the very same way: dragging windows through monitors makes it lag or not.

Last edited by winnyec (2016-06-13 23:17:43)

Offline

#23 2016-06-13 23:57:19

juego
Member
Registered: 2015-04-13
Posts: 41
Website

Re: Firefox lag recently

Same here. Glad to have found this thread. I noticed that this lag was happening with many applications. Even with Terminator and Firefox. Main problem I saw is that the graphics where frozen until I moved the mouse. Very noticable when playing a video for example.

Installing

xcompmgr

did not solve it.
Removing

xf86-video-intel

did solve it.

Thanks to all for your help

Offline

#24 2016-06-14 02:34:06

hobarrera
Member
From: CABA, Argentina
Registered: 2011-04-12
Posts: 342
Website

Re: Firefox lag recently

Removing xf86-video-intel solved it for me as well. Firefox(gtk3) was the only app I noticed affected, while Thunar (gtk2) was not affected at all.


GPG Key | AUR packages | github

caffeine-ng: Temporarily disable screensaver/sleeping with a simple click.

Offline

#25 2016-06-14 03:20:53

raddecen
Member
Registered: 2015-12-19
Posts: 26

Re: Firefox lag recently

Trilby wrote:

A better workaround seems to be just ditching the xf86-video-intel driver.  I couldn't figure out why I had these problems on one computer but not the other until I realized I had tried getting rid of xf86-video-intel on one of them.

Allegedly the intel driver is no longer necessary and there is some debate over whether it or the built in modesetting driver perform better (they each seem to win some battles).  But with this issue, I've ditched the intel driver completely and all is well.

I recently ditched the xf86-video-intel driver and it improved the hardware acceleration in Firefox a lot. However, LibreOffice ecrashed with "gpu hang"s everytime I opened it and I had to reinstall it. Did you experience this issue?

Offline

Board footer

Powered by FluxBB