You are not logged in.

#1 2016-06-13 03:55:26

jwhendy
Member
Registered: 2010-04-01
Posts: 612

[duplicate] Slow/lag after update (sublime-text-dev, atom, rstudio)

Update: I didn't find it in my original search as I think symptoms are manifesting themselves differently for various folks, but this post appears to be the same issue. I can confirm that downgrading to kernel 4.5.4 solved the issue for me. Please see that post for other ideas (like removing xf86-video-intel to use in the built-in i915 driver) and a link here regarding some possible intel graphics driver Xorg options.

-----
I booted up to find that sublime-text-dev was running extremely lag-ish. Any action at all takes several seconds to complete (just arrowing around, clicking to move the cursor, basic stuff). I thought it was just sublime, and went on to install atom as I'd been thinking of trying it out. I got the same behavior. Happened to need to look at an R script using rstudio and found it, too, was doing the same.

top is showing nothing out of the ordinary, with the highest cpu consumers fluctuating between the usual: top, chromium, urxvt, Xorg. None ever feature higher than ~1-2%. According to free I'm using ~800k of ram, leaving just under 23G available. I have no idea what's up.

Here's a list of recent packages; I know sublime was working on Thurs or Fri last week, so if it's a package it should be one of these.

[2016-06-09 18:20] [PACMAN] Running 'pacman -Syu'
[2016-06-09 18:20] [PACMAN] synchronizing package lists
[2016-06-09 18:20] [PACMAN] starting full system upgrade
[2016-06-09 18:29] [ALPM] transaction started
[2016-06-09 18:29] [ALPM] upgraded pciutils (3.4.1-1 -> 3.5.1-1)
[2016-06-09 18:29] [ALPM] upgraded expat (2.1.1-2 -> 2.1.1-3)
[2016-06-09 18:29] [ALPM] upgraded gnutls (3.4.12-1 -> 3.4.13-1)
[2016-06-09 18:29] [ALPM] upgraded chromium (51.0.2704.79-1 -> 51.0.2704.84-1)
[2016-06-09 18:29] [ALPM] upgraded cups-filters (1.8.3-2 -> 1.9.0-1)
[2016-06-09 18:29] [ALPM] upgraded feh (2.15.4-1 -> 2.16-1)
[2016-06-09 18:29] [ALPM] upgraded linux (4.6.1-2 -> 4.6.2-1)
[snip]
[2016-06-09 18:30] [ALPM] upgraded linux-docs (4.6.1-2 -> 4.6.2-1)
[2016-06-09 18:30] [ALPM] upgraded linux-headers (4.6.1-2 -> 4.6.2-1)
[2016-06-09 18:30] [ALPM] upgraded lua (5.3.2-1 -> 5.3.3-1)
[2016-06-09 18:30] [ALPM] upgraded turbostat (4.6-2 -> 4.6-3)
[2016-06-09 18:30] [ALPM] upgraded xorg-server-common (1.18.3-1 -> 1.18.3-2)
[2016-06-09 18:30] [ALPM] upgraded xorg-server (1.18.3-1 -> 1.18.3-2)
[2016-06-09 18:30] [ALPM] transaction completed

[2016-06-10 15:48] [PACMAN] Running 'pacman -Syu'
[2016-06-10 15:48] [PACMAN] synchronizing package lists
[2016-06-10 15:49] [PACMAN] starting full system upgrade
[2016-06-10 15:49] [ALPM] transaction started
[2016-06-10 15:49] [ALPM] upgraded a52dec (0.7.4-8 -> 0.7.4-9)
[2016-06-10 15:49] [ALPM] upgraded at-spi2-atk (2.20.1-1 -> 2.20.1-2)
[2016-06-10 15:49] [ALPM] upgraded librsvg (2:2.40.15-2 -> 2:2.40.16-1)
[2016-06-10 15:49] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2016-06-10 15:49] [ALPM] upgraded pacman-mirrorlist (20160606-1 -> 20160610-1)
[2016-06-10 15:49] [ALPM] upgraded python2-setuptools (1:22.0.5-1 -> 1:23.0.0-1)
[2016-06-10 15:49] [ALPM] upgraded turbostat (4.6-3 -> 4.6-4)
[2016-06-10 15:49] [ALPM] transaction completed

Other details:
- HP zbook 15 (i7)
- nvidia with bumblebee
- openbox

I haven't started troubleshooting yet by downgrading as it's late and I need to go to bed. I wanted to post here in case there were any suggestions for where to look. Do sublime, rstudio, and atom share any common backends that might be acting up? I don't notice anything odd from Chromium, urxvt, thunar, or emacs (just some applications I've used while this was going on).

Thanks for any suggestions.

Last edited by jwhendy (2016-06-14 20:23:54)

Offline

#2 2016-06-14 17:12:40

g8ntly
Member
Registered: 2016-06-14
Posts: 6

Re: [duplicate] Slow/lag after update (sublime-text-dev, atom, rstudio)

A few day ago i ran into the same issue (sublime-text lagging; being unuseable after full system upgrade). I "solved" it for me by downgrading the kernel back to 4.5.4-1.

cd /var/cache/pacman/pkg
sudo pacman -U linux-4.5.4-1-x86_64.pkg.tar.xz

But i see that you already had newer kernel versions installed. I did experience the lagging of sublime after upgrading to linux-4.6.1-2-x86_64 from 4.5.4-1.
(i run arch on an thinkpad t540s)

I know that this is not a valuable solution - sry my ignorance about this. I had to finish my work.

Anyone has a clue what could cause this problem?
A regression in intel graphic drivers?

cheers

Offline

#3 2016-06-14 20:27:48

jwhendy
Member
Registered: 2010-04-01
Posts: 612

Re: [duplicate] Slow/lag after update (sublime-text-dev, atom, rstudio)

@g8ntly: thanks for the tips! I think I didn't go back far enough in my pacman logs and must have updated everything without rebooting or something. I thought it was the change from 4.6.1 to 4.6.2, but after finding the thread I just linked to above (as an update), I saw folks mentioning 4.5.4 and sure enough that update was just a day or so before.

Take a look at the threads I linked to above; it seems like it's exactly an issue with intel graphics. Would never have suspected that as I use bumblebee and thought it might be related to dkms-nvidia, which is where I started troubleshooting (replacing dkms-nvidia with standard nvidia, reverting nvidia and nvidia-utils, etc.).

Anyway, I don't love the solution as one has to watch linux with every update until some solution comes about. For some, it seems that just uninstalling xf86-video-intel works, and in the second link someone has some kernel line options that seemed to help. Thanks again and your comment reminded me to mark this as a duplicate since all the action is going on in other threads smile

Offline

#4 2016-06-15 00:14:16

g8ntly
Member
Registered: 2016-06-14
Posts: 6

Re: [duplicate] Slow/lag after update (sublime-text-dev, atom, rstudio)

Thank you for pointing me to the other threads! smile

Offline

Board footer

Powered by FluxBB