You are not logged in.

#1 2016-06-13 17:40:34

Alcasa
Member
Registered: 2013-05-18
Posts: 46

[Toshiba Z20T] No speaker sound after suspend

Hi,

after resuming from suspend to RAM the laptop main speakers produce no sound, but the microphone jack works.

Kernel: 4.6.2-1-ARCH

aplay -l returns the same before and after suspend

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: CX20753/4 Analog [CX20753/4 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Killing or using pasuspender does not help.
Sound returns after a reboot. What could the problem be?

Any help would be appreciated, since the problem has been really bugging me a lot. Many thanks in advance.

Offline

#2 2016-06-14 16:18:20

Alcasa
Member
Registered: 2013-05-18
Posts: 46

Re: [Toshiba Z20T] No speaker sound after suspend

Bump. Tried reloading alsa with alsactl kill rescan and adding model=toshiba to snd-hda-intel module options. Still no sound. Any more ways to debug the problem?

Offline

#3 2016-06-17 08:25:26

Alcasa
Member
Registered: 2013-05-18
Posts: 46

Re: [Toshiba Z20T] No speaker sound after suspend

Have reported a bug on the alsa mailing list with more logs and tried using the HDA Analyzer tool. Bumping again.
Bug report

Last edited by Alcasa (2016-06-17 08:27:16)

Offline

#4 2019-01-15 22:40:04

pierro78
Member
Registered: 2013-05-18
Posts: 7

Re: [Toshiba Z20T] No speaker sound after suspend

Alcasa wrote:

Have reported a bug on the alsa mailing list with more logs and tried using the HDA Analyzer tool. Bumping again.
Bug report

hello, can I ask if you solved this issue ??
(I am also experiencing it and it looks like you did quite extensive research on it ... btw I am also interested if you found a workaround ... thanks !! )

PS :
also tried with hibernation
then wakeup
stop pulseaudio
modprobe -r "all snd modules"
modprobe "all snd modules"
start pulseaudio

=> same issue sad

Last edited by pierro78 (2019-01-22 21:21:27)

Offline

Board footer

Powered by FluxBB