You are not logged in.

#1 2016-06-21 14:04:09

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

[SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

Any web browser build with qt5-webengine 5.7 as a backend crashes on some pages. I've check:
- qupzilla-git (rev 54 and today's rev 56) build from AUR,
- otter-browser (weekly edition, today 0.9.11.dev129) build with my own PKGBUILD,
- quill-git build from modernized PKGBUILD from AUR (because that in AUR isn't proper).
Maybe the best test we can do with otter-browser, because it can use both: qt5-webengine or qt5-webkit as a backend (my PKGBUILD: https://dl.dropboxusercontent.com/u/591 … 129.tar.gz - you can choose backend i.e. in ~/.config/otter/otter.conf from qtwebkit to qtwebengine). The same page i.e. http://caballodefuerza.blogspot.com/ works perfectly with qt5-webkit and crashed with qt5-webengine.
The same web browsers build with qt5-webengine 5.6.x works perfectly (almost smile). Page above works good.
This is stack trace from otter-browser with qt5-webengine:

otter-browser   
[0621/154719:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB
Received signal 11 SEGV_MAPERR 000000000020
#0 0x7fac38f9182e <unknown>
#1 0x7fac38f91c09 <unknown>
#2 0x7fac36539310 <unknown>
#3 0x7fac3890be65 <unknown>
#4 0x7fac3898af9c <unknown>
#5 0x7fac38a1032b <unknown>
#6 0x7fac38a10ffe <unknown>
#7 0x7fac38a10ca9 <unknown>
#8 0x7fac38a10ca9 <unknown>
#9 0x7fac38a11101 <unknown>
#10 0x7fac389902bb <unknown>
#11 0x7fac38991666 <unknown>
#12 0x7fac39fe5104 <unknown>
#13 0x7fac3a12a948 <unknown>
#14 0x7fac385c9ee2 <unknown>
#15 0x7fac38dd7d52 <unknown>
#16 0x7fac3a5085d1 <unknown>
#17 0x7fac3a510885 <unknown>
#18 0x7fac39005df9 <unknown>
#19 0x7fac396662b7 <unknown>
#20 0x7fac39666b2c <unknown>
#21 0x7fac39005df9 <unknown>
#22 0x7fac38faf458 <unknown>
#23 0x7fac38fb00e9 <unknown>
#24 0x7fac38fb05b2 <unknown>
#25 0x7fac38fb25c9 <unknown>
#26 0x7fac38fc4814 <unknown>
#27 0x7fac38fae7b5 <unknown>
#28 0x7fac38d0421f <unknown>
#29 0x7fac381559a4 <unknown>
#30 0x7fac38155ee4 <unknown>
#31 0x7fac38155431 <unknown>
#32 0x7fac375e9454 QtWebEngine::processMain()
#33 0x000000400793 <unknown>
#34 0x7fac36526741 __libc_start_main
#35 0x0000004007e9 <unknown>
  r8: 0000000000000001  r9: 0000000000000000 r10: 0000000000000000 r11: 000000000000000f
 r12: 00001ac704e98160 r13: 0000000000000006 r14: 0000000000000000 r15: 0000060bc8610000
  di: 0000000000000000  si: 0000060bc8654aa8  bp: 0000000000000000  bx: 0000000000000000
  dx: 0000000000000006  ax: 0000060bc861d9e0  cx: 0000000000000ac0  sp: 00007fffcdcb6a88
  ip: 00007fac3890be65 efl: 0000000000010293 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000020
[end of stack trace]

Last edited by pb (2016-10-21 14:07:28)

Offline

#2 2016-06-26 17:13:29

krabat
Member
Registered: 2014-07-03
Posts: 40

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

FYI as for QupZilla the problem is discussed in https://github.com/QupZilla/qupzilla/issues/2008, upstream there's QTBUG-53928.

Offline

#3 2016-06-27 11:04:19

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

I'm sure that this crashing browsers (not only active cards, but browser at all) is one of at least few bugs in qt5-webengine. The other is i.e. not working of speeddial (in QupZilla or Otter-Browser), not working session restore... In KaOS SpeedDial was disabled in QupZilla 2.x...

Offline

#4 2016-06-27 11:34:56

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,117

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

pb wrote:

I'm sure that this crashing browsers (not only active cards, but browser at all) is one of at least few bugs in qt5-webengine. The other is i.e. not working of speeddial (in QupZilla or Otter-Browser), not working session restore... In KaOS SpeedDial was disabled in QupZilla 2.x...

Session restore works for me with Qupzilla 2.0.1/QtWebEngine 5.7.0

Offline

#5 2016-06-27 12:36:04

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

arojas wrote:

Session restore works for me with Qupzilla 2.0.1/QtWebEngine 5.7.0

I've just tried. I've right. On clean qupzilla profile it works. Even SpeedDial works again. Sorry for my fault. The main bug - crashing on some web pages - still egsist.

EDIT:
Earlier, with my old profile, after browser's crash, I've noticed this same bug as mantioned there: https://github.com/QupZilla/qupzilla/issues/2016. Maybe we should consider to add information, that after upgrade to qupzilla 2.x (build against of qt5-webengine 5.7) it's at least useful to create a new profile.

EDIT:
Hmmm.... it's rather Arch Linux' related problem with qt5-webengine 5.7.0. I've just checked the latest KaOS ISO with Qt5.7 and QupZilla 2.0.99 (it's rather KaOS' number then upstream, but it's responds to QupZilla 2.0.1) and everything works ok. QupZilla is build against of qt5-webengine 5.7.0. Raported page (http://caballodefuerza.blogspot.com/) works without crashes. The other, too.

EDIT:
Some more investications... smile I've tested openSUSE "Krypton" (it's a testing release with Plasma 5.6.95) and QupZilla crash on the page above. That it's rather not only Arch's issue...

EDIT:
Another one page where qt5-webengine's browsers crashes... dropbox.com smile

Last edited by pb (2016-07-01 11:42:38)

Offline

#6 2016-07-08 15:37:52

eddloschi
Member
Registered: 2014-04-12
Posts: 3

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

Hi all

After upgrading Qt from 5.6 to 5.7 I started experiencing the exact same issue on a project that I'm developing using QtWebEngine (the SEGV_MAPERR was on the same memory address).

I started investigating this as some other distros (i.e. KaOS) that already have Qt 5.7 don't have this issue as mentioned above.

It turns out it's GCC 6 fault. It's even stated on their changes page. The null pointer check optimization seems to break chromium's code.

Arch's QtWebEngine package does include two patches to disable this optimization but looks like the patch is missing something, but it does work partially (when compiled without those patches it crashes instantly).

So, I added

-fno-delete-null-pointer-checks

to CFLAGS and CXXFLAGS to /etc/makepkg.conf and rebuilt QtWebEngine and the crashes on my project and QupZilla are gone big_smile

This flag probably should be added to the PKGBUILD

Offline

#7 2016-07-08 21:58:55

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,117

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

eddloschi wrote:

This flag probably should be added to the PKGBUILD

Thanks a lot! Fixed in 5.7.0-2. We can finally move qupzilla 2.0 to stable.

Offline

#8 2016-07-09 06:03:47

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

Thanks a lot, too! QupZilla (and other qt5-webengine apps) working now.

Offline

#9 2016-07-17 08:24:00

gorki.b
Member
Registered: 2014-06-22
Posts: 15

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

Hi
Trying to start qupzilla.
In a freshly installed arch linux (without chrome or Chromium) I get this error message.

[0717/101650:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chrom … lopment.md for more information on developing with the sandbox on.
QupZilla: 0 extensions loaded
AdBlockSubscription:: loadSubscription invalid format of adblock file "/home/md/.config/qupzilla/profiles/default/adblock/customlist.txt"
nouveau: kernel rejected pushbuf: Datei oder Verzeichnis nicht gefunden
nouveau: ch5: krec 0 pushes 0 bufs 2 relocs 0
nouveau: ch5: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch5: buf 00000001 00000006 00000004 00000000 00000004
nouveau: kernel rejected pushbuf: Datei oder Verzeichnis nicht gefunden
nouveau: ch5: krec 0 pushes 0 bufs 2 relocs 0
nouveau: ch5: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch5: buf 00000001 00000006 00000004 00000000 00000004

All updates are installed.
What can or should I do.

Offline

#10 2016-07-17 09:59:29

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

Re: [SOLVED] Browsers wich use qt5-webengine 5.7 crashes on some pages

@gorki.b - Yours error is not the same that I mentioned. Qupzilla 2.x isn't even in testing, now. And it works or not?

Last edited by pb (2016-07-17 10:00:02)

Offline

Board footer

Powered by FluxBB