You are not logged in.

#1 2016-06-22 13:21:54

samotarnik
Member
Registered: 2016-06-22
Posts: 2

Sierra EM7455 not working

Hi everyone,
Arch newbie here.

I have a Lenovo Thinkpad T460s with Sierra EM7455 LTE module which I can't get to work. I've tried it via the ModemManager, the "Mobile Broadband" option shows up in the networkmanager applet in my gnome panel. I go through the settings, fill out the country and the provider, it even autodetects the proper APN.

When I then click on the new connection (configuration) in the menu to connect, nothing happens (visually) and it does not connect. Here's the journalctl output at that moment:

% sudo journalctl -xf
...
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1440] device (cdc-wdm0): Activation: starting connection 'T-Mobile Default' (d1ef0d5c-4360-43ea-839d-8223b3b56917)
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1456] audit: op="connection-activate" uuid="d1ef0d5c-4360-43ea-839d-8223b3b56917" name="T-Mobile Default" pid=809 uid=1000 result="success"
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1462] device (cdc-wdm0): state change: disconnected -> prepare (reason 'none') [30 40 0]
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1468] manager: NetworkManager state is now CONNECTING
Jun 22 11:24:27 wintermute ModemManager[373]: <info>  Simple connect started...
Jun 22 11:24:27 wintermute ModemManager[373]: <info>  Simple connect state (3/8): Enable
Jun 22 11:24:27 wintermute ModemManager[373]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (disabled -> enabling)
Jun 22 11:24:27 wintermute ModemManager[373]: Couldn't reload current power state: MBIM protocol error: NotOpened
Jun 22 11:24:27 wintermute ModemManager[373]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (enabling -> disabled)
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1755] (cdc-wdm0): modem state changed, 'disabled' --> 'enabling' (reason: user-requested)
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1756] (cdc-wdm0): modem state changed, 'enabling' --> 'disabled' (reason: unknown)
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1756] device (cdc-wdm0): state change: prepare -> disconnected (reason 'user-requested') [40 30 39]
Jun 22 11:24:27 wintermute NetworkManager[389]: <info>  [1466587467.1760] manager: NetworkManager state is now CONNECTED_LOCAL
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: (gnome-shell:809): libnm-glib-WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/4: No such interface 'org.freedesktop.DBus.Properties' on object at path /org/freedesktop/NetworkManager/ActiveConnection/4
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: (gnome-shell:809): libnm-glib-WARNING **: Device activation failed: Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/4' failed in libnm-glib.
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: (gnome-shell:809): Gjs-WARNING **: JS ERROR: Error: Argument 'path' (type utf8) may not be null
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: ensureActiveConnectionProps@resource:///org/gnome/shell/ui/status/network.js:107
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: NMConnectionDevice<._activeConnectionChanged@resource:///org/gnome/shell/ui/status/network.js:393
Jun 22 11:24:27 wintermute org.gnome.Shell.desktop[809]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
...

There's this "Couldn't reload current power state: MBIM protocol error: NotOpened" error but I don't know what it means. Following this topic, here's the output of some other commands on the system.

% uname -a          
Linux wintermute 4.6.2-1-ARCH #1 SMP PREEMPT Wed Jun 8 08:40:59 CEST 2016 x86_64 GNU/Linux

% sudo systemctl is-enabled ModemManager
enabled

% sudo systemctl is-active ModemManager
active

% lsusb | grep Sierra
Bus 001 Device 002: ID 1199:9079 Sierra Wireless, Inc.

% lsmod | grep cdc
cdc_mbim               16384  0
cdc_wdm                20480  2 cdc_mbim
cdc_ncm                28672  1 cdc_mbim
usbnet                 36864  2 cdc_mbim,cdc_ncm
usbcore               200704  12 btusb,uvcvideo,qcserial,usbserial,usbnet,cdc_mbim,usb_wwan,cdc_ncm,cdc_wdm,xhci_hcd,xhci_pci

% cat /sys/module/cdc_ncm/parameters/prefer_mbim
Y

% ls -l /dev/cdc*
crw------- 1 root root 180, 0 Jun 22 11:12 /dev/cdc-wdm0

% sudo mbimcli -d /dev/cdc-wdm0 --query-device-caps
[/dev/cdc-wdm0] Device capabilities retrieved:
	      Device type: 'remote'
	   Cellular class: 'gsm'
	      Voice class: 'no-voice'
	        Sim class: 'removable'
	       Data class: 'umts, hsdpa, hsupa, lte'
	         SMS caps: 'pdu-receive, pdu-send'
	        Ctrl caps: 'reg-manual'
	     Max sessions: '8'
	Custom data class: 'unknown'
	        Device ID: '014582000329590'
	    Firmware info: 'SWI9X30C_02.08.02.00'
	    Hardware info: 'EM7455'

% dmesg | grep wdm0
[   14.851309] cdc_mbim 1-2:1.12: cdc-wdm0: USB WDM device

% dmesg | grep cdc 
[   14.831759] usbcore: registered new interface driver cdc_ncm
[   14.846231] usbcore: registered new interface driver cdc_wdm
[   14.851309] cdc_mbim 1-2:1.12: cdc-wdm0: USB WDM device
[   14.851490] cdc_mbim 1-2:1.12 wwan0: register 'cdc_mbim' at usb-0000:00:14.0-2, CDC MBIM, 5a:c4:0a:1c:d1:c4
[   14.851510] usbcore: registered new interface driver cdc_mbim
[   14.934326] cdc_mbim 1-2:1.12 wwp0s20f0u2i12: renamed from wwan0

% rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Can anyone please help with this? Thanks.

Offline

#2 2016-06-22 17:08:57

samotarnik
Member
Registered: 2016-06-22
Posts: 2

Re: Sierra EM7455 not working

Here are some more shell command outputs, I've masked the phone number in the last command.

% sudo systemctl status NetworkManager
  ● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2016-06-22 15:40:57 CEST; 9min ago
   Main PID: 338 (NetworkManager)
      Tasks: 3 (limit: 512)
     Memory: 15.8M
        CPU: 266ms
     CGroup: /system.slice/NetworkManager.service
             └─338 /usr/bin/NetworkManager --no-daemon

  Jun 22 15:40:59 wintermute NetworkManager[338]: <info>  [1466602859.3059] device (docker0): state change: secondaries -> activated (reason 'none') [90 100 0]
  Jun 22 15:40:59 wintermute NetworkManager[338]: <info>  [1466602859.3060] manager: NetworkManager state is now CONNECTED_LOCAL
  Jun 22 15:40:59 wintermute NetworkManager[338]: <info>  [1466602859.3125] device (docker0): Activation: successful, device activated.
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.4780] (cdc-wdm0): modem state changed, 'disabled' --> 'enabling' (reason: user preference)
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.4787] manager: (cdc-wdm0): new Broadband device (/org/freedesktop/NetworkManager/Devices/4)
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.4790] device (cdc-wdm0): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.4793] device (cdc-wdm0): modem state 'enabling'
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.4804] device (cdc-wdm0): state change: unavailable -> disconnected (reason 'none') [20 30 0]
  Jun 22 15:41:00 wintermute NetworkManager[338]: <info>  [1466602860.6042] (cdc-wdm0): modem state changed, 'enabling' --> 'disabled' (reason: unknown)
  Jun 22 15:41:00 wintermute NetworkManager[338]: <warn>  [1466602860.6043] (cdc-wdm0) failed to enable modem: GDBus.Error:org.freedesktop.libmbim.Error.Status.Failure: Failure

% sudo systemctl status ModemManager  
  ● ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2016-06-22 15:40:57 CEST; 9min ago
   Main PID: 322 (ModemManager)
      Tasks: 5 (limit: 512)
     Memory: 9.9M
        CPU: 57ms
     CGroup: /system.slice/ModemManager.service
             ├─322 /usr/bin/ModemManager
             └─368 /usr/lib/libmbim/mbim-proxy

  Jun 22 15:40:57 wintermute ModemManager[322]: [/dev/cdc-wdm0] Read max control message size from descriptors file: 4096
  Jun 22 15:40:59 wintermute ModemManager[322]: <info>  Couldn't find support for device at '/sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0': not supported by any plugin
  Jun 22 15:40:59 wintermute ModemManager[322]: <info>  Couldn't find support for device at '/sys/devices/pci0000:00/0000:00:1f.6': not supported by any plugin
  Jun 22 15:40:59 wintermute ModemManager[322]: <info>  Creating modem with plugin 'Generic' and '2' ports
  Jun 22 15:40:59 wintermute ModemManager[322]: <info>  Modem for device at '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-2' successfully created
  Jun 22 15:40:59 wintermute ModemManager[322]: opening device...
  Jun 22 15:40:59 wintermute ModemManager[322]: [/dev/cdc-wdm0] Read max control message size from descriptors file: 4096
  Jun 22 15:41:00 wintermute ModemManager[322]: <info>  Modem: state changed (unknown -> disabled)
  Jun 22 15:41:00 wintermute ModemManager[322]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (disabled -> enabling)
  Jun 22 15:41:00 wintermute ModemManager[322]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (enabling -> disabled)

% mmcli -L                                       

Found 1 modems:
	/org/freedesktop/ModemManager1/Modem/0 [Generic] MBIM [1199:9079]

% mmcli -m /org/freedesktop/ModemManager1/Modem/0

/org/freedesktop/ModemManager1/Modem/0 (device id '9ef7cc6608398ca7ea804df938d601cdf23aa9cc')
  -------------------------
  Hardware |   manufacturer: 'Generic'
           |          model: 'MBIM [1199:9079]'
           |       revision: 'SWI9X30C_02.08.02.00'
           |      supported: 'gsm-umts, lte'
           |        current: 'gsm-umts, lte'
           |   equipment id: '014582000329590'
  -------------------------
  System   |         device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-2'
           |        drivers: 'cdc_mbim'
           |         plugin: 'Generic'
           |   primary port: 'cdc-wdm0'
           |          ports: 'cdc-wdm0 (mbim), wwp0s20f0u2i12 (net)'
  -------------------------
  Numbers  |           own : '+38599XXXXXXX'
  -------------------------
  Status   |           lock: 'none'
           | unlock retries: 'sim-pin2 (3)'
           |          state: 'disabled'
           |    power state: 'low'
           |    access tech: 'unknown'
           | signal quality: '0' (cached)
  -------------------------
  Modes    |      supported: 'allowed: 3g, 4g; preferred: none'
           |        current: 'allowed: 3g, 4g; preferred: none'
  -------------------------
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  -------------------------
  IP       |      supported: 'ipv4, ipv6, ipv4v6'
  -------------------------
  3GPP     |           imei: '014582000329590'
           |  enabled locks: 'fixed-dialing'
           |    operator id: 'unknown'
           |  operator name: 'unknown'
           |   subscription: 'unknown'
           |   registration: 'unknown'
  -------------------------
  SIM      |           path: '/org/freedesktop/ModemManager1/SIM/0'

  -------------------------
  Bearers  |          paths: 'none'

Offline

#3 2017-03-21 08:01:35

thip
Member
Registered: 2017-03-21
Posts: 1

Re: Sierra EM7455 not working

Did you ever make any progress with this? I'm having similar issues with pretty much identical outputs on a gen5 x1 carbon and it's driving me mad trying to fix it.

Offline

#4 2017-03-22 02:25:51

jmmec
Member
Registered: 2016-12-23
Posts: 5

Re: Sierra EM7455 not working

If you don't find the answer here, it would be good to post over at the Sierra Wireless forum - pretty certain someone over there will know the answer:

https://forum.sierrawireless.com/viewforum.php?f=117

Regards

Offline

#5 2017-04-28 12:51:29

cbarreholm
Member
Registered: 2017-04-28
Posts: 2

Re: Sierra EM7455 not working

I have similar problems on Ubuntu 16.04 with a Thinkpad T470p and Sierra EM7455.

This sounds like a good lead on a possible solution:
https://forums.lenovo.com/t5/Linux-Disc … -p/3344299

Offline

#6 2017-04-28 14:14:32

cbarreholm
Member
Registered: 2017-04-28
Posts: 2

Re: Sierra EM7455 not working

Boot Ubuntu 16.10 on USB and successfully connected the modem. I guess that new Modem Manager solves the problem, as suggested in my previous link.

Offline

Board footer

Powered by FluxBB