You are not logged in.

#1 2006-05-12 18:21:36

tlaloc
Member
From: Lower Saxony
Registered: 2006-05-12
Posts: 350

[solved] Cannot pacman -Syu

Hi,
even circumventing the mawk/gawk-problem, I cannot update. I always receive the error: libgphoto2 is corrupted.

Is that my problem or is something wrong with the package (which I cannot simply remove because of KDE dependencies, etc)?

Cheers, t.

Offline

#2 2006-05-12 18:24:03

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,546
Website

Re: [solved] Cannot pacman -Syu

Is this a new install of Arch or have you been running it for awhile before this error?
If this installation is not "new" did you run updates lately? Did you get any warnings or errors in the last update?

Offline

#3 2006-05-12 18:33:02

tlaloc
Member
From: Lower Saxony
Registered: 2006-05-12
Posts: 350

Re: [solved] Cannot pacman -Syu

It is an install I made in January, when 0.7.1 was released. I did an update every 1 or 2 weeks, and never had any problems.
Thanks for your interest, t.

Offline

#4 2006-05-12 18:39:51

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [solved] Cannot pacman -Syu

Do this first:

pacman -U http://ftp.heanet.ie/mirrors/ftp.archlinux.org/extra/os/i686/libgphoto2-2.1.6-6.pkg.tar.gz

That's my local mirror, and I can guarantee that it's not corrupt, because I've just done it myself.

Then go ahead with -Syu.

Offline

#5 2006-05-12 19:03:56

tlaloc
Member
From: Lower Saxony
Registered: 2006-05-12
Posts: 350

Re: [solved] Cannot pacman -Syu

Thank you, tomk - that did the trick. It is always fun to work with professionals. I am not a professional (with regard to Linux systems), and I'll be back with other problems  big_smile
Cheers, T.

Offline

#6 2006-05-12 20:05:15

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [solved] Cannot pacman -Syu

"professionals" - I like that. big_smile

Glad it worked out for you. If you have other problems, don't forget to search the forum and wiki first - many questions have been asked and answered already.

Offline

Board footer

Powered by FluxBB