You are not logged in.

#1 2006-05-13 18:09:57

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

automount (in gnome)

Hello! I'd like automount... I have installed hal and dbus, added hal and dbus in DAEMONS in rc.conf . But when I insert cd or a pendrive, it isn't mounted.
I have to go to 'computer' and click on the device, but i'd like that it is mounted in automatic, like ubuntu-way. In ubuntu, when you insert a cd, it opens a windows with the cd's content
It's possible to have the same on arch?

Offline

#2 2006-05-13 18:14:24

ingvildr
Member
From: Brighton, England
Registered: 2005-04-19
Posts: 203

Re: automount (in gnome)

do you have pmount?, that and look in the preferences menu i sware you can set auto mount there.

Offline

#3 2006-05-13 18:30:37

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

Re: automount (in gnome)

yes, i have pmount. What I have to do in preference menu? i don't see a tool for automount... sad

Offline

#4 2006-05-13 18:36:42

ingvildr
Member
From: Brighton, England
Registered: 2005-04-19
Posts: 203

Re: automount (in gnome)

should be under removable drives and media

Offline

#5 2006-05-13 19:58:53

Arkamririon
Member
From: Germany
Registered: 2005-12-27
Posts: 34

Re: automount (in gnome)

you must start the
gnome-volume-manager.
Best is to put it in System -> Settings -> Session -> Autostart Apps (not sure about the right english word, tried to translate the menues by myself)

Offline

#6 2006-05-13 20:26:39

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: automount (in gnome)

Arkamririon wrote:

you must start the
gnome-volume-manager.
Best is to put it in System -> Settings -> Session -> Autostart Apps (not sure about the right english word, tried to translate the menues by myself)

AFAIK gnome-volume-manager is started by gnome-session

Offline

#7 2006-05-13 21:01:45

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

Re: automount (in gnome)

Arkamririon wrote:

you must start the
gnome-volume-manager.
Best is to put it in System -> Settings -> Session -> Autostart Apps (not sure about the right english word, tried to translate the menues by myself)

yes, it's already set!


@ingvild: under removable drivers and media, i already set up...

Offline

#8 2006-05-14 07:12:12

Arkamririon
Member
From: Germany
Registered: 2005-12-27
Posts: 34

Re: automount (in gnome)

ok next try:

does the /media directory exists?
if not create it.

To get errormessages, kill the gnome-volume-manager process and start it in a terminal to get the output when pluggin in a usbstick.

Offline

#9 2006-05-14 07:28:47

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

Re: automount (in gnome)

# gnome-volume-manager

(gnome-volume-manager:14347): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

Offline

#10 2006-05-14 07:31:11

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

Re: automount (in gnome)

ok, perhaps i know the problem...
If I run gnome-volume-manager as root, it gives me the error: "(gnome-volume-manager:14347): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed."

but if i insert a pendrive, it is mounted correctly! but when i try to umount the device (click on the icon, under 'umount'), it appaers another error:

Error: device /dev/sda1 was not mounted by you


If I run gnome-volume-manager as user, it doesn't give me any error, but it isn't mounted!
Perhaps is a groups' error..

Offline

#11 2006-05-14 07:44:22

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: automount (in gnome)

Add yourself to the storage group

gpasswd -a username storage

Offline

#12 2006-05-14 07:54:39

lordalbert
Member
From: Italy
Registered: 2006-04-15
Posts: 33
Website

Re: automount (in gnome)

ok, thanx a lot! Now it works correctly!

Offline

Board footer

Powered by FluxBB