You are not logged in.

#1 2006-05-16 15:19:25

Titus
Member
From: Izmir
Registered: 2006-05-11
Posts: 120
Website

flash animations don't have sounds

i installed flashplayer and java corectly and they are workinf fine except sound when i entered th website with animations i can watch them but hear no sound.
how can i correct this mistake?


In a world without walls,who need windows?

Offline

#2 2006-05-16 15:46:12

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: flash animations don't have sounds

I noticed this problem recently on my work machine - it turned out it was because my audio chipset doesn't support hardware mixing, and so only one app could play at a time.  Since I always have a media player running, it locked /dev/dsp even if I hit 'stop', and so no audio could get through from flash.

I solved the problem by looking through the wiki and coming across this page: Allow multiple programs to play sound at once - I'm using the oss2jack method.

Offline

#3 2006-05-16 15:50:41

Titus
Member
From: Izmir
Registered: 2006-05-11
Posts: 120
Website

Re: flash animations don't have sounds

i don't use any other sound program while  i was trying the  flash animations, but my ex distro was ubuntu and i can play xmms and hear sounds but now i can't.
thanks lot for ur wiki page i'll look it  up.


In a world without walls,who need windows?

Offline

#4 2006-05-16 15:55:20

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: flash animations don't have sounds

cool! people are using my package! nobody is voting though...


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#5 2006-05-16 17:24:46

trapdoor
Member
Registered: 2005-03-27
Posts: 82
Website

Re: flash animations don't have sounds

You can also try

aoss firefox

(if you are using firefox)

Offline

#6 2006-05-16 17:26:54

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: flash animations don't have sounds

test1000, I just found out about and installed that stuff today. tongue  Give me time, I'm only one man, and I am at work!  heh

Offline

#7 2006-06-12 21:57:24

prim
Member
From: Wroclaw - Poland
Registered: 2006-05-10
Posts: 47

Re: flash animations don't have sounds

You need alsa-oss package.


Feel free to correct my English

Offline

#8 2006-06-13 03:01:53

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: flash animations don't have sounds

I had the same problem, and I also fixed it by starting the esd (eds in a term)


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#9 2006-06-13 05:56:46

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: flash animations don't have sounds

the simplest, most transparent solution is to just load the snd-pcm-oss and snd-mixer-oss modules.

these modules recreate the /dev entries that oss would use, and forward the connections to alsa. this way, applications compatible only with oss will still work in a modern alsa environment.

the aoss program does the same thing, but without creating the actual /dev nodes for everyone.

Offline

#10 2006-06-14 17:41:26

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: flash animations don't have sounds

@paranoos: yeah good luck getting that to work with all apps at the same time...


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#11 2006-06-14 21:01:54

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 785
Website

Re: flash animations don't have sounds

test1000 wrote:

@paranoos: yeah good luck getting that to work with all apps at the same time...

.....

works here.

Offline

#12 2006-06-15 17:05:51

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: flash animations don't have sounds

@codemac:
but it doesn't work in all cases. Unless theyve dramatically improved support and it just happens to have eluded me and the oss2jack author.


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#13 2006-06-15 19:58:41

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: flash animations don't have sounds

to clarify the discussion here, there are many, many soundcards out there, especially onboard chips, that don't support hardware mixing.

if you're one of the many unfortunates, you have to fiddle with alsa or sound daemons to enable software mixing, in order to get more than one application to play sound. but oss emulation doesn't play nice most of the time.

gentoo has a useful wiki entry, which may help. one of the things mentioned is getting the mixer to set a fixed samplerate for output, since many chips only support either 44.1kHz or 48kHz (more often the latter, I believe).

i'd imagine this would help most of you having problems still, so have a go at it, and report here. if it works, please append to our wiki.

Offline

#14 2006-06-17 13:17:22

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: flash animations don't have sounds

My ALSA plays different sound sources at the same time (using dmix). But I can't get any sound from Flash animations. Any tips?


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#15 2006-06-17 17:29:05

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: flash animations don't have sounds

look up.

from what I understand, flash doens't support alsa, just oss.

So, either run foss firefox

or load the approperiate modules.


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#16 2006-06-18 11:05:53

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: flash animations don't have sounds

Offline

#17 2006-06-18 13:55:02

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: flash animations don't have sounds

Yeah, using "aoss opera" solves it all.


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#18 2006-06-22 16:38:59

detto
Member
Registered: 2006-01-23
Posts: 510

Re: flash animations don't have sounds

Uhm... okay,

ive tried loading those oss modules

modprobe snd-pcm-oss
modprobe snd-mixer-oss

when i play a file in quodlibet and start a game (warsow) i have no sound in the game.
so i tried it with starting esd, bcoz i think quodlibet maybe needs it, so

sudo /etc/rc.d/esd start

was what i tried next, but after that one quodlibet just stops playing anything, also after restarting it and removing ~/.quodlibet folder/settings.

as mentioned earlier it should work with those oss modules loaded, but hell....it doesnt! sad  what should i do, what may i have overlooked?
thx in advance,
cheers,

detto

EDIT: just tried with another player, -> cmus.
its set to output through alsa, and its working smooth and as it should with games at the same time.

so the problem exists somewhere between: esd, quodlibet, gstreamer ?
would be nice if a helping hand would ... help big_smile  lol

sry for this thing called my-english-speaking :?

Offline

#19 2006-06-22 18:55:00

detto
Member
Registered: 2006-01-23
Posts: 510

Re: flash animations don't have sounds

Ok, dont matter, got it working now! tongue

Modules snd_pcm_oss and snd_mixer_oss are still loaded, so is esd daemon.

It came up to my mind reading something about the package gstreamer-plugins, ... somehow (dont remember exactly tongue ) i detected "gstreamer0.10-alsa" in pacman search, and THAT one did the trick. I guess, without esd running, quodlibet tried to access with oss, and it did, but no other program could play sounds then.
with esd running, its making its way through esd which is accessing alsa (with dmix), and everythings fine.
please please correct me, if im wrong here with this presumption! roll

best regards,
detto

Offline

#20 2006-06-25 08:23:40

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 802

Re: flash animations don't have sounds

Try moving ~/.macromedia so a new directory & contents gets created

Offline

Board footer

Powered by FluxBB