You are not logged in.

#1 2016-07-24 09:38:00

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

[kde-unstable] KDE Applications 16.08 beta

KDE Applications 16.08 beta is available for testing in the [kde-unstable] repo.

Ported to KF5 in this release: kdf, kolourpaint, cervisia

You need to have [testing] enabled. As usual, report packaging issues to bugs.archlinux.org with the [kde-unstable] label, and upstream issues to bugs.kde.org

Known packaging issues:
- Blogger support missing in blogilo (needs new libkgapi release)
- QR code support missing in kaddressbook (prison version needed is incompatible with Plasma)
- kde-l10n is not packaged, so translations will not be up to date.

Happy testing!

Offline

#2 2016-07-24 14:56:50

MrPeacock
Member
Registered: 2016-03-10
Posts: 17

Re: [kde-unstable] KDE Applications 16.08 beta

Hi Arojas,

as everytime thanks a lot for your passionate work!!!
This time i've problems with kde-pim. Kontact crashes after some seconds.

If i start kmail or akregator from konsole,  it is the same. I'm using nouveau. It seems
nouveau crashes:

org.kde.akonadi.ETM: first fetched collection: "Search"
nouveau: kernel rejected pushbuf: No such file or directory
nouveau: ch18: krec 0 pushes 0 bufs 2 relocs 0
nouveau: ch18: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch18: buf 00000001 00000006 00000004 00000000 00000004
*** Error in `kmail': double free or corruption (fasttop): 0x00007f1ff814fac0 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x6ed4b)[0x7f20a4654d4b]
/usr/lib/libc.so.6(+0x74546)[0x7f20a465a546]
/usr/lib/libc.so.6(+0x74d1e)[0x7f20a465ad1e]
/usr/lib/xorg/modules/dri/nouveau_dri.so(+0x4613df)[0x7f207372b3df]
/usr/lib/xorg/modules/dri/nouveau_dri.so(+0x46161e)[0x7f207372b61e]
/usr/lib/xorg/modules/dri/nouveau_dri.so(+0x4ef73f)[0x7f20737b97

...


nouveau:        0x20217000
nouveau:        0x000000df
nouveau:        0x1000f010
[0724/165231:ERROR:shared_memory_posix.cc(392)] close: Bad file descriptor
Unable to start Dr. Konqi

Maybe it depends on Mesa-1.0.1-2 update

regards

Offline

#3 2016-07-24 15:34:45

mis
Member
Registered: 2016-03-16
Posts: 234

Re: [kde-unstable] KDE Applications 16.08 beta

Konsole background transparency stopped working for me.

In  Settings -> Edit current profile -> Appearance  there is this message

Konsole was started before desktop effects were enabled. You need to restart Konsole to see transparent background.

No output if started from a terminal.

Maybe related to this (very old) bug?
https://bugs.kde.org/show_bug.cgi?id=320001

I tried restarting konsole and logout / login, but no luck.

Graphics driver: xf86-video-ati


Edit:
I'm not sure... is this an upstream bug?

Last edited by mis (2016-07-24 15:51:37)

Offline

#4 2016-07-24 15:41:38

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [kde-unstable] KDE Applications 16.08 beta

MrPeacock wrote:

Hi Arojas,

as everytime thanks a lot for your passionate work!!!
This time i've problems with kde-pim. Kontact crashes after some seconds.

If i start kmail or akregator from konsole,  it is the same. I'm using nouveau. It seems
nouveau crashes:

Probably https://bugreports.qt.io/browse/QTBUG-41242

Offline

#5 2016-07-24 17:34:21

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 849

Re: [kde-unstable] KDE Applications 16.08 beta

@arojas: what should be installed to get calendar applet akonadi plugin?
Thanks for your work, as always smile

Offline

#6 2016-07-24 17:35:59

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [kde-unstable] KDE Applications 16.08 beta

nierro wrote:

@arojas: what should be installed to get calendar applet akonadi plugin?
Thanks for your work, as always smile

kdepim-addons

Offline

#7 2016-07-25 02:51:03

MrPeacock
Member
Registered: 2016-03-10
Posts: 17

Re: [kde-unstable] KDE Applications 16.08 beta

no success on getting kontact to work...

i've done so far:

- downgrade mesa
- downgrade libdrm
- tried egl/glx
- opengl 2.0 / XRender
- compositor off

but i dunno why kontact still keeps crashing...

org.kde.akonadi.ETM: first fetched collection: "Search"
*** KMail got signal 11 (Exiting)
*** Dead letters dumped.
nouveau: kernel rejected pushbuf: Bad file descriptor
nouveau: ch17: krec 0 pushes 1 bufs 27 relocs 0
nouveau: ch17: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch17: buf 00000001 00000007 00000002 00000002 00000000
nouveau: ch17: buf 00000002 0000000a 00000002 00000002 00000000
nouveau: ch17: buf 00000003 0000000b 00000002 00000002 00000000
nouveau: ch17: buf 00000004 00000008 00000002 00000002 00000000
nouveau: ch17: buf 00000005 00000006 00000004 00000000 00000004
nouveau: ch17: buf 00000006 0000002d 00000002 00000000 00000002
nouveau: ch17: buf 00000007 0000002e 00000002 00000000 00000002
nouveau: ch17: buf 00000008 00000033 00000002 00000002 00000000

cheers

Offline

#8 2016-07-27 14:24:40

MrPeacock
Member
Registered: 2016-03-10
Posts: 17

Re: [kde-unstable] KDE Applications 16.08 beta

Hi,

as workaround

LIBGL_ALWAYS_SOFTWARE=1 kontact

works.
regards

Offline

Board footer

Powered by FluxBB