You are not logged in.

#1 2016-07-24 17:13:18

abramelin
Member
From: chroot /root/home/
Registered: 2016-07-24
Posts: 7

Wine won't Start battle.net or hearthstone (SOLVED!)

I have had wine and playonlinux both work with hearthstone flawlessly in the past on my linux mint. Now whenever I right click the hearthstone-setup.exe or the battlenet-setup.exe and try to start with wine, it will pull up the screen "starting battle.net" and load for a few seconds then completely close for no reason. This happened when I was trying to install it through playonlinux as well. They both downloaded the wine-mono and wine_gecko packages and still nothing. I went into winecfg and disabled dbghelp and added msvcp100 (native, builtin) and still the same problem.
The playonlinux error said "error in POL shortcut for battle.net" and I have had this error before on my old distro (not saying it has anything to do with Arch or any distro) but then I would try it with Wine and it would either work for wine or pol if not both.
Please help.

EDIT: I am running both latest versions of wine and pol. wine is 1.9.14

Last edited by abramelin (2016-07-30 08:51:24)

Offline

#2 2016-07-24 22:28:54

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Last time something like this happened to me (about a week ago), I restarted the system.
I'm not using PoL, I'm using wine from the official repos on a 32-bit Arch.

Offline

#3 2016-07-25 01:27:14

JohnBobSmith
Member
From: Canada
Registered: 2014-11-29
Posts: 804

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

abramelin wrote:

...
Now whenever I right click the hearthstone-setup.exe or the battlenet-setup.exe and try to start with wine, it will pull up the screen "starting battle.net" and load for a few seconds then completely close for no reason. ... but then I would try it with Wine and it would either work for wine or pol if not both.

You seem to contradict yourself and as such I have no idea what the issue is... Do your programs behave as expected right now?

Last edited by JohnBobSmith (2016-07-25 01:27:33)


I am diagnosed with bipolar disorder. As it turns out, what I thought was my greatest weakness is now my greatest strength.

Everyday, I make a conscious choice to overcome my challenges and my problems. It's not easy, but its better than the alternative...

Offline

#4 2016-07-25 12:59:54

ColdPie
Member
Registered: 2007-09-18
Posts: 47

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Try installing corefonts with winetricks.

Offline

#5 2016-07-27 04:38:58

abramelin
Member
From: chroot /root/home/
Registered: 2016-07-24
Posts: 7

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

JohnBobSmith, I was explaining how on a previous distro, either "wine" or "pol" would work. If one wouldn't perform correctly then the other would. On my Arch install neither will work. Sorry if my wording and explanation was vague, I have trouble voicing my thoughts sometimes because I am thinking of multiple things all at once.

ColdPie, I have installed corefonts.

karol, simply restarting my computer is not a decent solution in my opinion. Although I have restarted the laptop since the problem, and I appreciate your suggestion.

I believe it is a memory problem for my gpu. My gpu is operating on 4MB of memory (I don't know how this happened). I have used wine before successfully on any games and gotten them to work, but for some reason my memory for the gpu is so low.. It should be 128 or 256 for my "video memory size". I don't know how to resize my video memory to something acceptable like 128 or 256. I have looked around but couldn't find any info on this.
I would like to try resizing first before trying to find another possible solution.
I apologize for not replying sooner. I had become frustrated with this and decided to not think about it for a few days.

EDIT: I am using xf86-video-intel and xorg

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 146d
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 31
    Region 0: Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 4050 [size=8]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

I am not sure at all but isn't Region 0 supposed to be 256? I'm going off info from an unreliable source that this may be the problem?
However if this has nothing to do with it and it is correct, then I am back to square one and don't have any solutions.

Last edited by abramelin (2016-07-27 05:12:16)

Offline

#6 2016-07-27 08:46:42

Omar007
Member
Registered: 2015-04-09
Posts: 317

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Afaik that value should be fine. FYI, that does not show you the amount of memory of the GPU though, it shows the amount of your RAM that is mapped to the GPU.
Idk the current stance of Arch on xf86-video-intel but I've heard that it may be deprecated and is being dropped by several distributions in favour of xf86-video-modesetting.

From what I understand there are a few things to keep in mind for the Battle.NET launcher. See https://appdb.winehq.org/objectManager. … &iId=28855 and try the fonts and/or troubleshooting steps on said page.

Offline

#7 2016-07-27 13:23:12

ColdPie
Member
Registered: 2007-09-18
Posts: 47

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Offline

#8 2016-07-27 13:24:25

Art3mk4
Member
From: Russia
Registered: 2014-06-17
Posts: 2

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Try

 winetricks vcrun2015 

this helped for me.

Offline

#9 2016-07-27 13:45:34

JohnBobSmith
Member
From: Canada
Registered: 2014-11-29
Posts: 804

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

POL can check/set the video memory under the display tab after clicking configure for your virtual drive. The wine registry editor key you want (use as last resort! may break something!) is HKCU/Software/Wine/Direct3D with a string value VideoMemorySize. Set this to the integer value which corresponds to the amount of memory on your video card. So I would use 512 for me. You can use lspci combinations to check the size of your video memory.

Good luck!


I am diagnosed with bipolar disorder. As it turns out, what I thought was my greatest weakness is now my greatest strength.

Everyday, I make a conscious choice to overcome my challenges and my problems. It's not easy, but its better than the alternative...

Offline

#10 2016-07-30 08:51:02

abramelin
Member
From: chroot /root/home/
Registered: 2016-07-24
Posts: 7

Re: Wine won't Start battle.net or hearthstone (SOLVED!)

Thank you all for your help and suggestions! It has benefited me a lot. I now have battle.net working as of right now. Used this newest comment on the WineHQ
"As of July 29 2016

Battle.net Patch 1.4.3 Build 7730

Wine 1.9.15

These steps are required:

    Install Core TTF Fonts from Microsoft

    Arch: aur/ttf-ms-fonts

    Debian/Ubuntu: contrib/ttf-mscorefonts-installer

    openSUSE: fetchmsttfonts

    Reboot may be necessary for changes to take effect.

    Alternatively you can install corefonts using winetricks

    winetricks corefonts

    Open winecfg. Go to Libraries tab and add libraries with default (native, builtin) setting

    api-ms-win-crt-runtime-l1-1-0.dll

    api-ms-win-crt-stdio-l1-1-0.dll

    ucrtbase.dll

    vcruntime140.dll

    Alternatively you can install vcrun2015 using winetricks

    winetricks vcrun2015

    Download latest Battle.net installer
    Install Battle.net"

https://appdb.winehq.org/objectManager. … &iId=28855

Arch people are the cool kids in internet land. I will now go play hearthstone thanks to you guys and gals smile

Offline

Board footer

Powered by FluxBB