You are not logged in.

#1 2016-08-14 00:07:00

Registered: 2011-10-30
Posts: 32

SOLVED: Syba ASMedia ASM1061 SATA3 card boots to a blank screen

I just bought a Syba ASMedia ASM1061 SATA3 / USB3 card Link is here

I was wanting to use the 2 internal SATA3 ports for some SSDs. However when I attach any SSD to any of the ports of this card my boot stops at a blank screen with a flashing cursor in the top left of the screen (even if my boot drive is on the motherboard SATA socket). I have no idea how to start diagnosing this. It's just like X fails to launch and no login manager shows. Remove the SSD and PC boots as normal!

lspci -vv shows

04:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01) (prog-if 01 [AHCI 1.0])
	Subsystem: ASMedia Technology Inc. Device 1060
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 38
	Region 0: I/O ports at d050 [size=8]
	Region 1: I/O ports at d040 [size=4]
	Region 2: I/O ports at d030 [size=8]
	Region 3: I/O ports at d020 [size=4]
	Region 4: I/O ports at d000 [size=32]
	Region 5: Memory at fa210000 (32-bit, non-prefetchable) [size=512]
	Expansion ROM at fa200000 [disabled] [size=64K]
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0f00c  Data: 4123
	Capabilities: [78] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [80] Express (v2) Legacy Endpoint, MSI 00
		DevCap:	MaxPayload 512 bytes, PhantFunc 0, Latency L0s <1us, L1 <8us
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr+ UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
		LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM not supported, Exit Latency L0s <512ns, L1 <2us
			ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Range ABC, TimeoutDis+, LTR-, OBFF Not Supported
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
		LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
			 EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
	Capabilities: [100 v1] Virtual Channel
		Caps:	LPEVC=0 RefClk=100ns PATEntryBits=1
		Arb:	Fixed- WRR32- WRR64- WRR128-
		Ctrl:	ArbSelect=Fixed
		Status:	InProgress-
		VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
			Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=01
			Status:	NegoPending- InProgress-
	Kernel driver in use: ahci
	Kernel modules: ahci

Strange thing is that I have this same card installed in a HP N40L microserver running XPEnology and it works just fine.

Can someone offer me any advice as to either what the problem might be or how to go about finding out what the issue is with the failure to get to a login manager?

Thank you.

EDIT: well the only solution I could come up with was, that 1 of the 2 SSDs attached to the card was my normal system SSD and the other was an old copy of my system disk (which I was using as "blank"). For some reason the normal system SSD did not like the older copy alongside it. Possibly some mix up with disk IDs. When I removed the old SSD from the card, it booted normally.

I'm nearly sure I tried this several times before but hey.... it works now.

Last edited by PTBM133A4X (2016-08-14 18:01:38)

Arch x86_64 as of 01/01/2013


#2 2017-12-12 14:18:01

From: Finland
Registered: 2009-11-08
Posts: 28

Re: SOLVED: Syba ASMedia ASM1061 SATA3 card boots to a blank screen

Bought similar hardware from aliexpress. And experiencing very similar problem. Boot hangs and doesnt work. Tried to boot straight from ssd that i have windows installed and it hangs. UEFI seems to detect hardware atleast at some level fine and i get typical Sata controller boot screen while starting machine.

My card is installed on 3rd 4x 2.0 PCIE-slot. Motherboard x370 Prime pro. Have 2 separate GPU in first and 2nd slot.


Board footer

Powered by FluxBB