You are not logged in.

#1 2016-08-14 13:48:28

Nyamuk
Member
Registered: 2016-08-14
Posts: 16

[SOLVED] can't install package after downgrade libcrypt

i have error when play dota,
i find in forum to downgrade libcrypt to 1.6.5 with command "sudo pacman -U libgcrypt"
after downgrade libcrypt to 1.6.5 i can play dota, but if i can't install any package
i better can't play dota

i usually install with -S "that is first time i use -U"

then i try to install package, but it give me error

invalid or corrupted package (pgp signature)

i search again, and find some way
sudo pacman -S archlinux-keyring

warning: Public keyring not found; have you run 'pacman-key --init'?
error: GPGME error: Invalid crypto engine
error: archlinux-keyring: missing required signature
:: File /var/cache/pacman/pkg/archlinux-keyring-20160402-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

then i try
[nyamuk@nyamuk ~]$ sudo pacman-key --init
gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)
chmod: cannot access '/etc/pacman.d/gnupg/trustdb.gpg': No such file or directory
gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)
gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)
==> Updating trust database...
gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)
==> ERROR: Trust database could not be updated.

i realize this happen because i downgrade "libgcrypt"

i want upgarde libgcrypt with sudo pacman -Syu but it give me error like when i try to install package

is there a way to fix this?
can i use live cd to fix it?

i find this
Boot from the install disk and completely update your system using pacman's --root option. Or turn off signature checking temporarily.
Partial updates strike again.

what mean by partial updates?
and how to do pacman -root option from live cd?

am i need to mount then chroot?

Last edited by Nyamuk (2016-08-14 14:17:55)

Offline

#2 2016-08-14 13:52:09

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,903
Website

Re: [SOLVED] can't install package after downgrade libcrypt

Nyamuk wrote:

i find in forum to downgrade libcrypt to 1.6.5 with command "sudo pacman -U libgcrypt"

Where did you find this?  For this to do anything at all, you must have had a file called "libgcrypt" in your current working directly.  Where did you get this file?  Why does it not end in .pkg.tar.xz like an arch package should?

To undo the first thing you broke, you may be able to find the most recent libcrypt package in your cache and install that: `pacman -U /var/cache/pacman/pkg/libcrypt-someversion.pkg.tar.xz`.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2016-08-14 14:03:55

Nyamuk
Member
Registered: 2016-08-14
Posts: 16

Re: [SOLVED] can't install package after downgrade libcrypt

Where did you find this?  For this to do anything at all, you must have had a file called "libgcrypt" in your current working directly.  Where did you get this file?  Why does it not end in .pkg.tar.xz like an arch package should?

from the forum, where i find the solution to downgrade, i get this file for 64bit
libgcrypt-1.6.5-1-x86_64.pkg.tar.xz
then i sudo pacman -U libgcrypt in that directory
downgrade look fine, then i open steam play dota, that working

To undo the first thing you broke, you may be able to find the most recent libcrypt package in your cache and install that: `pacman -U /var/cache/pacman/pkg/libcrypt-someversion.pkg.tar.xz`.

i try this, i can upgrade libcrypt i think, i try to sudo pacman-key --init
it look fine

then i try, sudo pacman -Syu

downloading required keys...
error: key "A6234074498E9CEE" could not be looked up remotely
error: key "5C2E46A0F53A76ED" could not be looked up remotely
error: key "786C63F330D7CB92" could not be looked up remotely
error: key "AFF5D95098BC6FF5" could not be looked up remotely
error: key "7A4E76095D8A52E4" could not be looked up remotely
error: key "39E4B877E62EB915" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

i find in other post, i need to reinstall archlinux-keyring
i fail because i can't install package
then i try to install archlinux-keyring with pacman -U /var ... (same when i try to upgrade libgcrypt to 1.7)

still try install package

yeah, i can packer -S hollywood big_smile
thanks, and thanks for your fast respond smile

Last edited by Nyamuk (2016-08-14 14:17:28)

Offline

Board footer

Powered by FluxBB