You are not logged in.

#1 2006-05-21 08:53:23

From: DK
Registered: 2004-03-09
Posts: 96

ndiswrapper and irq-problems


A few days ago i updated ndiswrapper, and after next reboot my wpa-encrypted wireless connection wouldn't start... So i dug up a cable, and tried to google for a fix. First fix was that wpa_supplicant now should use a new interface to ndiswrapper ("-Dwext" instead of "-Dndiswrapper"). But then i found out that i was getting a IRQ error in the system log:

ndiswrapper version 1.16 loaded (preempt=yes,smp=yes)
ndiswrapper: driver tnet1130 (Texas Instruments,12/01/2004, loaded
PCI: Found IRQ 5 for device 0000:00:0b.0
ndiswrapper: using irq 5
irq 5: nobody cared (try booting with the "irqpoll" option)
 [<c014ab24>] __report_bad_irq+0x24/0x90
 [<c014ac2f>] note_interrupt+0x9f/0x260
 [<c014a43d>] handle_IRQ_event+0x3d/0x70
 [<c014a56d>] __do_IRQ+0xfd/0x110
 [<c0105b49>] do_IRQ+0x19/0x30
 [<c0103c56>] common_interrupt+0x1a/0x20
 [<c010f604>] delay_tsc+0x14/0x20
 [<d8f8512f>] KeStallExecutionProcessor+0xf/0x20 [ndiswrapper]
 [<d8f9b5fa>] miniport_init+0xaa/0x140 [ndiswrapper]
 [<d8f9ca8c>] NdisDispatchPnp+0x9c/0x92c [ndiswrapper]
 [<d8f95d98>] IoAllocateIrp+0x48/0x60 [ndiswrapper]
 [<d8f941b0>] get_current_nt_thread+0xd0/0xe0 [ndiswrapper]
 [<d8f96088>] IoQueueThreadIrp+0x18/0x100 [ndiswrapper]
 [<d8f95606>] IofCallDriver+0x36/0x70 [ndiswrapper]
 [<d8f97706>] IoSendIrpTopDev+0xb6/0x130 [ndiswrapper]
 [<d8f96ad1>] IoGetAttachedDevice+0xa1/0xb0 [ndiswrapper]
 [<d8f978de>] pnp_start_device+0x4e/0xc0 [ndiswrapper]
 [<d8f97d8c>] wrap_pnp_start_device+0x1bc/0x210 [ndiswrapper]
 [<c023f543>] pci_device_probe+0x63/0x80
 [<c029f6b4>] driver_probe_device+0x54/0xf0
 [<c029f7d0>] __driver_attach+0x0/0x80
 [<c029f841>] __driver_attach+0x71/0x80
 [<c029ea4d>] bus_for_each_dev+0x5d/0x80
 [<c029f525>] driver_attach+0x25/0x30
 [<c029f7d0>] __driver_attach+0x0/0x80
 [<c029ee1c>] bus_add_driver+0x8c/0x180
 [<d8f97f10>] wrap_pnp_resume_pci_device+0x0/0x30 [ndiswrapper]
 [<c023f060>] __pci_register_driver+0x80/0xc0
 [<c01616b1>] vmalloc+0x21/0x30
 [<d8f88a09>] register_devices+0x349/0x5c0 [ndiswrapper]
 [<d8f89543>] wrapper_ioctl+0x1f3/0xc20 [ndiswrapper]
 [<c017eb73>] __link_path_walk+0xbc3/0xf90
 [<c018c2ed>] mntput_no_expire+0x1d/0x80
 [<c017efc0>] link_path_walk+0x80/0x100
 [<c01825e0>] filldir+0x0/0xd0
 [<c01825e0>] filldir+0x0/0xd0
 [<c0140b9e>] debug_mutex_add_waiter+0x3e/0xc0
 [<c0182523>] vfs_readdir+0x73/0xc0
 [<c012b3cd>] current_fs_time+0x5d/0x80
 [<c01820de>] do_ioctl+0x8e/0xa0
 [<c018214d>] vfs_ioctl+0x5d/0x320
 [<c0182498>] sys_ioctl+0x88/0xa0
 [<c010322f>] sysenter_past_esp+0x54/0x75
[<d8f8ec50>] (ndis_isr+0x0/0xf0 [ndiswrapper])
Disabling IRQ #5
wlan0: vendor: 'TNET1130'
wlan0: ndiswrapper ethernet device 00:4f:62:04:30:bd using driver tnet1130, 104C
wlan0: encryption modes supported: WEP; TKIP with WPA

I google'd some more and tried to add "apci=off noapic" to my boot options, but no succes... Since I haven't seen this error before the udgrade the other day, i'm bound to think it has somthing to do with the recent update. I've tried downgrading ndiswrapper but no luck. The wireless connection still works fine under windows, so it's a linux problem sad
If anyone has some advice, it will be greatly appreciated!


Board footer

Powered by FluxBB