You are not logged in.

#1 2016-09-01 12:25:14

PootisBird
Member
Registered: 2014-04-16
Posts: 123

[SOLVED]systemctl status is not in an agreement with dmesg

I have one thing bugging me with my system. Systemctl shows that process is ok and running with exit code 0 while dmesg shows exit code 1.

systemctl status systemd-vconsole-setup.service
● systemd-vconsole-setup.service - Setup Virtual Console
   Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static; vendor preset: disabled)
   Active: active (exited) since czw 2016-09-01 14:10:54 CEST; 2min 48s ago
     Docs: man:systemd-vconsole-setup.service(8)
           man:vconsole.conf(5)
  Process: 182 ExecStart=/usr/lib/systemd/systemd-vconsole-setup (code=exited, status=0/SUCCESS)
 Main PID: 182 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/systemd-vconsole-setup.service
dmesg | grep vconsole
[    0.567696] systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
[    0.568467] systemd[1]: systemd-vconsole-setup.service: Unit entered failed state.
[    0.568473] systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.
/etc/vconsole.conf
FONT=Lat2-Terminus16
FONT_MAP=8859-2
KEYMAP=pl
localectl status
System Locale: LANG=pl_PL.UTF-8
       VC Keymap: pl
      X11 Layout: pl

Polish special characters are working fine with dmesg error.
I'm using Nvidia drivers, If I switch to nouveau then backspace is not working properly in TTY.
If I disable FONT_MAP then I get no error but special characters are not working.

Last edited by PootisBird (2016-09-01 12:44:32)

Offline

#2 2016-09-01 12:45:22

PootisBird
Member
Registered: 2014-04-16
Posts: 123

Re: [SOLVED]systemctl status is not in an agreement with dmesg

Turns out that "sd-vconsole" hook in /etc/mkinitcpio.conf is unnecessary.

Offline

Board footer

Powered by FluxBB