You are not logged in.

#1 2016-09-14 00:39:40

Fuentes
Member
Registered: 2011-08-01
Posts: 19

[SOLVED] Can't connect to samba share after update Samba to 4.5.0-2

Hi everyone:

Today i updated my arch vbox with sudo pacman -Syu as usual. After rebooting to test the changes i checked the dmesg log and the journal and all seems to be ok. Then when i tried to connect from the Windows 7 that host the Arch guest the crendentials dialog showed up. I wrote the info, but the dialog showed again and again without accepting my credentials.

I spent the whole day trying to fix this issue with no avail. All seems to be ok: NBMD and WINBINDD resolves the local and remote names, i connect using ssh shell to the virtual machine and all runs smoothly. I can mount from the Arch gest to the Windows host using mount.cifs, but when i try to connect from the windows host to the arch guest, the auth credentials are not accepted.

Any hint to this issue?
Many thanks in advance.

PS: I tried to downgrade samba but i receive reference errors: "... reference to the samba-4.5.0..." and i don't know hot to solve this.

Last edited by Fuentes (2016-09-14 05:03:19)

Offline

#2 2016-09-14 05:09:25

Fuentes
Member
Registered: 2011-08-01
Posts: 19

Re: [SOLVED] Can't connect to samba share after update Samba to 4.5.0-2

In Samba 4.5 the NTLMv1 support has been disabled by default (https://www.samba.org/samba/history/samba-4.5.0.html), so if you use an old client like my windows 7, the auth process fails miserably.

I had two options to solve this:

- Enable NTLMv1 in Samba
- Change the default encription level in Windows

I decided to change Samba.
Salute to everyone!

Last edited by Fuentes (2016-09-14 05:10:36)

Offline

Board footer

Powered by FluxBB