You are not logged in.

#1 2006-05-24 02:33:19

Registered: 2006-05-10
Posts: 8

xgl + compiz not so easy to setup.. i dont think

So i am now for the 2nd night in a row trying to get xgl + compiz running and am failing misserably.

so anywho, here's the low-down.
Gnome 2.14
latest fglrx drivers (ATi Mobility Radeon 9700)

i edited my gdm custom.conf so that 1=Xgl and then Xgl is defined as


name=Standard server
command=/usr/bin/Xgl :1 -ac -accel xv:pbuffer -accel glx:pbuffer

also setup a compizrc as explained in the wiki and added it to the list of things to start up on loging into gnome. at which point i rebooted. at first there was a littel lag, not as with the normal server, so i thought maybe it loaded, and perhaps xgl did load, just not compiz so i can't see any of the benefits (also its really slow, way too slow, i know its supposed to be faster) so i know something isn't right. so anyway, when i logged in it failed to load up gnome-window-decorations, so i deleted conpizrc and logged out and in once again. great, windows ahve borders now smile but obviously compiz is not loaded.

i also tried doing it way #2 (by adding a .desktop file in sessions folder and ahve it load up, failed as well). i noticed the wiki is a work in progress and has several huge errors (for example the location of custom.conf).

so....what am i doing wrong? what do i need to do to make it right?


#2 2006-05-24 05:35:10

From: Oxford, UK
Registered: 2005-11-03
Posts: 674

Re: xgl + compiz not so easy to setup.. i dont think

Make sure that gnome is reading your conf file:

cd /opt/gnome/etc/gdm/ && cp custom.conf gdm.conf

That's just a minor point...

The biggest problem I had with Xgl was caused by confliction between loading plugins through the command line and loading them through gconf-editor. Some things worth trying are:

o Editing /usr/bin/startxgl and removing 'gconf gconf-dump' from the 'compiz --replace' line
o Alternatively, in the same line leave 'gconf' and remove the other plugin names - if you do this and can get into gconf-editor somehow, maybe by normal 'startx', check there isn't a 'dock' entry in the list under apps/compiz/general/... ; if there is, remove it

It's a tricky bugger, that's for sure; I still don't know for sure how to make it work myself, and I've been playing around with it for ages now!

Before you worry about GDM, try getting it to work with the startxgl command. If that doesn't work, GDM hasn't got a chance.

Remember that the command is  startxgl [display_number] gnome [ati / nvidia] , so for example, I run 'startxgl 1 gnome ati'. Note also that the display number can make the difference between it working or not - display 1 often works for me when I'm playing around with Xgl, while display 0 doesn't.

Keep us posted, we're here to help wink

.oO Komodo Dave Oo.


#3 2006-05-24 23:56:04

Registered: 2006-05-10
Posts: 8

Re: xgl + compiz not so easy to setup.. i dont think

yeah tried what you said, still no luck. so what i did for now is just totally disable xgl (pretty much undid everything except uninstall the compiz packages) so i am at least in a normal non-laggy operative environment. i am not gonna give xgl another run till somebody actually figures out how to make that thing run.


Board footer

Powered by FluxBB