You are not logged in.

#1 2006-05-24 08:49:33

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

problems starting X

Hello,

I'm kinda noobish, since I'm only experimenting for a month or 2 with Linux, but I've managed to install Arch with the 0.7.1-cd on an old laptop (and tweaking it a little with the wiki and forumposts as my guide).

Yesterday I decided to reinstall it completely to see if I could call my self 'able to install ArchLinux' - I failed sad

I used the 0.7.1-cd again and tried the FTP-install first, but my PCMCIA-card would not be recognised by the system and modprobing the correct driver was also not sufficient to make it work (afterwards I read about other required steps to manually configure my NIC...)

So, I did the 0.7.1 install from CD and this worked quite beautifully smile - I immediately pacman -Syu'd me into Gimmick and installed all the packages I had installed before, including xorg, xf86-video-neomagic, gnome, gdm, hwd.

I did

# hwd -u
# hwd -x
# cp /etc/X11/xorg.conf.hwd /etc/X11/xorg.conf

and tried to startx - no dice.

Upon inspecting my brand new xorg.conf, I found out there was no graphics card identified and several other settings were wrong: kbd-layout, but more importantly: my mouse was installed as /dev/psaux instead of /dev/input/mouse0...

After correcting these mistakes, startx gave me an error like:

"No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes = 16"

and an xkbcomp-warning that supposedly is "not fatal to the X server".

Whatever I tried, I could not get this to go away, and found several other people having this error, but no solutions were found.

So I switched to xorgconfig to make me a new xorg.conf, and with this I was able to get rid of the GLX-error. The non-fatal warning remained however and X does not start, leaving me in the log only this warning:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

Google advised me to look at my kbdlayout (which is "be") and kbdmodel (which was "pc105", but changing it to "thinkpad" as it was in my debian-days didn't help).

Anyone? I'm kinda hoping this has got something to do with the upgrade to Gimmick, since I traced my steps back with the notes I've been making during my previous install and this one, but I cannot find the problem.

Anyone?

THX!

Zl.
/EDIT: I'm typing this out of the top of my head from another computer, and I just remembered there is another warning:

FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing

(I copied this error from google, so it might be another path in my specific case) - Maybe this is the culprit? I also remember commenting out some paths to fonts in the xorg.conf to make the list in xorg.conf resemble the different font dirs on my system (some automatically added dirs were not present onmy system)

Offline

#2 2006-05-24 09:52:55

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 799

Re: problems starting X

The 0.7.2 CD has just been released - ftp, base, or full. May be worth burning one of those and trying again.

Try and save your pacman cache so you don't need to download all the packages you have that are uptodate

Offline

#3 2006-05-24 19:10:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: problems starting X

The freefontpath error has been present since we switched to Xorg 7, and hasn't harmed anyone.
Besides, it only comes up when you shut down X11.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB