You are not logged in.

#1 2016-09-24 15:31:57

nesk
Member
Registered: 2011-03-31
Posts: 169

[Solved, sort of] Libvirt not reading OVMF options in qemu:///session

I'm trying to start a VM with UEFI in VIrtual Manager, following workaround from Wiki
I built OVMF from ABS, copied files to /vms/UEFI_OVMF_win7/ and added this to /etc/libvirt/qemu.conf:

nvram = [
    "/vms/UEFI_OVMF_win7/OVMF_CODE.fd:/vms/UEFI_OVMF_win7/OVMF_VARS.fd"
]

and restarted libvirtd daemon (# systemctl stop libvirtd, # systemctl start libvirtd). Checked with ps - there were no leftover libvirtd processes from root or regular user. Directory /vms/UEFI_OVMF_win7/ is accessible and owned by regular user.

Now, if I try to create a new VM in qemu:///system, it does give me an option of UEFI:
fHvXlrc.png
But in qemu:///session it says UEFI not found:
4VUvXMx.png

Anyone else had this problem? I thought a user-specific qemu.conf might be in order, but I can't find any info on where to place it or if user-specific qemu.conf files are even a thing in libvirt.

Last edited by nesk (2016-09-25 09:49:23)


My minimalist setup (WIP): TTY on second GPU, startx, i3, dunst, neomutt, ranger, newsboat

Offline

#2 2016-09-25 09:51:49

nesk
Member
Registered: 2011-03-31
Posts: 169

Re: [Solved, sort of] Libvirt not reading OVMF options in qemu:///session

Found a passing mention of ~/.config/libvirt/qemu.conf in this bug report https://github.com/vagrant-libvirt/vagr … issues/272.
Created ~/.config/libvirt/qemu.conf, put the nvram entry into it and now it works.


My minimalist setup (WIP): TTY on second GPU, startx, i3, dunst, neomutt, ranger, newsboat

Offline

Board footer

Powered by FluxBB