You are not logged in.

#1 2004-01-03 20:43:34

BashfulBruce
Member
From: Milton Keynes,UK
Registered: 2003-11-22
Posts: 10

Can't get sound to work - no /dev/dsp !!!

I could really do with some help here, this is the first time I have tried to get sound working under linux. I am using a Abit VT6X4 board with on-board sound (VT82C686A) AC97 compliant chipset. I am using Kernel 2.6 which uses the config from the 2.6 package but with added SCSI support. I created the audio group as per FAQ but with ^snd as well as ^sound in the devfsd.conf. I installed all of the ALSA packages, I added snd_via82xx and snd-pcm-oss to /rc.conf, I added the following to /etc/modules.conf

# ALSA portion
        alias char-major-116 snd
        alias snd-card-0 snd-via82xx
        # module options should go here

        # OSS/Free portion
        alias char-major-14 soundcore
        alias sound-slot-0 snd-card-0

        # card #1
        alias sound-service-0-0 snd-mixer-oss
        alias sound-service-0-1 snd-seq-oss
        alias sound-service-0-3 snd-pcm-oss
        alias sound-service-0-8 snd-seq-oss
        alias sound-service-0-12 snd-pcm-oss


When I login (as user or root) I get the dreaded no dev/dsp error.
Now if I ls -la in /dev, I see no dsp file/directory, however, if i touch /dev/dsp I get an access denied error (as root).
If I lsmod I get the following listed, so the modules appear to load ok.

snd_pcm_oss            49412  0
snd_mixer_oss          17056  1 snd_pcm_oss
snd_via82xx            22688  0
snd_pcm                91168  2 snd_pcm_oss,snd_via82xx
snd_timer              22532  1 snd_pcm
snd_ac97_codec         52900  1 snd_via82xx
snd_page_alloc          9220  2 snd_via82xx,snd_pcm
snd_mpu401_uart         6432  1 snd_via82xx
snd_rawmidi            20768  1 snd_mpu401_uart
snd_seq_device          6504  1 snd_rawmidi
snd                    46596  9 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7456  1 snd

Offline

#2 2004-01-05 04:20:53

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Can't get sound to work - no /dev/dsp !!!

I have the exact same problem, but I have a section in my modprobe.conf for devfs support, and It's no use either.
This is my modprobe.conf

#
# /etc/modprobe.conf (for v2.6 kernels)
#

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
    
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# Sound lookup entries for devfs support
alias /dev/dsp sound-service-0-3
alias /dev/sequencer sound-service-0-1
alias /dev/mixer sound-service-0-0

# End of file

And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#3 2004-01-05 11:56:49

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Can't get sound to work - no /dev/dsp !!!

My config, replace intel8x0 with your sound card & it should work :

alias char-major-116* snd
options snd cards_limit=1
alias snd-card-0 snd-intel8x0
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/sound/dsp snd-pcm-oss
alias /dev/sound/sequencer snd-seq-oss
alias /dev/sound/mixer snd-mixer-oss
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && { /usr/sbin/alsactl restore; }

Offline

#4 2004-01-05 14:02:36

farphel
Forum Fellow
From: New Hampshire - USA
Registered: 2003-09-18
Posts: 250
Website

Re: Can't get sound to work - no /dev/dsp !!!

I had the same problem a while back.  My ALSA drivers were getting loaded, but not the OSS compatible drivers.  A hack to get it working for me was to add them to my MODULES line in /etc/rc.conf.

MODULES=(!usbserial !ide-scsi snd-via82xx snd-mixer-oss snd-seq-oss snd-pcm-oss)

Your /etc/devfsd.conf needs to be set up correctly to link /dev/dsp to the appropriate devfs entry.


Follow the link below, sign up, and accept one promotional offer.  If I can get five suckers (err... friends) to do this, I'll get a free iPod.  Then you too can try to get a free iPod. Thanks! http://www.freeiPods.com/?r=11363142

Offline

#5 2004-01-05 18:07:47

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Can't get sound to work - no /dev/dsp !!!

zen_guerrilla wrote:

My config, replace intel8x0 with your sound card & it should work :

alias char-major-116* snd
options snd cards_limit=1
alias snd-card-0 snd-intel8x0
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/sound/dsp snd-pcm-oss
alias /dev/sound/sequencer snd-seq-oss
alias /dev/sound/mixer snd-mixer-oss
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && { /usr/sbin/alsactl restore; }

Thanks it worked.

Farphel, I already had the modules in my rc.conf, but thanks anyway.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#6 2004-01-07 21:36:33

BashfulBruce
Member
From: Milton Keynes,UK
Registered: 2003-11-22
Posts: 10

Re: Can't get sound to work - no /dev/dsp !!!

Still having no luck here. I added snd-mixer-oss snd-seq-oss  to the /etc/rc.conf.  Farphel, you mentioned setting up the /etc/devfsd.conf to link /dev/dsp to the appropriate devfs entry, could you please give me an example of which lines do this.
I also inserted the following into /etc/modprobe.conf
(i take it modules.conf is now ignored with Kernel 2.6?).

alias char-major-116* snd
options snd cards_limit=1
alias snd-card-0 snd-via82xx
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/sound/dsp snd-pcm-oss
alias /dev/sound/sequencer snd-seq-oss
alias /dev/sound/mixer snd-mixer-oss
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && { /usr/sbin/alsactl restore; }

Offline

#7 2004-01-07 21:51:38

farphel
Forum Fellow
From: New Hampshire - USA
Registered: 2003-09-18
Posts: 250
Website

Re: Can't get sound to work - no /dev/dsp !!!

Here's what I've got in my /etc/devfs.d regarding sound.

LOOKUP          snd             MODLOAD         ACTION snd
LOOKUP          dsp             MODLOAD
LOOKUP          mixer           MODLOAD
LOOKUP          midi            MODLOAD
REGISTER        sound/.*        PERMISSIONS     root.users 0660
REGISTER        snd/.*          PERMISSIONS     root.users 0660

DISCLAIMER: It works for me.  I think there are other posts on the forum that may have other and/or better examples.

After you make changes to /etc/devfsd.conf, you can restart the daemon with

kill -HUP <pid of devfsd>

.

HTH,
farphel


Follow the link below, sign up, and accept one promotional offer.  If I can get five suckers (err... friends) to do this, I'll get a free iPod.  Then you too can try to get a free iPod. Thanks! http://www.freeiPods.com/?r=11363142

Offline

#8 2004-01-09 13:10:03

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: Can't get sound to work - no /dev/dsp !!!

Hi

I am having the same problems .....I have no /etc/devfs.d file or dir whats going on?

Mr Green :mrgreen:


Mr Green

Offline

#9 2004-01-09 16:34:23

sasdav
Member
Registered: 2002-11-18
Posts: 66

Re: Can't get sound to work - no /dev/dsp !!!

Well, sound works fine for me in gnome or console, so let me show what I have.  First I added a group called audio.  Then whenever I add a user I use -G audio,etc to the useradd command.  Here's what I have in my files.

modules.conf:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cs4236  #change this to your own driver
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/dsp sound-service-0-3
alias /dev/sequencer sound-service-0-1
alias /dev/mixer sound-service-0-0

devfsd.conf
REGISTER sound/.* PERMISSIONS root.audio 660
REGISTER snd/.* PERMISSIONS root.audio 660

Offline

#10 2004-01-11 12:58:59

Mork II
Member
From: Visby, Sweden
Registered: 2003-05-14
Posts: 87

Re: Can't get sound to work - no /dev/dsp !!!

I also lost /dev/dsp after going 2.6. The solution for me was to clear out modules.conf and modprobe.conf entirely and load everything from rc.conf:

MODULES=(snd-intel8x0 snd-mixer-oss snd-seq-oss snd-pcm-oss)

Mixer settings are restored from rc.local

aumix -w 50 -v 85 -c 50

Offline

#11 2004-01-12 16:17:12

BashfulBruce
Member
From: Milton Keynes,UK
Registered: 2003-11-22
Posts: 10

Re: Can't get sound to work - no /dev/dsp !!!

Still getting nowhere fast, I can't help but feel that I am doing something fundamentally wrong. I have tried all of the suggetions, even cleared out modprobe.conf and modules.conf to no avail. Maybe, if someone could explain how /dev/dsp is created when using Kernel 2.6 I could troubleshoot this better.

Thanks

Bruce  :?

Offline

#12 2004-06-25 20:07:20

link
Member
Registered: 2004-04-30
Posts: 69

Re: Can't get sound to work - no /dev/dsp !!!

I'm not sure if this is still an issue, but I've found the only way to load these alsa modules on boot is from within /etc/rc.conf

Adding the line

install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && { /usr/sbin/alsactl restore; }

Will make the mixer state get restored, but you still need to add the modules to /etc/rc.conf. /etc/rc.sysinit loads each module from that array with /sbin/modprobe, which reads /etc/modprobe.conf for its config.

/dev/dsp is created by devfsd when the snd-<card> module is loaded I believe. Either that or the snd-pcm-oss module.

Offline

Board footer

Powered by FluxBB