You are not logged in.

#1 2016-10-10 00:06:48

andrej
Member
Registered: 2012-03-31
Posts: 21

[SOLVED]nVidia and KF 5.8, Kwin falls back to LLVMpipe for compositing

I just updated after about 3 weeks and to my disappointment KDE and nvidia don't want to cooperate again. sad

Kwin doesn't use the nvidia driver for compositing. Some digging brought me to this bug report: https://bugs.kde.org/show_bug.cgi?id=367766
It should have been fixed in KF 5.7 branch already. I was using that with the current nvidia 370.28 driver and it was working fine. I tried downgrading to the previous 367.35 driver and it didn't change anything.

My card is a NVS 510

lspci -v
...
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [NVS 510] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation Device 0967
        Flags: bus master, fast devsel, latency 0, IRQ 138
        Memory at de000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia
...

Here is my Xorg.log: http://pastebin.com/rqdBy7P3

Kwin produces this:

$ kwin_x11 --replace
OpenGL vendor string:                   VMware, Inc.
OpenGL renderer string:                 Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
OpenGL version string:                  3.3 (Core Profile) Mesa 12.0.3
OpenGL shading language version string: 3.30
Driver:                                 LLVMpipe
GPU class:                              Unknown
OpenGL version:                         3.3
GLSL version:                           3.30
Mesa version:                           12.0.3
X server version:                       1.18.4
Linux kernel version:                   4.7.6
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no

I'm not remotely capable of debuging this myself. Nvidia driver seems to load, the card must be rendering the screens because I don't think Skylake is capable of that much screen estate.
I have no idea how the rendering pipeline works so I'm in the dark here.

Does anyone know what's going on? What can I do? Should I report this to Kwin?

Last edited by andrej (2016-10-10 09:57:55)

Offline

#2 2016-10-10 07:42:48

seth
Member
Registered: 2012-09-03
Posts: 35,095

Re: [SOLVED]nVidia and KF 5.8, Kwin falls back to LLVMpipe for compositing

[     2.417] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[     2.417] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[     2.417] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[     2.417] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[     2.417] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.


This is because of

[     2.362] (II) LoadModule: "glx"
[     2.366] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     2.392] (II) Module glx: vendor="X.Org Foundation"

You're loading the MESA glx module, /usr/lib/xorg/modules/extensions/libglx.so should symlink /usr/lib/xorg/modules/extensions/libglx.so.370.28

Smells a hell lot like you're installing mesa/nouveau from arch and the nvidia blob via the nvidia installer instead of the Arch package?
In any case your GL installation is clearly broken. Not related to KWin.

Online

#3 2016-10-10 09:57:16

andrej
Member
Registered: 2012-03-31
Posts: 21

Re: [SOLVED]nVidia and KF 5.8, Kwin falls back to LLVMpipe for compositing

Turns out nvidia-libgl was missing.

I did switch from intel to nvidia recently but it was working with nvidia-libgl before the update yesterday which is weird. As if nvidia-libgl got replaced by libgl. Shouldn't there be a dependency conflict then?

Anyway, thanks a lot!

Offline

Board footer

Powered by FluxBB