You are not logged in.

#1 2016-10-12 19:36:37

Registered: 2012-06-20
Posts: 51

[SOLVED] TP-LINK TL-WN823N V2 WiFi adapter not recognized

Hi !

I'm trying to use a TP-LINK TL-WN823N V2 WiFi adapter on Archlinux.

I saw that someone make it work (or in other places on the web) with this package that use this repository.

I'm using Archlinux with kernel 4.7.6-1 (but I also tried kernel-lts 4.4.24-1).

Here is the lsusb line of the dongle:

Bus 001 Device 005: ID 2357:0109 

So I installed the package from the AUR.
I rebooted.
I loaded the module manually (sudo modprobe 8192eu) because it wasn't loaded.
I saw that the module was loaded from the dmesg command :

[  365.404871] RTL871X: module init start
[  365.404875] RTL871X: rtl8192eu v4.3.1.1_11320.20140505
[  365.404876] RTL871X: build time: Oct 12 2016 19:55:32
[  365.404905] usbcore: registered new interface driver rtl8192eu
[  365.404906] RTL871X: module init ret=0

But the device is still not visible from 'ip link show'.

I tried to plug/unplug it several times without success.

So, if you know :
- How I could solve this problem
- Any locations for logs
- Where I can write prints in the code to help me discover the problem

It would be really nice ! smile

Thank you for reading !

Last edited by shox (2016-10-13 10:29:22)


#2 2016-10-12 19:52:26

Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] TP-LINK TL-WN823N V2 WiFi adapter not recognized

The AUR package downloads a specific commit from the git repository. That commit is too old, support for your device was added later, that's why things don't work for you. Adjust the PKGBUILD to build the latest git version, by removing the #commit= stuff from the source line.

Edit: Something interesting, support for this device will be in the 4.9 kernel using the rtl8xxxu driver, then you won't need any external drivers anymore.

Last edited by Gusar (2016-10-12 20:00:55)


#3 2016-10-13 10:29:03

Registered: 2012-06-20
Posts: 51

Re: [SOLVED] TP-LINK TL-WN823N V2 WiFi adapter not recognized

Thank you Gusar !! That was the problem ! Really nice you saw it ! Should I notice the AUR maintainer ?

Oh, really cool it's get added in the 4.9 kernel !

However, I can't make it work with NetworkManager. The network list is always empty.

Here are the NetworkManager logs

supplicant interface state inactive -> disabled
supplicant interface state disabled -> inactive
set-hw-addr: new MAC address [...] not sucessfully set (scanning)

So, I used wpa_supplicant and it works well.

# wpa_supplicant -iwlan0 -cnet.conf -Dwext
# dhcpcd wlan0 

If someone know how to solve the problem with NetworkManager, I'm here smile

Thank you again !


Board footer

Powered by FluxBB