You are not logged in.

#1 2016-10-13 01:17:21

geefolk
Member
Registered: 2016-10-13
Posts: 3

gnome desktop cannot be started due to the following issue (libgtk-3)

I upgrade the Arch Linux last night thru pacman -Syu, and the OS cannot start the gnome desktop after upgrade. I get such information thru dmesg -k under terminal.

gnome-session-f[1709]: segfault at 0 ip 00007f9d70c2e1e9 sp 00007ffd1f5518e0 error 4 in libgtk-3.so.0.2200.1[7f9d7094c000+6f2000].

Is there anyone else see such error after upgrade?

Offline

#2 2016-10-13 05:11:08

geefolk
Member
Registered: 2016-10-13
Posts: 3

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I have fixed the problem once I reinstall the whole gnome packages. The issue is gone, but still don't know the reason yet.

Offline

#3 2016-10-15 16:38:56

ladanz
Member
Registered: 2009-08-08
Posts: 13

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Same here.

When i try to login in into gdm/gnome3 i get back to login screen and it is logged(dmesg):
gnome-session-f[674]: segfault at 0 ip 00007f9204ac61e9 sp 00007fffb1dfc9b0 error 4 in libgtk-3.so.0.2200.1[7f92047e4000+6f2000]

Offline

#4 2016-11-11 15:18:21

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I am having the same segfault after the latest gnome upgrade on Nov. 10. I will be more specific this evening when I am back home, but I am using proprietary Nvidia drivers on Gnome Xorg. Problem in my case won't be solved reinstalling gnome packages or GDM or GTK3 (tried this already).

Is there anything I can do short of rolling back on Nov-9  and blocking the updates of Gnome?

Last edited by gkun (2016-11-11 15:20:22)

Offline

#5 2016-11-11 15:54:12

V1del
Member
Registered: 2012-10-16
Posts: 1,936

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Update your microcode if you are on a intel cpu

Offline

#6 2016-11-11 16:17:03

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I am indeed running an Intel CPU, an old Core i5-650@3.20 GHz.  Just read the whole article and seen the updates I was missing on the Intel site... wow.
Ok I'm gonna try before anything else

Last edited by gkun (2016-11-11 16:22:01)

Offline

#7 2016-11-11 21:12:37

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Ok, I went and installed the intel-ucode package, let Grub know where the microcode would be, and checked that it updated:

[    0.000000] microcode: microcode updated early to revision 0x4, date = 2013-06-28
[    0.752468] microcode: sig=0x20655, pf=0x2, revision=0x4
[    0.752580] microcode: Microcode Update Driver: v2.01 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

Then reboot. Unluckily the problem remains. Here is the relevant part of dmesg:

[   12.052590] mousedev: PS/2 mouse device common for all mice
[   12.278282] Adding 10239996k swap on /dev/sda4.  Priority:-1 extents:1 across:10239996k FS
[   12.407513] nvidia: loading out-of-tree module taints kernel.
[   12.407519] nvidia: module license 'NVIDIA' taints kernel.
[   12.407519] Disabling lock debugging due to kernel taint
[   12.418512] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   12.418578] nvidia-nvlink: Nvlink Core is being initialized, major device number 246
[   12.418592] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  375.10  Fri Oct 14 10:30:06 PDT 2016 (using threaded interrupts)
[   12.452957] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  375.10  Fri Oct 14 10:05:55 PDT 2016
[   12.462826] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   12.534856] floppy0: no floppy controllers found
[   12.733775] fuse init (API version 7.25)
[   17.802055] r8169 0000:02:00.0 enp2s0: link down
[   17.802061] r8169 0000:02:00.0 enp2s0: link down
[   17.802113] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   18.329513] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   18.329514] Bluetooth: BNEP filters: protocol multicast
[   18.329517] Bluetooth: BNEP socket layer initialized
[   20.576840] r8169 0000:02:00.0 enp2s0: link up
[   20.576853] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
[   35.371732] NVRM: Your system is not currently configured to drive a VGA console
[   35.371735] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   35.371737] NVRM: requires the use of a text-mode VGA console. Use of other console
[   35.371739] NVRM: drivers including, but not limited to, vesafb, may result in
[   35.371740] NVRM: corruption and stability problems, and is not supported.
[   35.372505] nvidia-modeset: Allocated GPU:0 (GPU-b2b081ca-a2d1-6972-6bc0-8f6dd40ef501) @ PCI:0000:01:00.0
[  126.973996] gnome-session-f[630]: segfault at 0 ip 00007f31c1990599 sp 00007ffd2ae756a0 error 4 in libgtk-3.so.0.2200.3[7f31c16ae000+6f3000]

Is there anything else which I should provide to try to help in debugging (and possibly, solving this problem)?

Last edited by gkun (2016-11-11 21:18:15)

Offline

#8 2016-11-12 09:27:53

zkwang
Member
Registered: 2014-04-18
Posts: 7

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I met the same problem after update gnome-shell today. Gnome on Wayland is Okay, but Gnome on Xorg is broken. The error promote in the log is similar. I am on an Intel GPU with microcode enabled.

Offline

#9 2016-11-12 15:21:01

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I wanted to try to replace Nvidia drivers with nouveau and see if the problem is driver specific. I used nouveau on Ubuntu in the same machine and it worked more or less fine.

This will have to wait as my isp has problems and I have no Internet service except for mobile...

Last edited by gkun (2016-11-12 15:54:45)

Offline

#10 2016-11-12 16:34:03

zerphian
Member
From: Germany
Registered: 2013-03-23
Posts: 1

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

I had the same problem. I'm using the Dell XPS 13 (9350) with an Intel GPU.
I could "solve" the problem by downgrading the mutter package to my last installed version 3.22.1+41+ge8fc090-1.
Maybe that helps anybody.

Offline

#11 2016-11-12 23:37:17

zkwang
Member
Registered: 2014-04-18
Posts: 7

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

zerphian wrote:

I had the same problem. I'm using the Dell XPS 13 (9350) with an Intel GPU.
I could "solve" the problem by downgrading the mutter package to my last installed version 3.22.1+41+ge8fc090-1.
Maybe that helps anybody.

Thanks for your suggestion! I "solved" the problem too by your suggestion smile Moreover, I am using Dell XPS 13 (9360) on Intel GPU.

Offline

#12 2016-11-12 23:37:36

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Well, downgrading mutter only looks much better than downgrading the whole list of gnome packages. I would rather really find a way to solve it than "solve" it, but... Sigh

Last edited by gkun (2016-11-12 23:39:17)

Offline

#13 2016-11-12 23:45:07

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Ok, so if I am not confused, what we have here is this, right?

https://bugs.archlinux.org/task/51791?p … ing=mutter

Cause the segfault is not in the bug report (I didn't open the logfile in the comments though), but the behavior is the same. Plus users are having the crash with modern Intel gpus and old Nvidia cards like mine, it seems.

Last edited by gkun (2016-11-12 23:47:36)

Offline

#14 2016-11-13 01:28:05

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Ok this for reference for whoever may need it, since I could not wait, downloaded the older version of mutter from my phone from here:

https://archive.archlinux.org/packages/ … pkg.tar.xz

Copied on my disk, downgraded with

pacman -U mutter-3.22.1+41+ge8fc090-1-x86_64.pkg.tar.xz

And it works perfectly. Now I added mutter on ignore list in /etc/pacman.conf

And will check when a version with no bugs is in the repository.

Just for the record my video card is :

Nvidia GeForce GT420. Arch 64 on Intel Core i5 650 @ 3.20 Ghz.

Last edited by gkun (2016-11-13 01:38:08)

Offline

#15 2016-11-13 13:05:23

TomTomTom
Member
Registered: 2015-01-15
Posts: 2

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Same issue here on my XPS 15 (9550). After update through "pacman -Syu" and restart the system the gnome top panel is missing, ALT+TAB does not work, etc. Only desktop icons are shown (good that I activated this feature).

Workaround: Start Gnome with Wayland instead of XOrg.
Workaround 2: Downgrade to older version (see above).

I hope this will be fixed as fast as possible because XOrg is currently working better than Wayland on the XPS 15 (I think because of the compatibiltiy to Intel Integrated Graphics).

Offline

#16 2016-11-15 09:09:38

mreichardt
Member
Registered: 2016-11-15
Posts: 1

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Hey, I had the same Issue. On a Dell Latitude E6530.
The Microcode update didn't fix the Problem.

But a 'pacman -Syu' and a reboot did fix the problem for me.

Offline

#17 2016-11-15 09:21:55

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Apparently it depends from the gpu? I tried pacman -Syu too after the microcode upgrade, but it didn't solve. I hope the bug gets a high priority, as I think many potential users won't be able to solve unless they keep mutter downgraded or they use Wayland (which is impossible for some, problematic for others).

Offline

#18 2016-11-17 09:24:40

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Yesterday mutter was upgraded to a new version. I removed mutter from the pacman ignore list and it was upgraded, everything works.

I think this thread could be marked as solved?

Offline

#19 2016-11-18 17:44:00

cybersoldier
Member
Registered: 2012-06-01
Posts: 3

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Same here, I just upgraded and had the new version of mutter on my list. Edited my .xinitrc to start gnome-session, and now it works fine.

Offline

#20 2016-11-28 14:38:54

henrylaxen
Member
Registered: 2016-11-28
Posts: 3

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Not so fast, sorry.  I'm using the latest version of everything on an xps-13 9350 with an Intel Iris Graphics 540: mutter 3.22.2+1+g5c46094-1,  gtk3 3.22.4-1 and gnome-session 3.22.2-1.  When I fire up startx, dmesg says:

gnome-session-f[4572]: segfault at 0 ip 00007f2a64e29949 sp 00007fff43454820 error 4 in libgtk-3.so.0.2200.4[7f2a64b47000+6f4000]

I just ran pacman -Syu before posting this, so everything is up to
date.  I tried downgrading mutter to version specified by gkun above,
but still got the segfault.   I also tried the version of mutter given
at

https://bugs.archlinux.org/task/51791?p … ing=mutter

and still got the segfault, so that did not fix the issue for me.
Anything I can do to help track this down.  I've had to resort to
blackbox as my window manager.  Quite painful after being used to
gnome.

Best wishes,
Henry Laxen

Offline

#21 2016-12-11 15:38:26

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Still having this? Cause the bug seems to have been closed.

Offline

#22 2016-12-11 16:03:15

henrylaxen
Member
Registered: 2016-11-28
Posts: 3

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Sadly yes.  I just did an update (pacman -Syu) and still crashed.  Here is my config as of Dec. 11, 2016:

[  999.258655] gnome-session-f[4572]: segfault at 0 ip 00007f2a64e29949 sp 00007fff43454820 error 4 in libgtk-3.so.0.2200.4[7f2a64b47000+6f4000]

Versions installed:
  gtk3 3.22.5-1
  mutter 3.22.2+1+g5c46094-1
  xf86-video-intel 1:2.99.917+746+g169c74f-1
  intel-ucode 20161104-1
  gnome-session 3.22.2-1

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 540 (rev 0a)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
3a:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
3c:00.0 Non-Volatile memory controller: Toshiba America Info Systems Device 0115 (rev 01)

Offline

#23 2016-12-12 19:04:11

ighea
Member
From: Finland
Registered: 2007-10-20
Posts: 116

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Plaah, I'm completely tired and ruind by the fish shell. I'm just a bit depressed as this issue landed on my system today.

Last edited by ighea (2016-12-12 19:07:33)


Installing Arch Linux On the Asus EEE PC
acpi-eee acpi-scripts and asusosd for Asus Eee PC (AUR)

Offline

#24 2016-12-13 19:08:03

gkun
Member
Registered: 2016-06-11
Posts: 23

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Have you tried to downgrade to the older version of mutter to confirm it is indeed a bug in the same package?

I mean the 3.22.1+41+ge8fc090-1 version from the archives linked some posts back.

Last edited by gkun (2016-12-13 19:09:24)

Offline

#25 2016-12-13 20:13:29

henrylaxen
Member
Registered: 2016-11-28
Posts: 3

Re: gnome desktop cannot be started due to the following issue (libgtk-3)

Dear gkun,

Yes I have previously, but I'll do it again right now, now being:
date: Tue Dec 13 14:08:07 CST 2016

after pacsrv -Syu, end of dmesg:
[14887.151690] gnome-session-f[16606]: segfault at 0 ip 00007f63ad10fc59 sp 00007ffd38a02590 error 4 in libgtk-3.so.0.2200.5[7f63ace2d000+6fa000]
[15051.570973] gnome-session-f[16905]: segfault at 0 ip 00007fb3e856ac59 sp 00007ffcb11eeb10 error 4 in libgtk-3.so.0.2200.5[7fb3e8288000+6fa000]
[15083.951522] gnome-session-f[17048]: segfault at 0 ip 00007f46131ddc59 sp 00007ffcdd65b1e0 error 4 in libgtk-3.so.0.2200.5[7f4612efb000+6fa000]

then after above, and then running

pacsrv -U mutter-3.22.1+41+ge8fc090-1-x86_64.pkg.tar.xz end of dmsg says:
[14887.151690] gnome-session-f[16606]: segfault at 0 ip 00007f63ad10fc59 sp 00007ffd38a02590 error 4 in libgtk-3.so.0.2200.5[7f63ace2d000+6fa000]
[15051.570973] gnome-session-f[16905]: segfault at 0 ip 00007fb3e856ac59 sp 00007ffcb11eeb10 error 4 in libgtk-3.so.0.2200.5[7fb3e8288000+6fa000]

The last line is different, but both crash, making gnome unusable.  If there is any other output I can provide, please let me know.

Best wishes,
Henry Laxen

Offline

Board footer

Powered by FluxBB