You are not logged in.

#1 2016-10-15 19:17:30

Tairosonloa
Member
From: Spain
Registered: 2016-10-15
Posts: 17

[SOLVED]How to run gnome-xorg session instead of gnome-wayland session

Hi guys,

Like many of ArchLinux users after upgrade to Gnome 3.22, I'm having problems with my icons, my desktop icons/folders and some applications that don't support wayland. So I want to use xorg (x11) like before the update instead of wayland until these bugs have been repaired. I'm using gdm as session manager.

What have I tried:

  1. I have uncomented the option WaylandEnable=false from /etc/gdm/custom.conf.

  2. I also have tried to add the enviroment variables XDG_SESSION_TYPE=x11 and GDK_BACKEND=x11 to /etc/enviroment.

  3. At the last, because I don't know how to configure gdm, I replaced /usr/share/xsessions/gnome.desktop by /usr/share/xsessions/gnome-xorg.desktop (but maintaining the original name gnome.desktop).

I have undo the (2) and (3) actions because it works fine from turning on my pc, but if I close and reopen my user session or if I use the Ctrl+Alt+Del key shorcut to restart X, I'm again on a wayland session.

So, I need help to correctly set gdm to only use xorg (x11) like before to upgate to Gnome 3.22.
Thanks you to all who spend their time to help me and to help the other users who come here with the same problem :)

EDIT: I have read the wiki before write this post, but I didn't find what I need (and I was looking for hours).

Last edited by Tairosonloa (2016-10-15 20:26:24)

Offline

#2 2016-10-15 19:51:19

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 442

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

gdm should have gnome-xorg or something like that in its options

isn't it in the wiki ?

ezik

Offline

#3 2016-10-15 19:57:11

Tairosonloa
Member
From: Spain
Registered: 2016-10-15
Posts: 17

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

shulamy wrote:

gdm should have gnome-xorg or something like that in its options

isn't it in the wiki ?

ezik

I have read the wiki before post in the forum, I shoud say it in my original post, will edit.
The problem is that I don't know how to configure gdm, or where is their options menu or what are their options commands. It's for that for what I'm asking for help :)

Last edited by Tairosonloa (2016-10-15 19:57:38)

Offline

#4 2016-10-15 20:13:30

leebickmtu
Member
Registered: 2016-06-07
Posts: 3

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

When you login, after selecting your user just click the gear icon below the password field and select "Gnome on Xorg". Then finish logging in. That selection will be saved and future logins will use is by default.

Please do that first as it is the best way.

But if for some reason that doesn't work the file the setting is being saved into when you select "Gnome on Xorg" is "/var/lib/AccountsService/users/<user_name>". Change the "XSession=" line to be "XSession=gnome-xorg". Don't mess with the gdm user file there, do it on your user file.

Offline

#5 2016-10-15 20:25:40

Tairosonloa
Member
From: Spain
Registered: 2016-10-15
Posts: 17

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

leebickmtu wrote:

When you login, after selecting your user just click the gear icon below the password field and select "Gnome on Xorg". Then finish logging in. That selection will be saved and future logins will use is by default.

Thanks you very much leebickmtu, I did what you said there and now looks like all problems I have with gnome 3.22 have disappear, even if I close and reopen my user session or if I use the Ctrl+Alt+Del command. I didn't need to do anything else.

Now, I'll mark the post as solved, but, just to finish, I would like to say (for the people who comes to this post with the same error) that I already have uncomented the option (1) (as I said on my first post), but I reverse the changes done in the options (2) and (3).

Ty to all who have helped me, have a nice day! :)

Last edited by Tairosonloa (2016-10-15 20:28:11)

Offline

#6 2018-02-01 10:39:16

thisisabdus
Member
From: India
Registered: 2018-02-01
Posts: 2
Website

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

That's awesome. I just solved my problem using this thread. Thank you all.

Offline

#7 2018-02-01 10:49:52

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,468

Re: [SOLVED]How to run gnome-xorg session instead of gnome-wayland session

Please don't necrobump with empty me too posts with information that is readily available in the wiki.

https://wiki.archlinux.org/index.php/Co … bumping.22
https://wiki.archlinux.org/index.php/Co … mpty_posts

Closing.

Last edited by V1del (2018-02-01 10:50:19)

Offline

Board footer

Powered by FluxBB