You are not logged in.

#1 2016-10-17 17:40:26

maanvol
Member
Registered: 2016-08-09
Posts: 20

How to switch from US to US international with dead keys?

I now do have 'LANG=en_US.UTF-8', but I do want to replace it by 'US international with AltGr dead keys'. What is the the locale name that I can place on the /etc/locale.conf file? Many thanks. Is it 'en_US ISO-8859-1'? I do not see any other options on the list. I now know that 'US international with dead keys' is also 'LANG=en_US.UTF-8' on /etc/locale.gen, so something else has to be changed, but how to do this?

Last edited by maanvol (2016-10-17 18:43:39)

Offline

#2 2016-10-17 18:48:06

philo
Member
Registered: 2015-01-26
Posts: 212

Re: How to switch from US to US international with dead keys?

Offline

#3 2016-10-18 17:10:24

maanvol
Member
Registered: 2016-08-09
Posts: 20

Re: How to switch from US to US international with dead keys?

I know that I need this information:
XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT="intl"
XKBOPTIONS=""

BACKSPACE="guess"

But, I do not know on which file to place it, and how to activate it. I did remove  'LANG=en_US.UTF-8' from /etc/locale.gen, but it is still running, and I do not know how to replace it by 'US international with AltGr dead keys'

Last edited by maanvol (2016-10-18 17:37:02)

Offline

#4 2016-10-18 18:18:15

R00KIE
Forum Fellow
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: How to switch from US to US international with dead keys?

https://wiki.archlinux.org/index.php/Ke … tion_files

And you'll still need  'LANG=en_US.UTF-8' in /etc/locale.gen.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2016-10-18 18:47:20

maanvol
Member
Registered: 2016-08-09
Posts: 20

Re: How to switch from US to US international with dead keys?

But if I take a look at, for instance, Ubuntu, it has the information:
XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT="intl"
XKBOPTIONS=""

BACKSPACE="guess"

on /etc/default/keyboard, and /etc/locale.conf is empty.


R00KIE wrote:

https://wiki.archlinux.org/index.php/Ke … tion_files

And you'll still need  'LANG=en_US.UTF-8' in /etc/locale.gen.

Offline

#6 2016-10-19 07:55:19

maanvol
Member
Registered: 2016-08-09
Posts: 20

Re: How to switch from US to US international with dead keys?

startx:

(==) Log file: "/var/log/Xorg.1.log", Time: Wed Oct 19 07:32:06 2016
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Parse error on line 6 of section InputClass in file /etc/X11/xorg.conf.d/00-keyboard.conf
    "XkbLayout" is not a valid keyword in this section.


On /etc/X11/xorg.conf.d/00-keyboard.conf:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        "XkbLayout" "us"
        "XkbModel" "pc105"
        "XkbVariant" "intl"
        "XkbOptions" " "
         BACKSPACE="guess"
EndSection



Why is "XkbLayout" not a valid keyword in this section? How to correct the '/etc/X11/xorg.conf.d/00-keyboard.conf' file?

I firstly did try it out with the term 'option', but I did not get 'US international with dead keys'.

I did put the terms 'Option' back on the file, and 'startx' now does function, but I still do not have 'US international with dead keys'. So, what do I do incorrectly?

I would like to give the 'localectl command' a try. How do I fill the data on it?
Something like this: localectl --no-convert set-x11-keymap us pc105 intl " " guess? I get the answer: "Too many arguments"

I deleted 'guess', now 'locatectl' functions, but I still do not have 'US international with dead keys'. So, what is wrong?

Last edited by maanvol (2016-10-19 09:01:19)

Offline

#7 2016-10-19 13:23:18

R00KIE
Forum Fellow
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: How to switch from US to US international with dead keys?

maanvol wrote:

But if I take a look at, for instance, Ubuntu, it has the information:

Arch Linux is not Ubuntu. Read the wiki page you have been pointed to twice already and try what is described there, come back when you have doubts about that.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2016-10-19 19:48:43

philo
Member
Registered: 2015-01-26
Posts: 212

Re: How to switch from US to US international with dead keys?

what about:

localectl set-x11-keymap us "" altgr-intl  

Last edited by philo (2016-10-20 15:17:48)

Offline

#9 2016-10-19 21:06:55

Awebb
Member
Registered: 2010-05-06
Posts: 6,048

Re: How to switch from US to US international with dead keys?

man localectl

Offline

#10 2016-10-21 19:16:47

maanvol
Member
Registered: 2016-08-09
Posts: 20

Re: How to switch from US to US international with dead keys?

Which keymap represents: 'English (US, international with dead keys) layout'? For instance on '/etc/vconsole.conf' you can have 'KEYMAP=de-latin1'. Does a list of keymaps exist?

Offline

#11 2016-10-21 19:42:37

Awebb
Member
Registered: 2010-05-06
Posts: 6,048

Re: How to switch from US to US international with dead keys?

maanvol wrote:

Which keymap represents: 'English (US, international with dead keys) layout'? For instance on '/etc/vconsole.conf' you can have 'KEYMAP=de-latin1'. Does a list of keymaps exist?

Awebb wrote:

man localectl

Offline

#12 2016-10-23 09:47:12

philo
Member
Registered: 2015-01-26
Posts: 212

Re: How to switch from US to US international with dead keys?

It is all over the web, e.g.:

https://www.freedesktop.org/software/sy … lectl.html

Last edited by philo (2016-10-23 11:30:35)

Offline

Board footer

Powered by FluxBB