You are not logged in.

#1 2016-10-20 14:15:45

dogo77
Member
Registered: 2010-06-08
Posts: 13

[SOLVED] Alt-Gr + [key] crashing xfce – why?

Hi,
i have some strange behaviour here.
4.7.6-1-ARCH #1 SMP PREEMPT Fri Sep 30 19:28:42 CEST 2016 x86_64 GNU/Linux
XFCE4 4.12
xorg-server 1.18.4-1
keyboard set to Generic 105 INTL
German layout
language codes as set in installation, everything was working fine.

i often use special characters such as … or ·
i get them with AltGr + [.] and [,]

since a few weeks, hitting certain combos crashes my xfce.
that means. For Example,
i hit AltGr+[c] --> freeze
i hit AltGt+[m] --> freeze

freeze means, i'm still able to move the mouse cursor, but
windows not clickable/movable
no text input
clock in panel stops counting seconds

only way to get back to normal is by killing process xinit from tty.

don't know where and how to search for a solution. Any hint?

Last edited by dogo77 (2016-10-30 14:41:26)

Offline

#2 2016-10-20 15:09:10

seth
Member
Registered: 2012-09-03
Posts: 10,296

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

Check whether it's only a visual thing (ie. stalled compositor), https://wiki.archlinux.org/index.php/Xf … te_manager ie. disable it

Last edited by seth (2016-10-20 15:09:51)

Offline

#3 2016-10-20 15:21:32

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

seth wrote:

Check whether it's only a visual thing (ie. stalled compositor), https://wiki.archlinux.org/index.php/Xf … te_manager ie. disable it

been there, disabled compositing, same behaviour.

Offline

#4 2016-10-20 15:24:28

seth
Member
Registered: 2012-09-03
Posts: 10,296

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

instead of killing the session, is killing the WM sufficient?

export DISPLAY=:0
kill xfwm4
# ensure it's dead
xfwm4 &

Otherwise check for grabs, install xdotool and run

export DISPLAY=:0
xdotool key "XF86LogGrabInfo"

Then inspect the xorg log (warning, could be in  ~/.local/share/xorg/ rather than in /var/log)

Offline

#5 2016-10-21 08:27:34

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

seth wrote:

instead of killing the session, is killing the WM sufficient?

export DISPLAY=:0
kill xfwm4
# ensure it's dead
xfwm4 &

no, that did not help.
switching back to xsession shows the background, last openend windows, an empty grey panel without symbols.
I can move the mouseponiter, but no further action is possible.
then i tried to kill xfce4-session, *panel
nothing helped

seth wrote:

Otherwise check for grabs, install xdotool and run

export DISPLAY=:0
xdotool key "XF86LogGrabInfo"

Then inspect the xorg log (warning, could be in  ~/.local/share/xorg/ rather than in /var/log)

i did this. then my ~.local/share/xorg/Xorg.0.log fills with grab events.
the logfile of a fresh start and some keys pressed can be found here:
https://p.42.vc/?b3b79accc185de07#dKeQt … qOLtcGfvU= (zerobin)
sorry, but i can't see whats wrong here.

thanks for looking into this, much appreciated…

Offline

#6 2016-10-21 14:23:17

seth
Member
Registered: 2012-09-03
Posts: 10,296

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

There'r no active grabs. But we now know for sure that the server still responds.
Can you try uninstalling xf86-video-intel (on a reasonably recent Arch, this should auto-enable the modesetting driver, ie. you still get GUI) and recause the issue?

Do you have any global shortcuts involving AltGr?


Does it matter which window is active when hitting the key combo?

And, for a wild gues,, record the outputs of "locale", "locale -a", "setxkbmap -print" and "setxkbmap -query".

Last edited by seth (2016-10-21 14:24:18)

Offline

#7 2016-10-22 01:06:45

FelledTreeNo9
Member
Registered: 2015-05-05
Posts: 23

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

Sounds a bit similar to an issue I had about a month ago - see my post and others here: https://bbs.archlinux.org/viewtopic.php?id=216856

Offline

#8 2016-10-24 07:28:22

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

seth wrote:

There'r no active grabs. But we now know for sure that the server still responds.
Can you try uninstalling xf86-video-intel (on a reasonably recent Arch, this should auto-enable the modesetting driver, ie. you still get GUI) and recause the issue?

I'll try this next.

seth wrote:

Do you have any global shortcuts involving AltGr?

none that i know of. xfce4-settings - keyboard - shortcuts doesn't have any.

seth wrote:

Does it matter which window is active when hitting the key combo?

No. even on plain desktop with no windows the freeze occurs

seth wrote:

And, for a wild gues,, record the outputs of "locale", "locale -a", "setxkbmap -print" and "setxkbmap -query".

output here:

locale

LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

locale -a

C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
en_US.utf8
german
POSIX

setxkbmap -print

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+de(nodeadkeys)+inet(evdev)+compose(lwin)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

setxkbmap -query

rules:      evdev
model:      pc105
layout:     de
variant:    nodeadkeys
options:    compose:lwin

Last edited by dogo77 (2016-10-24 07:48:44)

Offline

#9 2016-10-24 07:36:07

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

FelledTreeNo9 wrote:

Sounds a bit similar to an issue I had about a month ago - see my post and others here: https://bbs.archlinux.org/viewtopic.php?id=216856

yeah, that sounds similar.
just, i did not find any pacnew files.
and downgrading dbus…not shure if i want this. wink

Offline

#10 2016-10-24 07:37:49

seth
Member
Registered: 2012-09-03
Posts: 10,296

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

Can you please repost the output here (in code tags)
This zerobin service seems to provide no reasonable plaintext - or your locales are indeed "LANG=deDE.UTF-8", which is wrong.

Offline

#11 2016-10-24 07:55:29

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

seth wrote:

Can you please repost the output here (in code tags)
This zerobin service seems to provide no reasonable plaintext - or your locales are indeed "LANG=deDE.UTF-8", which is wrong.

i did this in post #8 from 2016-10-24 08:28:22

in the meanwhile i removed  xf86-video-intel --> no change

Offline

#12 2016-10-30 12:54:26

seth
Member
Registered: 2012-09-03
Posts: 10,296

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

Do you have some ck-exec or dbus-launch in "ps ax"?
xfce "somehow" seems to trigger that for "some" configuration - and messes with the logind session bus.
See eg. https://bbs.archlinux.org/viewtopic.php?id=218064&p=2 (very long thread, a new user should not have this problem, though)

Also see https://bugs.archlinux.org/task/50543 for a bunch of DBUS_SESSION_BUS_ADDRESS nuking incidents.

Last edited by seth (2016-10-30 12:55:47)

Offline

#13 2016-10-30 14:40:58

dogo77
Member
Registered: 2010-06-08
Posts: 13

Re: [SOLVED] Alt-Gr + [key] crashing xfce – why?

seth wrote:

Do you have some ck-exec or dbus-launch in "ps ax"?
xfce "somehow" seems to trigger that for "some" configuration - and messes with the logind session bus.

Thank you so much – found the solution in the mentioned thread.
I changed my .xinitrc to

…
#exec dbus-launch --exit-with-session startxfce4
exec startxfce4

and everything works as expected now.
»¶«

big_smile

Offline

Board footer

Powered by FluxBB