You are not logged in.

#1 2016-11-01 23:24:12

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

[SOLVED] Can not configure touchpad "tap to click" in Mate-gtk3

I have gnome 3.22 and I just installed Mate-gtk3 1.16.1 desktop. Still running under GDM (testing Mate for now)

Mate works very well, except I can not figure out how to configure tap to click for the touchpad. Scrolling works fine, just not tap to click
I tried to enabled it via dconf-editor following the guide here https://wiki.archlinux.org/index.php/To … ptics#MATE and setting tap-to-click to true

gsettings get org.mate.peripherals-touchpad tap-to-click
true

Under gnome the touchpad "tap to click" works under wayland and xorg, so libinput seems to be correct.

This is on a Dell E7440 which uses a AlpsPS2 touchpad

>xinput
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Logitech M510                               id=11    [slave  pointer  (2)]
⎜   ↳ Logitech K750                               id=12    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint Stick               id=15    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint TouchPad            id=16    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ C-Media USB Audio Device                    id=10    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD                 id=13    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=14    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                            id=17    [slave  keyboard (3)]
    ↳ Logitech K750                               id=18    [slave  keyboard (3)]

Last edited by gps1539 (2016-11-02 16:25:33)

Offline

#2 2016-11-02 04:46:59

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 1,172

Re: [SOLVED] Can not configure touchpad "tap to click" in Mate-gtk3

I guess you are using xf86-input-libinput, as your touchpad driver, you need to create a config file for libinput at /etc/X11/xorg.conf.d/40-libinput.conf with something like below contents

# Match on all types of devices but tablet devices and joysticks
        Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
	Option "ScrollMethod" "twofinger"
	Option "Tapping"
EndSection 

For more details read section on libinput at archwiki


Arch is home!
sway rofi qutebrowser vifm vim mutt lizzy pass

Offline

#3 2016-11-02 05:01:41

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

Re: [SOLVED] Can not configure touchpad "tap to click" in Mate-gtk3

Docbroke wrote:

I guess you are using xf86-input-libinput, as your touchpad driver, you need to create a config file for libinput at /etc/X11/xorg.conf.d/40-libinput.conf with something like below contents

# Match on all types of devices but tablet devices and joysticks
        Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
	Option "ScrollMethod" "twofinger"
	Option "Tapping"
EndSection 

For more details read section on libinput at archwiki


Thanks for the reply
how does gnome on xorg work OK without such a conf file? does gnome get the config from somewhere else?

Offline

#4 2016-11-02 06:26:22

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 1,172

Re: [SOLVED] Can not configure touchpad "tap to click" in Mate-gtk3

does this solve your issue?
Gnome may have ways to override the settings, I don't know as I don't use gnome.


Arch is home!
sway rofi qutebrowser vifm vim mutt lizzy pass

Offline

#5 2016-11-02 16:25:17

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

Re: [SOLVED] Can not configure touchpad "tap to click" in Mate-gtk3

Yes it did fixed the issue, thanks for the help.

My conf file.
cat /etc/X11/xorg.conf.d/30-touchpad.conf

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "Tapping" "on"
    Option "ScrollMethod" "twofinger"
    Option "TappingButtonMap" "lmr"
EndSection

Offline

Board footer

Powered by FluxBB