You are not logged in.

#1 2004-01-05 17:34:45

Registered: 2003-12-03
Posts: 1,659

2.2, 2.4 and 2.6 kernel exploit

A critical security vulnerability has been found  in  the  Linux  kernel memory  management  code in mremap(2) system call due to incorrect bound checks.


Since no special privileges are required to use the mremap(2) system call any process may misuse its unexpected behavior to disrupt the kernel memory management subsystem. Proper exploitation of this vulnerability may lead to local privilege escalation including execution of  arbitrary code with kernel level access. Proof-of-concept exploit code has been created and successfully tested giving UID 0 shell on vulnerable systems.

The exploitability of the discovered vulnerability is possible, although not a trivial one. We have identified at least two different attack vectors for the 2.4 kernel series. All users are encouraged to patch all vulnerable systems as soon as appropriate vendor patches are released.

This has been fixed in kernel 2.4.24
If you have any weird patches for your current kernel, like grsec or XFS: they should apply cleanly with patches for 2.4.23.

As the report states, 2.6 should also be exploitable, so I made a patch for kernel 2.6.0:


#2 2004-01-10 19:07:03

From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975

Re: 2.2, 2.4 and 2.6 kernel exploit

to update this upgrading to 2.4.24 or 2.6.1 should fix this

AKA uknowme

I am not your friend


Board footer

Powered by FluxBB