You are not logged in.

#1 2016-12-11 06:08:26

nadotu
Member
Registered: 2016-12-11
Posts: 2

SError: { UnrecFIS } on boot with Intel 540s Series SSD

I'am trying hard to understand the meaning of a totally irregular appearing error during boot according to one of the SSDs connected to my NUC5I5RYH:
New SSD M.2 240GB INTEL SSDSCKKW24 (Modell: 540s), firmware up to date, checked without any errors with Intels SSD Tool, SMART values unremarkable.
SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03) (prog-if 01 [AHCI 1.0])
CPU: Intel(R) Core(TM) i5-5250U (Broadwell-U)
ArchLinux up to date

I testet reboot, boot after shutdown and boot after shutdown with power unplugged.
On every ca. fifth to tenth boot I get:

ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
ata4.00: ATA-10: INTEL SSDSCKKW240H6,  LSF036C, max UDMA/133
ata4.00: 468862128 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
ata4.00: READ LOG DMA EXT failed, trying unqueued
ata4.00: failed to get Identify Device Data, Emask 0x40
ata4.00: configured for UDMA/133
ata4: exception Emask 0x2 SAct 0x0 SErr 0x2000000 action 0x6 frozen t4
ata4: irq_stat 0x00000011, unknown FIS 00478027 a0000830 00000000 08000001
ata4: SError: { UnrecFIS }
ata4: hard resetting link

What does that mean 'unknown FIS'?
There are some posts about similar errors found on the web but no one identical.
All I found was at:
https://ata.wiki.kernel.org/index.php/L … r_messages
'UnrecFIS    Unrecognized FIS (frame information structure) received'

What I tried successless:
- reinstalled everything twice after secure erease of the ssd
- cleaned the contacts of the M.2
- tried different schedulers
- disabled ncq (libata.force=noncq)


But where does it come from? Is my SSD dying? Is it a hardware or a software issue? Perhaps a firmware bug?
Any hint or help would be appreciated.

Offline

#2 2016-12-11 08:26:58

mich41
Member
Registered: 2012-06-22
Posts: 796

Re: SError: { UnrecFIS } on boot with Intel 540s Series SSD

FIS is a message sent by the disk. This particular problem doesn't seem to be caused by bad contacts or EMI because they normally produce 10B8B/Dispar/BadCRC in addition to other errors. Unlikely to be caused by issues with the flash memory itself either, unless the firmware also has broken error reporting at the same time.

Probably no harm in running the SMART self-test: smartctl -t long

Can you test this disk on other board or other disk on this board?

What happens after this link reset?

Does it work reliably the remaining 9/10 times?

Did you try limiting SATA speed to 3G? I doubt it would help but who knows.

Offline

#3 2016-12-11 21:57:04

nadotu
Member
Registered: 2016-12-11
Posts: 2

Re: SError: { UnrecFIS } on boot with Intel 540s Series SSD

Thank you for reply;
I ran smartctl -t long without errors.
As my NUC5I5 is the only device with M.2 port I own I can not test this drive in another device but I've ordered a second M.2 from another manufacturer now for testing. Hope to get it the next days and will report back than if the issue persists.

After the SATA reset boot proceeds normal and everything works as expected.
It seems that there is no further interference related to this error.
Will try to limit SATA to 3G and report back.

Meanwhile I found out that there was a  former firmware release (June 2016 031C) which provided the following changes:

* Corrected errant FIS causing BSOD when Write Cache disabled

so I asked at Intel communities if this error could be related to it.

Offline

#4 2016-12-12 08:18:44

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: SError: { UnrecFIS } on boot with Intel 540s Series SSD

It is always a good idea to run the latest firmware both for the system and the ssd, even if it seems there is no important change.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

Board footer

Powered by FluxBB