You are not logged in.

#1 2006-06-02 15:26:10

varaahan
Member
From: Chennai , India
Registered: 2006-05-29
Posts: 145

file permissions

By editing /etc/fstab file I could get the fat32 partitions loaded by default but I could not open or write any file in windows partition. As root user I used
"chmod +777 /mnt/win_c " but still the ls -l command gives " -rwxr-xr-x" output only. why?


Linux learner and admirer - ALWAYS
Regd Linux User : 431318

Offline

#2 2006-06-02 17:27:49

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: file permissions

I use this for windows 98 partition:

/dev/hdb1 /mnt/windoze vfat users,umask=111,dmask=000,iocharset=iso8859-2,codepage=852 0 0

I think smth like this should work. Read the man and check this options.

Offline

#3 2006-06-02 20:33:11

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: file permissions

use umask.
umask=0000  = chmod 0777
umask=0002  = chmod 0775
umask=0020  = chmod 0757
etc, etc.

Offline

#4 2006-06-03 00:58:06

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: file permissions

Penguin wrote:

use umask.
umask=0000  = chmod 0777
umask=0002  = chmod 0775
umask=0020  = chmod 0757
etc, etc.

AS he said, so you will want to change your line to something like this:

/dev/hda1 /mnt/point vfat users,umask=0000,auto,exec 0 0

Offline

Board footer

Powered by FluxBB