You are not logged in.

#1 2017-01-02 20:33:15

robby
Member
Registered: 2016-08-07
Posts: 69

Unable to Update Arch Pacman -Syu [Solved]

Code below is a snip from the last lines of what happens when I run sudo pacman -Syu. I don't understand what is going on here. Would anyone be able to tell me how I can correct these signatures?

error: jasper: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/jasper-1.900.31-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: krb5: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/krb5-1.13.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: vala: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/vala-0.34.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libpsl: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/libpsl-0.16.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: gegl: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/gegl-0.3.8-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libraw: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/libraw-0.17.2-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: lib32-libtiff: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-libtiff-4.0.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: wget: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/wget-1.18-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Last edited by robby (2017-01-02 20:42:47)

Offline

#2 2017-01-02 20:34:56

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,132
Website

Re: Unable to Update Arch Pacman -Syu [Solved]

Update your keyring:

pacman -Sy archlinux-keyring && pacman -Syyu

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2017-01-02 20:39:47

robby
Member
Registered: 2016-08-07
Posts: 69

Re: Unable to Update Arch Pacman -Syu [Solved]

jasonwryan wrote:

Update your keyring:

pacman -Sy archlinux-keyring && pacman -Syyu

Thanks for the reply, seems like I have some sort of font problem. Going to look into it.

error: failed to commit transaction (conflicting files)
ttf-dejavu: /etc/fonts/conf.d/20-unhint-small-dejavu-sans-mono.conf exists in filesystem
ttf-dejavu: /etc/fonts/conf.d/20-unhint-small-dejavu-sans.conf exists in filesystem
ttf-dejavu: /etc/fonts/conf.d/20-unhint-small-dejavu-serif.conf exists in filesystem
ttf-dejavu: /etc/fonts/conf.d/57-dejavu-sans-mono.conf exists in filesystem
ttf-dejavu: /etc/fonts/conf.d/57-dejavu-sans.conf exists in filesystem
ttf-dejavu: /etc/fonts/conf.d/57-dejavu-serif.conf exists in filesystem
Errors occurred, no packages were upgraded.

Offline

#4 2017-01-02 20:40:12

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,319

Re: Unable to Update Arch Pacman -Syu [Solved]

Read the news on the front page.

Offline

#5 2017-01-02 20:42:57

robby
Member
Registered: 2016-08-07
Posts: 69

Re: Unable to Update Arch Pacman -Syu [Solved]

Offline

#6 2017-01-02 20:43:31

robby
Member
Registered: 2016-08-07
Posts: 69

Re: Unable to Update Arch Pacman -Syu [Solved]

Offline

#7 2017-10-23 15:54:02

zulqurnain
Member
Registered: 2016-11-15
Posts: 17

Re: Unable to Update Arch Pacman -Syu [Solved]

jasonwryan wrote:

Update your keyring:

pacman -Sy archlinux-keyring && pacman -Syyu

For me it was NOT a font problem. This is what did it for me thanks. == FYI == this usually happens after not updating arch for a while. you will most like have another issue in which removing ca-certificates will be the final step

Offline

#8 2017-10-23 16:04:20

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,142
Website

Re: Unable to Update Arch Pacman -Syu [Solved]

Please don't necrobump.

https://wiki.archlinux.org/index.php/Co … bumping.22

If you haven't updated in a while, or you encounter any unexpected messages when trying to update, then the news should be your first port of call.

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB