You are not logged in.

#1 2017-01-04 22:52:24

TrueNDiary
Member
Registered: 2016-12-29
Posts: 14

[Solved] ERROR: device '' not found. Skipping fsck

Help! I've tried to install arch linux alongside windows 10 UEFI and after I rebooted and try to log in to arch
I got this error, how do I fix it?
http://i.imgur.com/34yBJhc.jpg

Mod note: Removed oversized image of text. Don't post images of text, post the text itself. If you must post images, adhere to the CoC -- WorMzy

Last edited by TrueNDiary (2017-01-07 02:04:13)

Offline

#2 2017-01-04 23:10:10

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,826
Website

Re: [Solved] ERROR: device '' not found. Skipping fsck

Which bootmanager are you using? How have you configured it?

Mod note: Moving to NC.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2017-01-05 06:00:18

TrueNDiary
Member
Registered: 2016-12-29
Posts: 14

Re: [Solved] ERROR: device '' not found. Skipping fsck

WorMzy wrote:

Which bootmanager are you using? How have you configured it?

Mod note: Moving to NC.

Hey, I'm using rEFInd bootloader
Here is what I did:

54.	root@archiso ~ # mount -t efivarfs efivarfs /sys/firmware/efi/efivars | [verification]
55.	root@archiso ~ # pacman -S refind-efi
56.	root@archiso ~ # refind-install
57.	root@archiso ~ # cd /boot/EFI/refind/
58.	root@archiso ~ # mkdir -p themes
59.	root@archiso ~ # ls -R /boot
60.	root@archiso ~ # cd -
61.	root@archiso ~ # nano /boot/refind_linux.conf
62.	root@archiso ~ # Change “ro” to “rw”

That the only thing I did.

Offline

#4 2017-01-05 16:36:17

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,138
Website

Re: [Solved] ERROR: device '' not found. Skipping fsck

The root devicepath is configured as

''

but that's not the root device, it's an empty string.
Configure the root device correctly in /boot/refind_linux.conf .
Refind doesn't do any automagic to find it for you.

Offline

#5 2017-01-07 01:32:09

TrueNDiary
Member
Registered: 2016-12-29
Posts: 14

Re: [Solved] ERROR: device '' not found. Skipping fsck

teateawhy wrote:

The root devicepath is configured as

''

but that's not the root device, it's an empty string.
Configure the root device correctly in /boot/refind_linux.conf .
Refind doesn't do any automagic to find it for you.

I've manage to get to the tty section using F2 and then select "Boot with minimal options".
So I logged as root
checked to see if I'm mounted and typed:

nano /boot/refind_linux.conf

Here is the output..

"Boot with standard options"  "archisobasedir=arch archisolabel=ARCH_201701"
"Boot to single-user mode"  "archisobasedir=arch archisolabel=ARCH_201701 single"
"Boot with minimal options"  "ro root=UUID=XXX"

I dont think the first two should be "archisobasedir=arch archisolabel=ARCH_201701"
Can you explain me how to configue my refind_linux.conf?

BTW if i'll replace those 2 "archisobasedir=arch archisolabel=ARCH_201701" with "ro root=UUID=XXX"
will it solve the problem?

Last edited by TrueNDiary (2017-01-07 02:05:00)

Offline

#6 2017-01-07 01:48:13

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,138
Website

Re: [Solved] ERROR: device '' not found. Skipping fsck

Offline

#7 2017-01-07 02:03:43

TrueNDiary
Member
Registered: 2016-12-29
Posts: 14

Re: [Solved] ERROR: device '' not found. Skipping fsck

teateawhy wrote:

I've ran this command:

mkrlconf

and it generated a new properly configured refind_linux.conf file.
This solved my problem.

Thank you very much @teateawhy

Offline

Board footer

Powered by FluxBB