You are not logged in.

#1 2017-01-06 15:36:21

divmin
Member
Registered: 2017-01-06
Posts: 3

[SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

I'm aware that this is a recurring problem, but even after reading the wikis and forums the microphone of my Logitech Quickcam E 3500 is still not working. I admit that I edited the config files of both ALSA and Pulseaudio so to have two simultaneous outputs on both my speakers and my TV, so since I don't have a default configuration I really don't know where I should start looking for the problem. Any suggestion?

Last edited by divmin (2017-01-07 09:52:25)

Offline

#2 2017-01-06 16:41:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,001

Re: [SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

Check that $application records to the correct device in pavucontrol? Can you post

lsusb -t
pacmd list-cards
pacmd list-sources
#While recording something you want to hear
pacmd list-source-outputs 
sudo fuser -v /dev/snd/*

and post those configuration files I'd say

Last edited by V1del (2017-01-06 19:26:44)

Offline

#3 2017-01-06 21:31:56

divmin
Member
Registered: 2017-01-06
Posts: 3

Re: [SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

Here we go.

lsusb -t

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 2, Class=Audio, Driver=, 480M
    |__ Port 2: Dev 2, If 3, Class=Audio, Driver=, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/10p, 5000M
    |__ Port 5: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
    |__ Port 3: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 4: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 4: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 9: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 9: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M

pacmd list-cards

0 card(s) available.

pacmd list-sources

 3 source(s) available.
  * index: 0
	name: <alsa_output.hw_0_0.monitor>
	driver: <module-alsa-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 344 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 2000.00 ms; range is 0.50 .. 2000.00 ms
	monitor_of: 0
	module: 0
	properties:
		device.description = "Monitor of Built-in Audio"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
    index: 1
	name: <combined.monitor>
	driver: <module-combine-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 200.00 ms; range is 0.50 .. 200.00 ms
	monitor_of: 1
	module: 1
	properties:
		device.description = "Monitor Source of Simultaneous output to Built-in Audio, HDA NVidia"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
    index: 2
	name: <alsa_output.hw_1_7.monitor>
	driver: <module-alsa-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 344 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 1999.82 ms; range is 0.50 .. 1999.82 ms
	monitor_of: 2
	module: 2
	properties:
		device.description = "Monitor of HDA NVidia"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
 

This is what I got while I was recording a video with guvcview:

pacmd list-source-outputs

0 source output(s) available.

sudo fuser -v /dev/snd/*

                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  divmin   2142 F.... guvcview
/dev/snd/pcmC0D0c:   divmin   2142 F...m guvcview
/dev/snd/pcmC0D0p:   divmin   1836 F...m pulseaudio
/dev/snd/pcmC1D7p:   divmin   1836 F...m pulseaudio
/dev/snd/timer:      divmin   2142 f.... guvcview

As for the config files, these are the ones I modified:

/etc/pulse/default.pa https://gist.github.com/anonymous/fddc4 … b866c8dbc3
/etc/modprobe.d/alsa-base.conf https://gist.github.com/anonymous/6077c … 293f6f75f9

I hope I haven't forgotten anything. As you can see from alsa-base.conf, I suppose that what is causing the problem is that I instructed ALSA to never use any USB sound card as the main one (I followed this wiki article: https://wiki.archlinux.org/index.php/Ad … sound_card). I did this as I was acually having problems getting the system recognizing the correct sound card, but did this instruction disable the webcam microphone for good? How should I enable it?

Offline

#4 2017-01-07 08:25:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,001

Re: [SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

You seem to have accidentally copy pasted that same list twice into your alsa-base.conf. And especially problematic you have

options snd-usb-audio index=-2options bt87x index=-2

which leads to the kernel trying to load the USB module with an index value of -2options and it should be rather clear that that's not going to work, so you currently you aren't loading the usb-audio module at all.

Personally I wouldn't really  forego automatic detection like you did in that default.pa, there are more guaranteed ways to achieve a combined sink using the unique identifier names the autodetection provides, and I also wouldn't have tsched=0 just like that, but it isn't really the main issue here. And you don't have pulseaudio-alsa installed and you try to record through a tool which uses the ALSA API which also has certain potential for breakage, but you should be able to instruct guvcview to use pulseaudio instead of portaudio/ALSA.

If after fixing your alsa-base.conf you still have issues (reboot after adjusting the alsa-base.conf) repost those same outputs with the exception of lsusb but the addition of

aplay -lL

Offline

#5 2017-01-07 09:52:11

divmin
Member
Registered: 2017-01-06
Posts: 3

Re: [SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

Awesome, now the mictophone works! Thank you very much!
May I ask you how you would edit default.pa differently? Or could you please direct me to an article in the wiki on how to do that?

Offline

#6 2017-01-07 10:12:53

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,001

Re: [SOLVED] USB Webcam microphone not working (Logitech Quickcam E 3500)

I'd just remove those two alsa sinks in the beginning and load the combine module (and set it as default) at the end of the file instead. That way you don't lose the additional information the autodetection provides and you don't have to adjust your pulse config should you ever, e.g. switch the HDMI port you are connected to. But really this is only somewhat of a minor pet peeve, if that setup as it is currently works for you, you can leave it at that.

Offline

Board footer

Powered by FluxBB