You are not logged in.

#1 2017-01-07 19:59:48

ChesSeu
Member
Registered: 2016-10-27
Posts: 18

[solved] Errors occured, no packages were updated,

Hey!
My arch distro has been unused for about 1 month and I am trying to update the software before I start using it again. Therefore I ran the following commands:

pacman -Syy
pacman -Su

The first one was updating the package databases without any issues but the

pacman -SU 

had the following output:

 :: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (148) alsa-lib-1.1.3-1  archlinux-keyring-20170104-1  atom-1.12.9-1  avahi-0.6.32-3  bash-4.4.005-2  boost-libs-1.62.0-4  ca-certificates-mozilla-3.27.2-1  cairo-1.14.8-1  caribou-0.4.21+0+g36e3d0f-2
               compton-0.1_beta2.5-4  conky-1.10.6-1  coreutils-8.26-1  curl-7.52.1-2  dbus-1.10.14-1  device-mapper-2.02.168-1  dhcpcd-6.11.5-1  electron-1.4.13-1  enchant-1.6.0-10  ffmpeg-1:3.2.2-2
               filesystem-2016.12-2  firefox-50.1.0-1  freetype2-2.7.1-1  gdk-pixbuf2-2.36.3-1  git-2.11.0-2  gmp-6.1.2-1  gnome-shell-3.22.2+18+gdf7727a-1  gnupg-2.1.17-3  gnutls-3.4.17-1  grep-2.27-1
               gsm-1.0.16-1  gtk-update-icon-cache-3.22.6-1  gtk3-3.22.6-1  gtk3-print-backends-3.22.6-1  harfbuzz-1.4.1-1  harfbuzz-icu-1.4.1-1  hunspell-1.5.4-1  icu-58.2-1  imagemagick-6.9.7.1-1
               iproute2-4.9.0-1  jasper-2.0.10-1  krb5-1.13.7-1  lib32-harfbuzz-1.3.1-2  lib32-icu-58.1-2  lib32-libpng-1.6.27-1  lib32-llvm-libs-3.9.1-2  lib32-mesa-13.0.3-1  lib32-mesa-libgl-13.0.3-1
               lib32-systemd-232-1  lib32-xz-5.2.3-1  libarchive-3.2.2-1  libcdr-0.1.3-2  libe-book-0.1.2-6  libelf-0.168-1  libevdev-1.5.6-1  libfbclient-2.5.6.27020-2  libgcrypt-1.7.5-1  libgpg-error-1.26-1
               libgweather-3.20.4-1  libinput-1.5.3-1  libixion-0.11.1-4  libmspub-0.1.2-6  libmwaw-0.3.9-1  libnewt-0.52.19-2  libnftnl-1.0.7-1  libnm-glib-1.4.4-1  liborcus-0.11.2-4  libplist-1.12-5
               libpng-1.6.27-1  libpsl-0.16.1-1  libreoffice-fresh-5.2.4-2  libssh-0.7.3-2  libsystemd-232-6  libteam-1.23-2  libtiff-4.0.7-2  libunistring-0.9.7-1  libutil-linux-2.29-2  libvisio-0.1.5-3
               libvoikko-4.0.2-2  libxml2-2.9.4+12+ge905f081-4  libxpm-3.5.12-1  linux-4.8.13-1  llvm-libs-3.9.1-2  logrotate-3.11.0-1  lpsolve-5.5.2.5-1  lvm2-2.02.168-1  lz4-1:1.7.4.2-1  man-db-2.7.6.1-2
               man-pages-4.09-1  mesa-13.0.3-1  mesa-libgl-13.0.3-1  minizip-1:1.2.8-7  mkinitcpio-busybox-1.25.1-1  mutter-3.22.2+6+g06f5b6b3e-1  nano-2.7.3-1  ncurses-6.0+20161224-1  networkmanager-1.4.4-1
               nodejs-7.4.0-1  npm-4.0.5-1  npth-1.3-1  nss-3.27.2-1  ocl-icd-2.2.10-1  oniguruma-6.1.3-1  openjpeg2-2.1.2-2  pacman-mirrorlist-20170106-1  perl-net-http-6.12-1  pinentry-1.0.0-1
               poppler-0.50.0-1  pygobject-devel-3.22.0-2  pygobject2-devel-2.28.6-13  python-3.6.0-1  python-atspi-2.20.2-2  python-chardet-2.3.0-3  python-gobject-3.22.0-2  python-lxml-3.7.1-2
               python-requests-2.12.4-2  python-urllib3-1.19.1-2  python-xdg-0.25-4  python2-2.7.13-1  python2-distutils-extra-2.39-2  python2-gobject2-2.28.6-13  qt5-base-5.7.1-1  qt5-x11extras-5.7.1-1
               raptor-2.0.15-5  readline-7.0.001-1  slang-2.3.1a-1  speech-dispatcher-0.8.5-2  speex-1.2.0-1  sqlite-3.16.1-1  sudo-1.8.19.p1-1  systemd-232-6  systemd-sysvcompat-232-6  tdb-1.3.12-1
               thunderbird-45.6.0-1  util-linux-2.29-2  virtualbox-5.1.12-1  virtualbox-host-dkms-5.1.12-1  webkit2gtk-2.14.2-2  webkitgtk2-2.4.11-3  wget-1.18-3  wine-2.0rc4-1  wpa_supplicant-1:2.6-4
               x265-2.2-1  xcb-proto-1.12-3  xcb-util-xrm-1.2-1  xf86-video-intel-1:2.99.917+746+g169c74f-1  xz-5.2.3-1  zeromq-4.2.0-1  zlib-1:1.2.8-7

Total Download Size:      2.05 MiB
Total Installed Size:  2508.46 MiB
Net Upgrade Size:        53.62 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 krb5-1.13.7-1-x86_64                                                                                1100.1 KiB  1515K/s 00:01 [#############################################################################] 100%
 libpsl-0.16.1-1-x86_64                                                                                49.8 KiB  4.86M/s 00:00 [#############################################################################] 100%
 jasper-2.0.10-1-x86_64                                                                               286.8 KiB  2.55M/s 00:00 [#############################################################################] 100%
 wget-1.18-3-x86_64                                                                                   544.9 KiB  1775K/s 00:00 [#############################################################################] 100%
 lib32-libpng-1.6.27-1-x86_64                                                                         120.3 KiB  5.11M/s 00:00 [#############################################################################] 100%
(148/148) checking keys in keyring                                                                                             [#############################################################################] 100%
(148/148) checking package integrity                                                                                           [#############################################################################] 100%
error: krb5: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/krb5-1.13.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: libpsl: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/libpsl-0.16.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: jasper: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/jasper-2.0.10-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: lib32-libpng: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-libpng-1.6.27-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: wget: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/wget-1.18-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded. 

As you can I see get an error from the

/var/cache/pacman/pkg/wget-1.18-3-x86_64.pkg.tar.xz

.
What am I supposed to do here?

Last edited by ChesSeu (2017-01-07 20:07:10)

Offline

#2 2017-01-07 20:02:51

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,259

Re: [solved] Errors occured, no packages were updated,

Update archlinux-keyring.

Offline

#3 2017-01-07 20:06:53

ChesSeu
Member
Registered: 2016-10-27
Posts: 18

Re: [solved] Errors occured, no packages were updated,

Thanks Scimmia! it worked.

Offline

Board footer

Powered by FluxBB