You are not logged in.

#1 2017-01-18 05:11:41

sipiri
Member
Registered: 2017-01-18
Posts: 3

[SOLVED] Bluetooth: "protocol not available"

<edit>
I'm an idiot and didn't follow all of the directions on the wiki.
The solution to my problem:

sudo pacman -S pulseaudio-bluetooth
sudo nano /etc/bluetooth/main.conf

add line "Enable=Source,Sink,Media,Socket" under [general]

Props to adesh and HilmTye for helping me with this
</edit>

So... yeah. I've spent twelve hours trying to solve this problem.
I can't connect with my device, but I can pair.

Device: Altec Lansing earbuds [ https://www.amazon.com/Altec-Lansing-MZ … B010UU5ND8 ]
System: computer=MSI-Ghost -> bios=GRUB -> os=ARCH [current] ->de= KDE [arch-repo_current]
I also have a whole bloatload of KDE apps- otherwise it's a clean install.

I've followed all directions specified on these two pages:
https://wiki.archlinux.org/index.php/bl … leshooting
https://bbs.archlinux.org/viewtopic.php?id=166678&p=2

I've made three attempts at this: One using modern methods, one using ancient methods, and one using both ancient and modern methods.

Here is a list of packages I've installed:

bluez
bluez-utils
pulseaudio-bluetooth
blueman
dbus 
alsa-plugins 
pulseaudio 
pulseaudio-alsa 
pavucontrol 
ponymix

Here is my error in console:

[bluetooth]# pair 00:25:DB:39:62:5B
Attempting to pair with 00:25:DB:39:62:5B
[CHG] Device 00:25:DB:39:62:5B Connected: yes
[CHG] Device 00:25:DB:39:62:5B Modalias: bluetooth:v0039p1582d0305
[CHG] Device 00:25:DB:39:62:5B UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 00:25:DB:39:62:5B ServicesResolved: yes
[CHG] Device 00:25:DB:39:62:5B Paired: yes
Pairing successful
[CHG] Device 00:25:DB:39:62:5B ServicesResolved: no
[CHG] Device 00:25:DB:39:62:5B Connected: no                                                                                                       
[bluetooth]# connect 00:25:DB:39:62:5B                                                                                                             
Attempting to connect to 00:25:DB:39:62:5B                                                                                                         
Failed to connect: org.bluez.Error.Failed

Here is my error in the "bluetooth devices" GUI (I think blueman installed the gui?)

Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not available...

Here is my error in the Pulse journal:

-- Logs begin at Tue 2017-01-17 20:47:01 CST, end at Tue 2017-01-17 22:28:10 CST. --
Jan 17 22:25:54 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 41927, resource id: 67108869, major code: 142 (Unknown), minor code: 3
Jan 17 22:25:54 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 42136, resource id: 69206021, major code: 142 (Unknown), minor code: 3
Jan 17 22:25:54 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 42258, resource id: 52428824, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:29 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 43015, resource id: 60817414, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:29 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 43082, resource id: 52428824, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:29 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 43237, resource id: 69206021, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:31 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 43363, resource id: 67108869, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:31 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 43412, resource id: 52428824, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:36 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 45347, resource id: 60817414, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:37 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 45476, resource id: 52428824, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:50 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 48651, resource id: 60817414, major code: 142 (Unknown), minor code: 3
Jan 17 22:26:51 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 48744, resource id: 52428824, major code: 142 (Unknown), minor code: 3
Jan 17 22:27:02 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 49039, resource id: 60817414, major code: 142 (Unknown), minor code: 3
Jan 17 22:27:38 squirrel bluetoothd[373]: a2dp-sink profile connect failed for 00:25:DB:39:62:5B: Protocol not available
Jan 17 22:27:42 squirrel kwin_x11[533]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 19626, resource id: 71303175, major code: 15 (QueryTree), minor code: 0
Jan 17 22:27:58 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 51526, resource id: 54525964, major code: 142 (Unknown), minor code: 3
Jan 17 22:27:58 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 51552, resource id: 69206021, major code: 142 (Unknow
Jan 17 22:27:58 squirrel plasmashell[542]: QXcbConnection: XCB error: 2 (BadValue), sequence: 51785, resource id: 52428824, major code: 142 (Unknow
Jan 17 22:28:10 squirrel sudo[1407]:   rachel : TTY=pts/2 ; PWD=/home/rachel ; USER=root ; COMMAND=/usr/bin/journalctl -n 20
Jan 17 22:28:10 squirrel sudo[1407]: pam_unix(sudo:session): session opened for user root by rachel(uid=0)

(googling suggests that the "XCB error" entries are related to a KDE bug, so I'm thinking they're not relevant? I'm pretty much an idiot though, so I shouldn't have biased you with my irrelevant opinion.)


tl;dr: My computer's insane inner-voices are all fairly unanimous: I'm missing bluetooth protocols.

This problem has a bounty of 12 cookies to the first man who points me toward the solution.

Last edited by sipiri (2017-01-18 19:38:33)

Offline

#2 2017-01-18 05:54:37

adesh
Member
Registered: 2016-10-05
Posts: 167

Re: [SOLVED] Bluetooth: "protocol not available"

You are missing this package

pulseaudio-bluetooth

Offline

#3 2017-01-18 08:21:03

sipiri
Member
Registered: 2017-01-18
Posts: 3

Re: [SOLVED] Bluetooth: "protocol not available"

adesh wrote:

You are missing this package

pulseaudio-bluetooth

Huh. So I was.

No changes though- same errors being reported in console, gui, and journal.

Offline

#4 2017-01-18 10:25:09

HiImTye
Member
From: Nanaimo, BC, Canada
Registered: 2012-05-09
Posts: 1,061

Re: [SOLVED] Bluetooth: "protocol not available"

did you follow these instructions, as well as these?

Offline

#5 2017-01-18 19:40:39

sipiri
Member
Registered: 2017-01-18
Posts: 3

Re: [SOLVED] Bluetooth: "protocol not available"

HiImTye wrote:

did you follow these instructions, as well as these?

That sorted it.

Thanks a million. You have seven days to drive to Oklahoma to claim your cookies.

Offline

Board footer

Powered by FluxBB