You are not logged in.

#1 2017-01-25 13:45:32

johhnyhax
Member
Registered: 2017-01-25
Posts: 5

Steam libGL errors

Hey, when i am opening steam-runtime on archlinux 64 bit it shows some errors:

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Notes: My GPU is Nvidia GTX 960. I installed all drivers.

Offline

#2 2017-01-25 13:53:52

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,834
Website

Re: Steam libGL errors

You installed all drivers? Why? Just install the driver you need for your card, and it's lib32- equivalent.

https://wiki.archlinux.org/index.php/NVIDIA


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

#3 2017-01-25 14:01:06

johhnyhax
Member
Registered: 2017-01-25
Posts: 5

Re: Steam libGL errors

WorMzy wrote:

You installed all drivers? Why? Just install the driver you need for your card, and it's lib32- equivalent.

https://wiki.archlinux.org/index.php/NVIDIA

Saying "all drivers" i mean nvidia drivers for my gpu and all those libs (lib32-mesa et cetera).

Offline

#4 2017-01-25 14:34:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Steam libGL errors

Be explicit, since you mention lib32-mesa I'm not sure you actually have installed them. You need lib32-nvidia-utils and lib32-nvidia-libgl

Offline

#5 2017-01-25 17:10:51

johhnyhax
Member
Registered: 2017-01-25
Posts: 5

Re: Steam libGL errors

V1del wrote:

Be explicit, since you mention lib32-mesa I'm not sure you actually have installed them. You need lib32-nvidia-utils and lib32-nvidia-libgl

i have installed 32-nvidia-libgl and problem is still same.

Last edited by johhnyhax (2017-01-25 18:52:21)

Offline

#6 2017-01-25 17:14:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Steam libGL errors

Have you rebooted? Can you post your Xorg log and the output of

glxinfo | grep OpenGL #glxinfo is part of mesa-demos
pacman -Qs nvidia
pacman -Qs mesa

Offline

#7 2017-01-25 17:18:07

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,834
Website

Re: Steam libGL errors

Okay, tell us more about your system. How did you install Arch? Which kernel are you booting? How did you install the nvidia driver (via pacman, or using the nvidia installer)? If you used pacman, did you install the right package for your kernel (e.g. nvidia-lts if you're running linux-lts)? Did you generate an xorg.conf using nvidia's config tool?

As well as that information, please post the output of

uname -a
pacman -Qs nvidia

Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

#8 2017-01-25 18:46:51

johhnyhax
Member
Registered: 2017-01-25
Posts: 5

Re: Steam libGL errors

V1del wrote:

Have you rebooted? Can you post your Xorg log and the output of

glxinfo | grep OpenGL #glxinfo is part of mesa-demos
pacman -Qs nvidia
pacman -Qs mesa
WorMzy wrote:

Okay, tell us more about your system. How did you install Arch? Which kernel are you booting? How did you install the nvidia driver (via pacman, or using the nvidia installer)? If you used pacman, did you install the right package for your kernel (e.g. nvidia-lts if you're running linux-lts)? Did you generate an xorg.conf using nvidia's config tool?

As well as that information, please post the output of

uname -a
pacman -Qs nvidia
[igor@archigor ~]$ uname -a
Linux archigor 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux
[igor@archigor ~]$ pacman -Qs nvidia
local/lib32-nvidia-utils 375.26-2
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.1.1-2
    Nvidia VDPAU library
local/nvidia 375.26-1
    NVIDIA drivers for linux
local/nvidia-libgl 375.26-2
    NVIDIA drivers libraries symlinks
local/nvidia-utils 375.26-2
    NVIDIA drivers utilities
[igor@archigor ~]$ pacman -Qs mesa
local/glu 9.0.0-4
    Mesa OpenGL Utility library
local/lib32-glu 9.0.0-3
    Mesa OpenGL utility library (32 bits)
local/lib32-libtxc_dxtn 1.0.1-5
    S3 Texture Compression (S3TC) library for Mesa (32-bit)
local/lib32-mesa 13.0.3-1
    an open-source implementation of the OpenGL specification (32-bit)
local/lib32-mesa-libgl 13.0.3-1
    Mesa 3-D graphics library (32-bit)
local/libtxc_dxtn 1.0.1-6
    S3 Texture Compression (S3TC) library for Mesa
local/mesa 13.0.3-1
    an open-source implementation of the OpenGL specification

Offline

#9 2017-01-25 19:45:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Steam libGL errors

You  have lib32-mesa-libgl installed, that's wrong, we don't tell you to be specific for fun. You need lib32-nvidia-libgl

Offline

#10 2017-01-25 20:06:50

johhnyhax
Member
Registered: 2017-01-25
Posts: 5

Re: Steam libGL errors

V1del wrote:

You  have lib32-mesa-libgl installed, that's wrong, we don't tell you to be specific for fun. You need lib32-nvidia-libgl

Thank you so much, this helped

Problem solved.

Offline

#11 2017-01-25 20:28:10

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Steam libGL errors

Don't forget to edit the title of your initial post to mark as SOLVED, also please make some effort with future questions, the end result of this has been answered indirectly in the first response (with the wiki link) and directly in the 2nd...

Offline

Board footer

Powered by FluxBB