You are not logged in.

#1 2017-01-27 02:07:53

vietphi
Member
Registered: 2017-01-27
Posts: 54

backlight auto reset to maximum brightness after reboot

I was followed Arch wiki Backlight .

when using command:

ls /sys/class/backlight

output: acpi_video0  and intel_backlight

check the system status:

systemctl status systemd-backlight@backlight:intel-backlight.service
systemctl status systemd-backlight@backlight:acpi_video0.service

both are active. I'm trying to disable acpi_video0 but it's will come active again after boot.

I want it to remember my last brightness state, save on shutdown and load on boot.

Currently I'm using xbacklight to change my screen brightness. My laptop model is Acer Aspire 4740

Sorry for my bad English. Thank for your help!!

Last edited by vietphi (2017-01-27 03:33:21)

Offline

#2 2017-01-27 03:30:13

circleface
Member
Registered: 2012-05-26
Posts: 639

Re: backlight auto reset to maximum brightness after reboot

How are you trying to disable it?  Please post the  exact commands you are using.

Offline

#3 2017-01-27 03:35:40

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

circleface wrote:

How are you trying to disable it?  Please post the  exact commands you are using.

I tried this:

 systemctl stop systemd-backlight@backlight:acpi_video0.service
 systemctl disable systemd-backlight@backlight:acpi_video0.service

But overall I want it to save my brightness on shutdown and restore it on boot.

Offline

#4 2017-01-27 04:30:38

circleface
Member
Registered: 2012-05-26
Posts: 639

Re: backlight auto reset to maximum brightness after reboot

Weird...  Do you use the kernel parameter "systemd.restore_state=" at all?  It is supposed to default to 1, which is what you want, but maybe it got turned to 0 instead.

Offline

#5 2017-01-27 06:07:15

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

i'm not touching anything related to "systemd.restore_state..."

Offline

#6 2017-01-30 02:33:15

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

circleface wrote:

Weird...  Do you use the kernel parameter "systemd.restore_state=" at all?  It is supposed to default to 1, which is what you want, but maybe it got turned to 0 instead.

Can you guide me how to access parameter "systemd.restore_state"?
thank you

Offline

#7 2017-01-30 03:18:59

circleface
Member
Registered: 2012-05-26
Posts: 639

Re: backlight auto reset to maximum brightness after reboot

Since I don't know what boot loader you are using I can't be very precise, but this page has instructions for each boot loader / manager.

Offline

#8 2017-01-30 03:26:30

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

circleface wrote:

Since I don't know what boot loader you are using I can't be very precise, but this page has instructions for each boot loader / manager.

I'm using GRUB, but counldn't find any related to "systemd" in

/boot/grub/grub.cfg

Offline

#9 2017-01-30 03:59:43

circleface
Member
Registered: 2012-05-26
Posts: 639

Re: backlight auto reset to maximum brightness after reboot

If you haven't set it manually, and it seems you did not, it should be fine because the default is what you want.  I'm not nearly enough of an expert to know what the problem is, but maybe someone else can help out and figure out the problem.

Offline

#10 2017-01-30 08:17:35

du0ngpv
Member
Registered: 2017-01-30
Posts: 4

Re: backlight auto reset to maximum brightness after reboot

#cat /etc/default/grub
...
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor"
...
#systemctl disable systemd-backlight@backlight:acpi_video0
///sys/class/backlight/acpi_video0 will be removed

that work for me . backlight restore at boot and you can control backlight by FN key too

Em cũng dùng acer


Windows is my life smile

Offline

#11 2017-01-30 21:08:56

adamlau
Member
Registered: 2009-01-30
Posts: 418

Re: backlight auto reset to maximum brightness after reboot

I prefer the udev method as it works all the time, every time. systemd-backlight does not  restore settings upon ungraceful exits.


Arch Linux + sway
Debian Testing + GNOME/sway
NetBSD 64-bit + Xfce

Offline

#12 2017-01-31 07:04:57

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

du0ngpv wrote:

#cat /etc/default/grub
...
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor"
...
#systemctl disable systemd-backlight@backlight:acpi_video0
///sys/class/backlight/acpi_video0 will be removed

that work for me . backlight restore at boot and you can control backlight by FN key too

Em cũng dùng acer

After stop, disable and restart the service is still back on "active". I don't know why?

Offline

#13 2017-01-31 07:05:48

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

adamlau wrote:

I prefer the udev method as it works all the time, every time. systemd-backlight does not  restore settings upon ungraceful exits.

udev method only allow you to set static brightness level, it isjj not save your last brightness right?

Offline

#14 2017-01-31 12:35:21

cafe
Member
Registered: 2014-03-20
Posts: 153

Re: backlight auto reset to maximum brightness after reboot

In my experience, only acpi_backlight=vendor was necessary to remove the acpi_video0 device

Offline

#15 2017-02-01 03:56:36

du0ngpv
Member
Registered: 2017-01-30
Posts: 4

Re: backlight auto reset to maximum brightness after reboot

vietphi wrote:

After stop, disable and restart the service is still back on "active". I don't know why?

Are you escape the colon (:) ?

#systemctl disable systemd-backlight@backlight\:acpi_video0.service


Windows is my life smile

Offline

#16 2017-02-01 07:23:00

vietphi
Member
Registered: 2017-01-27
Posts: 54

Re: backlight auto reset to maximum brightness after reboot

du0ngpv wrote:
vietphi wrote:

After stop, disable and restart the service is still back on "active". I don't know why?

Are you escape the colon (:) ?

#systemctl disable systemd-backlight@backlight\:acpi_video0.service

I think this solution didn't work for me.

Offline

Board footer

Powered by FluxBB