You are not logged in.

#1 2017-02-07 09:38:02

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 994

[SOLVED] Pulseaudio using more cpu at idle than expected

With arch linux running in several machine with the plasma desktop, I have noticed that listing cpu usage with top shows that pulseaudio is consuming over 5% of cpu even when there are no applications running that should be needing any sound channels open. It is the same in four different machines so I am guessing that this may be a general issue that others will have also.

According to /etc/pulse/daemon.conf - pulse is supposed to exit after 20 secs of idle - so that is clearly not happening. Killing pulseaudio and restarting it without logging out of plasma seems to work as expected in plasma, but the cpu usage for pulseaudio goes up again if logging out and back in to the plasma desktop.

Does anyone else see pulseaudio using cpu when it is not expected in the plasma desktop?  Is this a plasma bug? Is there a known workaround? Is this effect seen in other desktops than plasma?

I would appreciate any insight on this.

Last edited by mcloaked (2017-02-07 10:49:19)


Mike C

Offline

#2 2017-02-07 09:41:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,247

Re: [SOLVED] Pulseaudio using more cpu at idle than expected

Have you seen the recent notices on an autostart of speech-dispatcher (which has been added with QT 5.8) and most KDE applications having been compiled to make use of that? See here: https://bbs.archlinux.org/viewtopic.php?id=222567 speech-dispatcher streams will open and be constantly ready to receive data. a solution to disable is at the end of the linked thread.

Offline

#3 2017-02-07 10:29:28

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 994

Re: [SOLVED] Pulseaudio using more cpu at idle than expected

V1del wrote:

Have you seen the recent notices on an autostart of speech-dispatcher (which has been added with QT 5.8) and most KDE applications having been compiled to make use of that? See here: https://bbs.archlinux.org/viewtopic.php?id=222567 speech-dispatcher streams will open and be constantly ready to receive data. a solution to disable is at the end of the linked thread.

I hadn't been aware of that - thank you. The link you referenced does have a comment on how to disable speech-dispatcher which I will try out to see if that helps the problem of pulse using more cpu than expected.

In my case speech-dispatcher is also needed by chrome so I can't just remove that package but having a way to disable it is very helpful.

$ pacman -Qi speech-dispatcher
Name            : speech-dispatcher
Version         : 0.8.6-1
Description     : High-level device independent layer for speech synthesis interface
Architecture    : x86_64
URL             : http://www.freebsoft.org/speechd
Licenses        : GPL2  FDL
Groups          : None
Provides        : None
Depends On      : libltdl  python-xdg  dotconf  libpulse  libao
Optional Deps   : festival: Speech output using Festival
                  espeak: Speech output using ESpeak
                  pulseaudio: PulseAudio support [installed]
Required By     : google-chrome  kdeaccessibility-jovie  kdeaccessibility-kaccessible
Optional For    : qt5-speech
Conflicts With  : None
Replaces        : None
Installed Size  : 1414.00 KiB
Packager        : Sven-Hendrik Haase <sh@lutzhaase.com>
Build Date      : Mon 09 Jan 2017 22:55:41 GMT
Install Date    : Tue 10 Jan 2017 10:31:46 GMT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Edit: I have checked this fix as suggested by Arojas in the linked thread, and it does indeed resolve the problem.

Last edited by mcloaked (2017-02-07 10:49:07)


Mike C

Offline

#4 2017-02-07 19:29:46

c00ter
Member
From: Alaskan in Washington State
Registered: 2014-08-28
Posts: 290

Re: [SOLVED] Pulseaudio using more cpu at idle than expected

I do believe Antonio Rojas (@arojas) has removed speech-dispatcher as a google-chrome dependency, as he stated a couple days ago. I've since removed it and had no ill effects. Plasma5 DE, Chrome running Netflix/Hulu...

Regards


UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things. -- Doug Gwyn

Offline

#5 2017-02-07 20:58:40

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 994

Re: [SOLVED] Pulseaudio using more cpu at idle than expected

c00ter wrote:

I do believe Antonio Rojas (@arojas) has removed speech-dispatcher as a google-chrome dependency, as he stated a couple days ago. I've since removed it and had no ill effects. Plasma5 DE, Chrome running Netflix/Hulu...

Regards

Yes that is correct - the PKGBUILD for the current stable google-chrome package in AUR was changed 5 days ago to remove the dependency on speech-dispatcher. I had not re-installed google-chrome as the version number had not changed - but re-installing using the current PKGBUILD now shows for the package details after the re-install:

$ pacman -Qi speech-dispatcher
Name            : speech-dispatcher
Version         : 0.8.6-1
Description     : High-level device independent layer for speech synthesis interface
Architecture    : x86_64
URL             : http://www.freebsoft.org/speechd
Licenses        : GPL2  FDL
Groups          : None
Provides        : None
Depends On      : libltdl  python-xdg  dotconf  libpulse  libao
Optional Deps   : festival: Speech output using Festival
                  espeak: Speech output using ESpeak
                  pulseaudio: PulseAudio support [installed]
Required By     : kdeaccessibility-jovie  kdeaccessibility-kaccessible
Optional For    : qt5-speech
Conflicts With  : None
Replaces        : None
Installed Size  : 1414.00 KiB
Packager        : Sven-Hendrik Haase <sh@lutzhaase.com>
Build Date      : Mon 09 Jan 2017 22:55:41 GMT
Install Date    : Sat 14 Jan 2017 12:59:58 GMT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

So this seems now to be resolved nicely.


Mike C

Offline

Board footer

Powered by FluxBB