You are not logged in.

#1 2017-02-17 13:10:09

emb3dded
Member
Registered: 2017-02-08
Posts: 4

[Solved] USB DAC Audio not working

Hello

Im quite overwhelmed by the amount of configuration needed to get my Audioengine D1 USB DAC working. What i did:
Checked if DAC is recognized:

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7230000 irq 30
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 2 [D1             ]: USB-Audio - Audioengine D1
                      Audioengine Audioengine D1 at usb-0000:00:14.0-4, full speed

- Checked if module is loaded

$ lsmod | grep snd
snd_hda_codec_hdmi     45056  1
snd_usb_audio         155648  0
snd_usbmidi_lib        28672  1 snd_usb_audio
snd_rawmidi            28672  1 snd_usbmidi_lib
snd_seq_device         16384  1 snd_rawmidi
snd_hda_codec_realtek    69632  1
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
snd_hda_intel          32768  0
snd_soc_rt5640        110592  0
snd_soc_ssm4567        16384  0
snd_hda_codec         106496  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_soc_rl6231         16384  1 snd_soc_rt5640
snd_soc_core          188416  2 snd_soc_ssm4567,snd_soc_rt5640
snd_hda_core           65536  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_compress           20480  1 snd_soc_core
snd_hwdep              16384  2 snd_hda_codec,snd_usb_audio
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm                90112  8 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm_dmaengine,snd_hda_core,snd_soc_rt5640,snd_hda_codec_hdmi,snd_soc_core
snd_timer              28672  1 snd_pcm
snd                    69632  14 snd_compress,snd_hda_intel,snd_hwdep,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_soc_core,snd_pcm
soundcore              16384  1 snd
ac97_bus               16384  1 snd_soc_core
snd_soc_sst_acpi       16384  0
snd_soc_sst_match      16384  1 snd_soc_sst_acpi
usbcore               208896  10 usbhid,snd_usb_audio,usb_storage,ehci_hcd,xhci_pci,snd_usbmidi_lib,btusb,uas,xhci_hcd,ehci_pci

- Added user to audio group
- Configured D1 as default audio device

$ cat .asoundrc
defaults.ctl.!card "D1"

The problem is, when i open alsa-mixer from command line, i cannot change the output level if the D1 (the default card get selected as expected). There is just an empty bar:
http://imgur.com/a/UBZeO
In KDE: If i click on the Volume Icon i just have an empty section (Audio Volume / Devices)

Here is the complete alsa-info.sh output:
http://www.alsa-project.org/db/?f=e5aa5 … e34cfb579e

I imagine i forgot to configure something with pulseaudio? Any hints where to look at would be appreciated.

Regards

Last edited by emb3dded (2017-02-17 17:48:52)

Offline

#2 2017-02-17 13:45:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,669

Re: [Solved] USB DAC Audio not working

It's a DAC, it gets a digital signal, handling the volume is not part of that digital signal. that's what you have the DAC for. Which is why you can only enable or disable the output of the digital signal in alsamixer.
And since you only adjusted the default control device (ctl - what stuff like alsamixer shows and controls)  you haven't yet switched the default playback (pcm) device so you'd have to add the line

defaults.pcm.!card "D1"

as well.

If you want a software based volume you can either:

A) Start to use pulseaudio which will also fix KDE's volume mixer since that is using pulseaudio, which isn't running at the moment.
B) Configure the ALSA softvol plugin: http://www.alsa-project.org/alsa-doc/al … ns_softvol

If you want to start using pulseaudio, you will want to remove the .asoundrc you created and install pulseaudio-alsa and if it doesn't work after a reboot, post

sudo fuser -v /dev/snd/*
pacmd list-cards
pacmd list-sinks
pacmd list-sink-outputs #While attempting to play something

If you want to stay with ALSA only, only post the first command if the above fix doesn't already work (and install kmix for an ALSA based KDE mixer (and disable the default plasma-pa in the systray settings)).

Last edited by V1del (2017-02-17 15:23:28)

Offline

#3 2017-02-17 17:48:26

emb3dded
Member
Registered: 2017-02-08
Posts: 4

Re: [Solved] USB DAC Audio not working

Thanks V1del

defaults.pcm.!card "D1"

Did the trick. Yeah, i should have known that handling the volume is not part of the OS smile Quite embarrassing smile

Offline

Board footer

Powered by FluxBB