You are not logged in.

#1 2006-06-14 01:09:49

sf.
Member
Registered: 2006-04-29
Posts: 23

[Solved] Can't run ion3 (liblualib.so)

I installed ion3 with pacman, which also installed lua-5.1-1 but when I try to run ion3 I get the following error:

"ion3: error while loading shared libraries: liblualib.so: cannot open shared object file: No such file or directory"


How can I solve this probably very basic problem?

Offline

#2 2006-06-14 03:10:36

dk
Member
Registered: 2004-04-20
Posts: 106

Re: [Solved] Can't run ion3 (liblualib.so)

try making a symbolic link in /usr/lib

ln -s liblua.so.5.1 liblua.so

Offline

#3 2006-06-14 12:36:16

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 785
Website

Re: [Solved] Can't run ion3 (liblualib.so)

http://bugs.archlinux.org  --  for the [testing] lua problem.

Did you install ion3 through [community]?  If so that's my package, and it shouldn't be installing lua 5.1.

Offline

#4 2006-06-14 15:55:04

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: [Solved] Can't run ion3 (liblualib.so)

i get this problem too. and it's caused by using the testing version of lua with ion3. when i downgraded to the lua version in extra it fixed itself. symlink like dk suggested does not work.

maybe when i enabled the testing repo and -Syu lua upgraded itself too?

edit:
seems so from pacman.log

grep lua /var/log/pacman.log
[11/28/05 00:28] installed lua (5.0.2-1)
[06/14/06 14:52] upgraded lua (5.0.2-1 -> 5.1-1)
[06/14/06 16:42] upgraded lua (5.1-1 -> 5.1-1)
[06/14/06 17:00] upgraded lua (5.1-1 -> 5.0.2-1)

Codemac, why don't you update the ion3 build? it's ancient and maye the new build will build with the new lua build.


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#5 2006-06-14 18:44:23

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 785
Website

Re: [Solved] Can't run ion3 (liblualib.so)

It's not updated for 2 reasons.

1) lua 5.1 is in [testing].  NOTHING in community gets built against [testing].
2) Neotuli said he was moving ion3 up to [extra].  If he is, then it's his package/problem now, if he isn't, then the community package will be updated when lua 5.1 gets out of [testing]

Offline

#6 2006-06-14 21:25:49

sf.
Member
Registered: 2006-04-29
Posts: 23

Re: [Solved] Can't run ion3 (liblualib.so)

Problem solved by downgrading Lua.

Thanks

Offline

#7 2006-06-15 00:03:41

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: [Solved] Can't run ion3 (liblualib.so)

If so that's my package, and it shouldn't be installing lua 5.1.

Thought it was yours.

1) lua 5.1 is in [testing]. NOTHING in community gets built against [testing].

Never said so either. I'd still like an upgraded ion3 build built against the lua in extra, which i believe is the only one it's building against now.. ?

So neotuli or codemac, whoever it is: update the package please.


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#8 2006-06-15 03:48:10

dk
Member
Registered: 2004-04-20
Posts: 106

Re: [Solved] Can't run ion3 (liblualib.so)

codemac wrote:

http://bugs.archlinux.org  --  for the [testing] lua problem.

Did you install ion3 through [community]?  If so that's my package, and it shouldn't be installing lua 5.1.

codemac-

Isn't ion3 in community a darcs build. If so, the latest builds do need lua 5.1

To: ion-general@lists.berlios.de
From: Tuomo Valkonen <tuomov>
Subject:  Re: ion and lua 5.1
Date: Tue, 16 May 2006 17:31:01 +0000 (UTC)

Ion3 from Darcs now requires Lua 5.1. Remember to upgrade libextl-3
too.

Offline

#9 2006-06-15 06:34:10

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved] Can't run ion3 (liblualib.so)

dk wrote:
codemac wrote:

http://bugs.archlinux.org  --  for the [testing] lua problem.

Did you install ion3 through [community]?  If so that's my package, and it shouldn't be installing lua 5.1.

codemac-

Isn't ion3 in community a darcs build. If so, the latest builds do need lua 5.1

To: ion-general@lists.berlios.de
From: Tuomo Valkonen <tuomov>
Subject:  Re: ion and lua 5.1
Date: Tue, 16 May 2006 17:31:01 +0000 (UTC)

Ion3 from Darcs now requires Lua 5.1. Remember to upgrade libextl-3
too.

no, community is releases.

test1000, file a bug if it's the testing package, and if it's community, contact codemac directly, many TU's and developers do not read forums much (except maybe me tongue )

Offline

#10 2006-06-15 12:38:14

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 785
Website

Re: [Solved] Can't run ion3 (liblualib.so)

AAAAAAActually, it is a darcs build in the current [community] package because of how ion development works, it's better to make a darcs build a week after a development snapshot.

And yes dk, that's my exact point.  For a newer build to be made, it needs lua 5.1.  Lua 5.1 is in [testing], not [extra].

http://archlinux.org/packages.php?id=3181
see?  lua 5.0.2.

test1000 :

sf. wrote:

Problem solved by downgrading Lua.

Thanks

That means, *gasp*, it's not a problem with an outdated package!  Because it's not a testing package!  If you upgrade your lua to the one in testing, you need to rebuild the package with darcs!  OMG!  I was telling the truth the whole time!  It's amazing, I know.

Ion now builds against lua 5.1.  Until 5.1 is in [extra], you wont be seeing an ion update.  You can install lua 5.1 from testing, and build the package on your own, but you will probably break other packages that depend on lua.

Offline

#11 2006-06-15 12:52:42

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: [Solved] Can't run ion3 (liblualib.so)

Are you saying that it's technically impossible to update any ion3 version from darcs more recent than the one in repo against the lua in extra?

just checking.


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

#12 2006-06-15 13:02:37

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved] Can't run ion3 (liblualib.so)

test1000 wrote:

Are you saying that it's technically impossible to update any ion3 version from darcs more recent than the one in repo against the lua in extra?

just checking.

Yes. But, it shouldnt be too long before the lua in [testing] is moved to extra.

Offline

Board footer

Powered by FluxBB