You are not logged in.

#1 2017-02-24 21:20:58

xlurp
Member
Registered: 2017-02-24
Posts: 3

[SOLVED] No sound after pulseaudio / kernel upgrade

Hi all

I have upgraded a lot of packets yesterday and now i have no sound in my computer (games, vlc, smplayer, youtube, sound test from kde, ...)
I upgrade kernel and pulseaudio. And a lot of others programs.

My card :
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

lsmod | grep snd                                                                                                                                                                                                         
snd_hda_codec_analog    16384  1                                                                                                                                                                                                                   
snd_hda_codec_generic    69632  1 snd_hda_codec_analog                                                                                                                                                                                             
snd_hda_intel          32768  6                                                                                                                                                                                                                   
snd_hda_codec         106496  3 snd_hda_intel,snd_hda_codec_analog,snd_hda_codec_generic                                                                                                                                                           
snd_hda_core           65536  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_analog,snd_hda_codec_generic                                                                                                                                             
snd_hwdep              16384  1 snd_hda_codec                                                                                                                                                                                                     
snd_pcm                90112  5 snd_hda_intel,snd_hda_codec,snd_hda_core                                                                                                                                                                           
snd_timer              28672  1 snd_pcm                                                                                                                                                                                                           
snd                    69632  17 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_hda_codec_analog,snd_timer,snd_hda_codec_generic,snd_pcm
soundcore              16384  1 snd

uname -a
Linux oldquadtimer 4.9.11-1-ARCH #1 SMP PREEMPT Sun Feb 19 13:45:52 UTC 2017 x86_64 GNU/Linux


Alsamixer is not muted
pulseaudio launch correctly but no sound.
cables and 2 differents set of speakers check
pavucontrol show a silence bar who change.

I have nod idea where i can check log

thanks to your time and help

XlurP

PS : sorry for my (very ?) bad english

Last edited by xlurp (2017-02-25 10:12:30)

Offline

#2 2017-02-24 21:26:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,612

Re: [SOLVED] No sound after pulseaudio / kernel upgrade

post

sudo fuser -v /dev/snd/*
pacmd list-cards
pacmd list-sinks
pacmd list-sink-inputs

Offline

#3 2017-02-24 21:32:28

xlurp
Member
Registered: 2017-02-24
Posts: 3

Re: [SOLVED] No sound after pulseaudio / kernel upgrade

fuser -v /dev/snd/*

USER        PID ACCESS COMMAND
/dev/snd/controlC0:  michael    2400 F.... pulseaudio

pacmd list-cards

1 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_00_1b.0>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA Intel"
                alsa.long_card_name = "HDA Intel at 0xf9ff8000 irq 28"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "293e"
                device.product.name = "82801I (ICH9 Family) HD Audio Controller"
                device.form_factor = "internal"
                device.string = "0"
                device.description = "Built-in Audio"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 60, available: no)
                output:analog-stereo: Analog Stereo Output (priority 6000, available: no)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: no)
                output:analog-surround-21: Analog Surround 2.1 Output (priority 800, available: no)
                output:analog-surround-21+input:analog-stereo: Analog Surround 2.1 Output + Analog Stereo Input (priority 860, available: no)
                output:analog-surround-40: Analog Surround 4.0 Output (priority 700, available: no)
                output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (priority 760, available: no)
                output:analog-surround-41: Analog Surround 4.1 Output (priority 800, available: no)
                output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (priority 860, available: no)
                output:analog-surround-50: Analog Surround 5.0 Output (priority 700, available: no)
                output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (priority 760, available: no)
                output:analog-surround-51: Analog Surround 5.1 Output (priority 800, available: no)
                output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (priority 860, available: no)
                output:analog-surround-71: Analog Surround 7.1 Output (priority 700, available: no)
                output:analog-surround-71+input:analog-stereo: Analog Surround 7.1 Output + Analog Stereo Input (priority 760, available: no)
                output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
                output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5560, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <output:iec958-stereo+input:analog-stereo>
        sinks:
                alsa_output.pci-0000_00_1b.0.iec958-stereo/#0: Built-in Audio Digital Stereo (IEC958)
        sources:
                alsa_output.pci-0000_00_1b.0.iec958-stereo.monitor/#0: Monitor of Built-in Audio Digital Stereo (IEC958)
                alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Built-in Audio Analog Stereo
        ports:
                analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
                        properties:

                analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
                        properties:

                analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)

pacmd list-sinks

1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1b.0.iec958-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_MUTE_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9958
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 0
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
        card: 0 <alsa_card.pci-0000_00_1b.0>
        module: 6
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "AD1988B Digital"
                alsa.id = "AD1988B Digital"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "1"
                alsa.card = "0"
                alsa.card_name = "HDA Intel"
                alsa.long_card_name = "HDA Intel at 0xf9ff8000 irq 28"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "293e"
                device.product.name = "82801I (ICH9 Family) HD Audio Controller"
                device.form_factor = "internal"
                device.string = "iec958:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "iec958-stereo"
                device.profile.description = "Digital Stereo (IEC958)"
                device.description = "Built-in Audio Digital Stereo (IEC958)"
                alsa.mixer_name = "Analog Devices AD1988B"
                alsa.components = "HDA:11d4198b,1043829c,00100400"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

        active port: <iec958-stereo-output>

pacmd list-sink-inputs

0 sink input(s) available.

Offline

#4 2017-02-24 23:17:52

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,612

Re: [SOLVED] No sound after pulseaudio / kernel upgrade

Use [ code ] tags not [ quote  ] tags for posting command output. Your pulseaudio is playing to the digital out either use pavucontrol's configuration tab on the far right or

pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

to change that fact.

Offline

#5 2017-02-25 10:11:54

xlurp
Member
Registered: 2017-02-24
Posts: 3

Re: [SOLVED] No sound after pulseaudio / kernel upgrade

it's work :-D . a big big thanks
i do the command and after unmute channel with pavucontrol

Offline

Board footer

Powered by FluxBB