You are not logged in.

#1 2017-03-05 19:46:49

FallenSnow
Member
Registered: 2014-04-07
Posts: 33

kworker cpu0 pegged at 100%

Don't know what got updated but the last 2 days my cpu0 has been stuck at 100%. Tried both linux-4.9 and linux-ck-4.10, same issue. Hopefully someone can help shed some light on what the cause is and how to go about fixing it. Thank you.

# perf top
  53.01%  [kernel]                        [k] pci_conf1_read
   7.11%  [kernel]                        [k] acpi_ns_search_one_scope
   3.18%  [kernel]                        [k] acpi_os_read_port
   2.89%  [kernel]                        [k] acpi_os_write_port
   1.31%  [kernel]                        [k] _raw_spin_lock_irqsave
   1.13%  [kernel]                        [k] kmem_cache_free
   1.09%  [kernel]                        [k] kmem_cache_alloc
   1.03%  [kernel]                        [k] memset_erms
   0.99%  [kernel]                        [k] _raw_spin_unlock_irqrestore
   0.91%  [kernel]                        [k] io_apic_sync
   0.60%  [kernel]                        [k] acpi_ps_parse_loop
   0.46%  [kernel]                        [k] acpi_ns_lookup
   0.46%  [kernel]                        [k] acpi_ps_get_opcode_info
   0.46%  [kernel]                        [k] acpi_ut_repair_name
   0.45%  [kernel]                        [k] acpi_ps_create_op
   0.42%  [kernel]                        [k] acpi_ut_valid_name_char
   0.41%  [kernel]                        [k] acpi_ex_name_segment
   0.40%  [kernel]                        [k] acpi_ex_extract_from_field
   0.33%  [kernel]                        [k] acpi_ns_search_and_enter
   0.32%  [kernel]                        [k] acpi_ut_update_object_reference
   0.31%  [kernel]                        [k] __schedule
   0.30%  [kernel]                        [k] acpi_ps_alloc_op
   0.30%  [kernel]                        [k] acpi_ds_exec_end_op
   0.28%  [xhci_hcd]                      [k] xhci_irq

Offline

#2 2017-03-05 19:54:19

FallenSnow
Member
Registered: 2014-04-07
Posts: 33

Re: kworker cpu0 pegged at 100%

Got a list of the packages I installed the day this issue started.

libgpg-error-1.27-1                                         2017-03-04 16:48:45
libutil-linux-2.29.2-1                                      2017-03-04 16:48:45
tzdata-2017a-1                                              2017-03-04 16:48:45
nodejs-7.7.1-1                                              2017-03-04 16:48:46
mesa-17.0.1-1                                               2017-03-04 16:48:47
mesa-libgl-17.0.1-1                                         2017-03-04 16:48:47
python-setuptools-1:34.3.1-1                                2017-03-04 16:48:48
util-linux-2.29.2-1                                         2017-03-04 16:48:48
zstd-1.1.3-1                                                2017-03-04 16:48:48
blender-17:2.78.c-2                                         2017-03-04 16:48:53
gdm-3.22.2+6+g4c7af60f-1                                    2017-03-04 16:48:53
gnupg-2.1.19-1                                              2017-03-04 16:48:53
graphene-1.6.0-1                                            2017-03-04 16:48:53
iasl-20170224-1                                             2017-03-04 16:48:53
lib32-libx11-1.6.5-1                                        2017-03-04 16:48:53
libepoxy-1.4.1-1                                            2017-03-04 16:48:53
libgdm-3.22.2+6+g4c7af60f-1                                 2017-03-04 16:48:53
xorg-server-1.19.2-1                                        2017-03-04 16:48:53
xorg-server-common-1.19.2-1                                 2017-03-04 16:48:53
xorg-server-xwayland-1.19.2-1                               2017-03-04 16:48:53
lib32-mesa-17.0.1-1                                         2017-03-04 16:48:54
lib32-mesa-libgl-17.0.1-1                                   2017-03-04 16:48:54
lib32-util-linux-2.29.2-1                                   2017-03-04 16:48:54
libva-mesa-driver-17.0.1-1                                  2017-03-04 16:48:54
libvirt-3.1.0-1                                             2017-03-04 16:48:55
libvirt-python-3.1.0-1                                      2017-03-04 16:48:55
linux-lts-4.9.13-1                                          2017-03-04 16:49:01
linux-lts-headers-4.9.13-1                                  2017-03-04 16:49:06
mercurial-4.1.1-1                                           2017-03-04 16:49:07
mesa-vdpau-17.0.1-1                                         2017-03-04 16:49:07
nvidia-lts-378.13-3                                         2017-03-04 16:49:07
ovmf-1:r21243.3858b4a1ff-1                                  2017-03-04 16:49:08
python2-idna-2.4-1                                          2017-03-04 16:49:08
python2-setuptools-1:34.3.1-1                               2017-03-04 16:49:08
syslinux-6.03-7                                             2017-03-04 16:49:09
totem-3.22.1-1                                              2017-03-04 16:49:09
uglify-js-2.8.5-1                                           2017-03-04 16:49:09
vala-0.34.5-1                                               2017-03-04 16:49:09
wine-mono-4.7.0-1                                           2017-03-04 16:49:13
xf86-video-intel-1:2.99.917+760+ge9cd8c21-1                 2017-03-04 16:49:13
xorg-server-devel-1.19.2-1                                  2017-03-04 16:49:13
xorg-server-xephyr-1.19.2-1                                 2017-03-04 16:49:14
xorg-server-xnest-1.19.2-1                                  2017-03-04 16:49:14
zeitgeist-1.0+1+g1bcc8585-1                                 2017-03-04 16:49:14

Offline

#3 2017-03-10 19:44:45

jimnutt
Member
Registered: 2013-02-04
Posts: 4

Re: kworker cpu0 pegged at 100%

This appears to be a regression of an old problem. I've been seeing at as well and almost all the results I'm finding are from a year or more ago. If you do

sudo grep . -r /sys/firmware/acpi/interrupts

you should see a list of acpi interrupts and the number of times they've been called. Look for the gpeXX values with high numbers (more than about 20,000 or so). Those are the ones that are probably causing the problem. The command

sudo echo "disable" >/sys/firmware/acpi/interrupts/gpeXX"

(where XX is the number of an interrupt with a high value) should clear it up almost instantly. You can set up a systemd oneshot to run this on startup.

Offline

Board footer

Powered by FluxBB