You are not logged in.

#1 2017-03-10 09:31:20

hellmelt
Member
Registered: 2016-03-24
Posts: 4

[SOLVED] VMWare player 12.5.3 fails (wrong version of libstdc++)

I accepted the upgrade offer given by VMWare player, from 12.5.2 to 12.5.3. After the upgrade, vmplayer did not start.

Found this in vmware-apploader-*.log:

Unable to load libcurl.so.4 from libcurl.so.4: /usr/lib/vmware/lib/libstdc++.so.6/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/libicuuc.so.58)

Checked the shipped libstdc++:

strings /usr/lib/vmware/lib/libstdc++.so.6/libstdc++.so.6 | grep CXXABI
CXXABI_1.3
CXXABI_1.3.1
CXXABI_1.3.2
CXXABI_1.3.3

No version 1.3.8 there! I made a copy of /usr/lib/vmware/lib/libstdc++.so.6/libstdc++.so.6, and created a link to the system version of libstdc++.so.6:

sudo ln -s /usr/lib/libstdc++.so.6 libstdc++.so.6

(in wd /usr/lib/vmware/lib/libstdc++.so.6/)

vmplayer works again!

If you use this trick, I don't take responsibility for malfunctions in VMWare or your system.

Last edited by hellmelt (2017-03-10 09:32:39)

Offline

#2 2017-03-10 15:38:03

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,845

Re: [SOLVED] VMWare player 12.5.3 fails (wrong version of libstdc++)

I am glad it works for you but, in general, generating a symlink to a library with a different major revision number presents risks.  The major number changes when the API changes -- notably when new functions are added or when deprecated functions are removed.  The latter being the one that is going to bite you where you least expect.  Apparently there are no function calls missing from rev 6 that were in 4 that VMPlayer used.  Or were there ? and you have just not found them yet?

http://unix.stackexchange.com/questions … mbers-work

I post this as a caution to others trying this work around either for this case or others. 
Note that I have been known to do this as well, but I document it in my system notes so as to remind myself when things go south.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2017-03-15 08:01:22

hellmelt
Member
Registered: 2016-03-24
Posts: 4

Re: [SOLVED] VMWare player 12.5.3 fails (wrong version of libstdc++)

Also the upgrade to VMWare Player 12.5.4 results in the same issue. Same solution works again.

I agree that using wrong versions of a library is dangerous, but in this case the problems are all within libstdc++.so.6, and the internal(?) version of CXXABI. I think VMWare is building their player on a system with a more recent version of libstdc++.so.6 than the one they ship with the installer. libcurl.so.4 is just component emitting the error, I assume libcurl version 4 is built using libstdc++ version 6.

Offline

Board footer

Powered by FluxBB