You are not logged in.

#1 2017-03-26 16:58:06

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

[SOLVED] SDDM fails to load after switch to libglvnd

Hello,

I'm using Arch with KDE and (I was using) propietary nvidia drivers.

I updated the system some days ago (last prior update was on 2017-02-12),

[2017-03-22 00:27] [PACMAN] Running 'pacman -Syuw'
[2017-03-22 00:27] [PACMAN] synchronizing package lists
[2017-03-22 00:27] [PACMAN] starting full system upgrade
[2017-03-22 01:23] [PACMAN] Running 'pacman -Su'
[2017-03-22 01:23] [PACMAN] starting full system upgrade
[2017-03-22 01:26] [ALPM] running 'texinfo-remove.hook'...
[2017-03-22 01:26] [ALPM] transaction started
[2017-03-22 01:26] [ALPM] removed lib32-nvidia-340xx-libgl (340.101-1)
[2017-03-22 01:26] [ALPM] removed nvidia-340xx-libgl (340.101-1)
[2017-03-22 01:26] [ALPM] upgraded linux-api-headers (4.7-1 -> 4.10.1-1)
[2017-03-22 01:26] [ALPM] upgraded tzdata (2016j-1 -> 2017a-1)
[2017-03-22 01:26] [ALPM] upgraded iana-etc (20161101-1 -> 20170224-1)
[2017-03-22 01:26] [ALPM] upgraded glibc (2.24-2 -> 2.25-1)
[2017-03-22 01:26] [ALPM-SCRIPTLET] Generating locales...
[2017-03-22 01:26] [ALPM-SCRIPTLET]   en_GB.UTF-8... done
[2017-03-22 01:26] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2017-03-22 01:26] [ALPM-SCRIPTLET]   es_ES.UTF-8... done
[2017-03-22 01:26] [ALPM-SCRIPTLET] Generation complete.
[2017-03-22 01:26] [ALPM] upgraded gcc-libs (6.3.1-1 -> 6.3.1-2)
[2017-03-22 01:26] [ALPM] upgraded ncurses (6.0+20161224-1 -> 6.0+20170128-1)
[2017-03-22 01:26] [ALPM] upgraded readline (7.0.001-1 -> 7.0.003-1)
[2017-03-22 01:26] [ALPM] upgraded bash (4.4.011-2 -> 4.4.012-2)
[2017-03-22 01:26] [ALPM] upgraded libgpg-error (1.26-1 -> 1.27-1)
[2017-03-22 01:26] [ALPM] upgraded dbus (1.10.14-1 -> 1.10.16-1)
[2017-03-22 01:26] [ALPM] upgraded kmod (23-1 -> 24-1)
[2017-03-22 01:26] [ALPM] upgraded libutil-linux (2.29.1-1 -> 2.29.2-1)
[2017-03-22 01:26] [ALPM] upgraded keyutils (1.5.9-1 -> 1.5.10-1)
[2017-03-22 01:26] [ALPM] upgraded util-linux (2.29.1-1 -> 2.29.2-1)
[2017-03-22 01:26] [ALPM] upgraded libseccomp (2.3.1-1 -> 2.3.2-1)
[2017-03-22 01:26] [ALPM] upgraded bzip2 (1.0.6-5 -> 1.0.6-6)
[2017-03-22 01:26] [ALPM] upgraded libepoxy (1.4.0-1 -> 1.4.1-1)
[2017-03-22 01:26] [ALPM] upgraded pcre (8.39-2 -> 8.40-1)
[2017-03-22 01:26] [ALPM] upgraded glib2 (2.50.2-1 -> 2.50.3-1)
[2017-03-22 01:26] [ALPM] upgraded harfbuzz (1.4.2-1 -> 1.4.5-1)
[2017-03-22 01:26] [ALPM] upgraded xorg-mkfontdir (1.0.7-7 -> 1.0.7-8)
[2017-03-22 01:26] [ALPM] upgraded libx11 (1.6.4-1 -> 1.6.5-1)
[2017-03-22 01:26] [ALPM] upgraded xorg-server-common (1.19.1-1 -> 1.19.3-1)
[2017-03-22 01:26] [ALPM] upgraded libgudev (230-1 -> 231-1)
[2017-03-22 01:26] [ALPM] upgraded libwacom (0.22-1 -> 0.24-1)
[2017-03-22 01:26] [ALPM] upgraded libinput (1.6.1-1 -> 1.6.3-1)
[2017-03-22 01:26] [ALPM] upgraded xf86-input-libinput (0.24.0-1 -> 0.25.0-1)
[2017-03-22 01:26] [ALPM] upgraded wayland (1.12.0-1 -> 1.13.0-1)
[2017-03-22 01:26] [ALPM] upgraded fixesproto (5.0-3 -> 5.0+9+g4292ec1-1)
[2017-03-22 01:26] [ALPM] upgraded mesa (13.0.4-1 -> 17.0.1-2)
[2017-03-22 01:26] [ALPM] installed libglvnd (0.2.999+g4ba53457-1)
[2017-03-22 01:26] [ALPM] upgraded xorg-server (1.19.1-1 -> 1.19.3-1)
[2017-03-22 01:27] [ALPM] upgraded nvidia-340xx-utils (340.101-1 -> 340.102-8)
[2017-03-22 01:27] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2017-03-22 01:27] [ALPM] upgraded sqlite (3.16.2-1 -> 3.17.0-1)
[2017-03-22 01:27] [ALPM] upgraded tslib (1.5-1 -> 1.7-1)
[2017-03-22 01:27] [ALPM] upgraded p11-kit (0.23.2-1 -> 0.23.5-1)
[2017-03-22 01:27] [ALPM] upgraded gnutls (3.5.8-2 -> 3.5.10-1)
[2017-03-22 01:27] [ALPM] upgraded qt5-base (5.8.0-5 -> 5.8.0-7)
[2017-03-22 01:27] [ALPM] upgraded solid (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded shared-mime-info (1.7-1 -> 1.8-1)
[2017-03-22 01:27] [ALPM] upgraded kcoreaddons (5.30.1-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kwidgetsaddons (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kjobwidgets (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded ki18n (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kconfig (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kwindowsystem (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kcrash (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kdbusaddons (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kservice (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kglobalaccel (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kcompletion (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kauth (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kcodecs (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kguiaddons (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kconfigwidgets (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kitemviews (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded karchive (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kiconthemes (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded sonnet (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded gstreamer (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:27] [ALPM] upgraded orc (0.4.26-1 -> 0.4.26-2)
[2017-03-22 01:27] [ALPM] upgraded gst-plugins-base-libs (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:27] [ALPM] upgraded ktextwidgets (5.30.0-2 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded attica-qt5 (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kxmlgui (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kbookmarks (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded libxslt (1.1.29+23+geb1030d-1 -> 1.1.29+42+gac341cbd-1)
[2017-03-22 01:27] [ALPM] upgraded phonon-qt5 (4.9.1-1 -> 4.9.1-2)
[2017-03-22 01:27] [ALPM] upgraded knotifications (5.30.0-2 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded gnupg (2.1.18-1 -> 2.1.19-1)
[2017-03-22 01:27] [ALPM] upgraded gpgme (1.7.1-2 -> 1.8.0-2)
[2017-03-22 01:27] [ALPM] upgraded kwallet (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kinit (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded kio (5.30.0-1 -> 5.32.0-2)
[2017-03-22 01:27] [ALPM] upgraded kitemmodels (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:27] [ALPM] upgraded lzo (2.09-1 -> 2.10-1)
[2017-03-22 01:27] [ALPM] upgraded libmariadbclient (10.1.21-1 -> 10.1.22-1)
[2017-03-22 01:27] [ALPM] upgraded jemalloc (4.4.0-1 -> 4.5.0-1)
[2017-03-22 01:27] [ALPM] upgraded mariadb-clients (10.1.21-1 -> 10.1.22-1)
[2017-03-22 01:28] [ALPM] upgraded mariadb (10.1.21-1 -> 10.1.22-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kmime (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-mime (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kpackage (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kdeclarative (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kcmutils (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kunitconversion (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kemoticons (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kded (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kparts (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kdelibs4support (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kmailtransport (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kcalcore (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded syntax-highlighting (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kpimtextedit (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kidentitymanagement (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kcalutils (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kcontacts (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded pciutils (3.5.2-1 -> 3.5.4-1)
[2017-03-22 01:28] [ALPM] upgraded snappy (1.1.3-2 -> 1.1.4-1)
[2017-03-22 01:28] [ALPM] upgraded nss (3.28.1-1 -> 3.29.3-2)
[2017-03-22 01:28] [ALPM] upgraded protobuf (3.1.0-1 -> 3.2.0-1)
[2017-03-22 01:28] [ALPM] upgraded libssh (0.7.4-1 -> 0.7.4-2)
[2017-03-22 01:28] [ALPM] upgraded libva (1.7.3-1 -> 1.7.3-2)
[2017-03-22 01:28] [ALPM] upgraded opencore-amr (0.1.3-2 -> 0.1.4-1)
[2017-03-22 01:28] [ALPM] upgraded v4l-utils (1.10.1-1 -> 1.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded ca-certificates-utils (20160507-1 -> 20170307-1)
[2017-03-22 01:28] [ALPM] upgraded ca-certificates-mozilla (3.28.1-1 -> 3.29.3-2)
[2017-03-22 01:28] [ALPM] upgraded ca-certificates (20160507-1 -> 20170307-1)
[2017-03-22 01:28] [ALPM] upgraded curl (7.52.1-2 -> 7.53.1-1)
[2017-03-22 01:28] [ALPM] upgraded ffmpeg (1:3.2.2-2 -> 1:3.2.4-1)
[2017-03-22 01:28] [ALPM] upgraded qt5-webengine (5.8.0-1 -> 5.8.0-4)
[2017-03-22 01:28] [ALPM] upgraded prison (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-contacts (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-calendar (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded qgpgme (1.7.1-2 -> 1.8.0-2)
[2017-03-22 01:28] [ALPM] upgraded libkleo (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kactivities (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kwayland (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded plasma-framework (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded threadweaver (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded krunner (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-search (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kmbox (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kldap (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded libkdepim (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded knewstuff (5.30.1-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kimap (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded pimcommon (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded grantleetheme (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kdepim-apps-libs (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kholidays (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded calendarsupport (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-calendar-tools (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded mailimporter (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded libgravatar (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-notes (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded libdatrie (0.2.10-1 -> 0.2.10-2)
[2017-03-22 01:28] [ALPM] upgraded pango (1.40.3-2 -> 1.40.4-1)
[2017-03-22 01:28] [ALPM] upgraded gst-plugins-base (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:28] [ALPM] upgraded messagelib (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded mailcommon (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadi-import-wizard (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akonadiconsole (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded kontactinterface (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded knotifyconfig (5.30.0-2 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded ktexteditor (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:28] [ALPM] upgraded kde-syndication (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded akregator (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:28] [ALPM] upgraded alsa-utils (1.1.3-1 -> 1.1.3-2)
[2017-03-22 01:29] [ALPM] upgraded qt4 (4.8.7-12 -> 4.8.7-16)
[2017-03-22 01:29] [ALPM] upgraded qca-qt4 (2.1.1-7 -> 2.1.3-1)
[2017-03-22 01:29] [ALPM] upgraded jasper (2.0.10-1 -> 2.0.12-1)
[2017-03-22 01:29] [ALPM] upgraded phonon-qt4 (4.9.1-1 -> 4.9.1-2)
[2017-03-22 01:29] [ALPM] upgraded libvoikko (4.0.2-2 -> 4.1-1)
[2017-03-22 01:29] [ALPM] upgraded kdelibs (4.14.29-1 -> 4.14.30-1)
[2017-03-22 01:29] [ALPM] upgraded talloc (2.1.8-1 -> 2.1.9-1)
[2017-03-22 01:29] [ALPM] upgraded libbsd (0.8.3-1 -> 0.8.3-2)
[2017-03-22 01:29] [ALPM] upgraded libwbclient (4.5.4-1 -> 4.5.6-2)
[2017-03-22 01:29] [ALPM] upgraded cifs-utils (6.5-1 -> 6.7-2)
[2017-03-22 01:29] [ALPM] upgraded smbclient (4.5.4-1 -> 4.5.6-2)
[2017-03-22 01:29] [ALPM] upgraded oxygen-icons (1:5.30.0-1 -> 1:5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded kdebase-runtime (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded qjson (0.8.1-5 -> 0.9.0-1)
[2017-03-22 01:29] [ALPM] upgraded amarok (2.8.0-14 -> 2.8.0-15)
[2017-03-22 01:29] [ALPM] upgraded analitza (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded kpty (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded libarchive (3.2.2-4 -> 3.3.1-4)
[2017-03-22 01:29] [ALPM] upgraded ark (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded artikulate (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded atk (2.22+1+gd57f97d-1 -> 2.24.0-1)
[2017-03-22 01:29] [ALPM] upgraded gdk-pixbuf2 (2.36.4-1 -> 2.36.5-1)
[2017-03-22 01:29] [ALPM] upgraded gtk-update-icon-cache (3.22.7-2 -> 3.22.10-1)
[2017-03-22 01:29] [ALPM] upgraded audacity (2.1.2-3 -> 2.1.3-1)
[2017-03-22 01:29] [ALPM] upgraded libkcddb (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded libkcompactdisc (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded audiocd-kio (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded babl (0.1.18-1 -> 0.1.24-1)
[2017-03-22 01:29] [ALPM] upgraded poppler (0.51.0-1 -> 0.52.0-1)
[2017-03-22 01:29] [ALPM] upgraded poppler-qt5 (0.51.0-1 -> 0.52.0-1)
[2017-03-22 01:29] [ALPM] upgraded libzip (1.1.3-1 -> 1.2.0-1)
[2017-03-22 01:29] [ALPM] upgraded ebook-tools (0.2.2-3 -> 0.2.2-4)
[2017-03-22 01:29] [ALPM] upgraded kfilemetadata (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded kidletime (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded baloo (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded baloo-widgets (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded binutils (2.27-1 -> 2.28-1)
[2017-03-22 01:29] [ALPM] upgraded blinken (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded kxmlrpcclient (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded kblog (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded blogilo (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded bluez (5.43-2 -> 5.44-1)
[2017-03-22 01:29] [ALPM] upgraded bluez-qt (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded bluedevil (1:5.9.1-1 -> 1:5.9.3-1)
[2017-03-22 01:29] [ALPM] upgraded bluez-libs (5.43-2 -> 5.44-1)
[2017-03-22 01:29] [ALPM] upgraded bluez-plugins (5.43-2 -> 5.44-1)
[2017-03-22 01:29] [ALPM] upgraded bluez-utils (5.43-2 -> 5.44-1)
[2017-03-22 01:29] [ALPM] upgraded kdnssd (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded libkdegames (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded bomber (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded bovo (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:29] [ALPM] upgraded frameworkintegration (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:29] [ALPM] upgraded kdecoration (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:30] [ALPM] upgraded breeze-icons (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:30] [ALPM] upgraded breeze (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:30] [ALPM] upgraded breeze-gtk (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:30] [ALPM] upgraded python2-cssutils (1.0.1-2 -> 1.0.2-1)
[2017-03-22 01:30] [ALPM] upgraded python2-mechanize (0.2.5-4 -> 1:0.3.1-1)
[2017-03-22 01:30] [ALPM] upgraded python2-lxml (3.7.2-1 -> 3.7.3-1)
[2017-03-22 01:30] [ALPM] upgraded python2-pillow (4.0.0-2 -> 4.0.0-3)
[2017-03-22 01:30] [ALPM] upgraded sip (4.19-1 -> 4.19.1-1)
[2017-03-22 01:30] [ALPM] upgraded python2-sip (4.19-1 -> 4.19.1-1)
[2017-03-22 01:30] [ALPM] upgraded pyqt5-common (5.7.1-3 -> 5.8-2)
[2017-03-22 01:30] [ALPM] upgraded python2-pyqt5 (5.7.1-3 -> 5.8-2)
[2017-03-22 01:30] [ALPM] upgraded python2-psutil (5.1.2-1 -> 5.2.0-1)
[2017-03-22 01:30] [ALPM] upgraded python2-appdirs (1.4.0-5 -> 1.4.3-1)
[2017-03-22 01:30] [ALPM] upgraded python2-pyparsing (2.1.10-2 -> 2.2.0-1)
[2017-03-22 01:30] [ALPM] upgraded python2-setuptools (1:34.1.1-1 -> 1:34.3.2-1)
[2017-03-22 01:30] [ALPM] upgraded python2-chardet (2.3.0-3 -> 2.3.0-4)
[2017-03-22 01:30] [ALPM] upgraded calibre (2.79.0-1 -> 2.82.0-1)
[2017-03-22 01:30] [ALPM] upgraded libqalculate (0.9.10-3 -> 0.9.11-1)
[2017-03-22 01:30] [ALPM] upgraded ghostscript (9.20-4 -> 9.21-1)
[2017-03-22 01:30] [ALPM] upgraded cantor (16.12.2-1 -> 16.12.3-2)
[2017-03-22 01:30] [ALPM] upgraded kdesu (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:30] [ALPM] upgraded cervisia (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded cryptsetup (1.7.3-1 -> 1.7.4-1)
[2017-03-22 01:30] [ALPM] upgraded dnssec-anchors (20150403-1 -> 20170228-1)
[2017-03-22 01:30] [ALPM] upgraded kjs (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:30] [ALPM] upgraded khtml (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:30] [ALPM] upgraded kio-extras (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded kuiserver (5.9.1-1 -> 5.9.3-2)
[2017-03-22 01:30] [ALPM] upgraded dolphin (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded dolphin-plugins (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded dosfstools (4.0-3 -> 4.1-1)
[2017-03-22 01:30] [ALPM] upgraded dragon (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded guile (2.0.13-2 -> 2.0.14-1)
[2017-03-22 01:30] [ALPM] upgraded drkonqi (5.9.1-1 -> 5.9.3-2)
[2017-03-22 01:30] [ALPM] upgraded eventviews (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded ffmpeg2.8 (2.8.9-2 -> 2.8.11-1)
[2017-03-22 01:30] [ALPM] upgraded ffmpegthumbs (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded file (5.29-1 -> 5.30-1)
[2017-03-22 01:30] [ALPM] upgraded filelight (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:30] [ALPM] upgraded json-glib (1.2.2+4+gd725fb5-1 -> 1.2.6+7+gf98d547-1)
[2017-03-22 01:30] [ALPM] upgraded gtk3 (3.22.7-2 -> 3.22.10-1)
[2017-03-22 01:30] [ALPM] upgraded startup-notification (0.12-4 -> 0.12-5)
[2017-03-22 01:30] [ALPM] upgraded noto-fonts (20170112-1 -> 20170307-2)
[2017-03-22 01:31] [ALPM] upgraded firefox (51.0.1-1 -> 52.0.1-1)
[2017-03-22 01:31] [ALPM] upgraded flex (2.6.3-1 -> 2.6.3-2)
[2017-03-22 01:31] [ALPM] upgraded gcc (6.3.1-1 -> 6.3.1-2)
[2017-03-22 01:31] [ALPM] upgraded gimp (2.8.18-4 -> 2.8.20-1)
[2017-03-22 01:31] [ALPM] upgraded git (2.11.1-1 -> 2.12.0-1)
[2017-03-22 01:31] [ALPM] upgraded gparted (0.27.0-1 -> 0.28.1-1)
[2017-03-22 01:31] [ALPM] upgraded granatier (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded grantlee-editor (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded graphene (1.4.0-1 -> 1.6.0-1)
[2017-03-22 01:31] [ALPM] upgraded grep (2.27-1 -> 3.0-1)
[2017-03-22 01:31] [ALPM] upgraded grub (1:2.02.rc1-1 -> 1:2.02.rc2-1)
[2017-03-22 01:31] [ALPM] upgraded gst-libav (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:31] [ALPM] upgraded gst-plugins-bad (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:31] [ALPM] upgraded gst-plugins-good (1.10.3-1 -> 1.10.4-1)
[2017-03-22 01:31] [ALPM] upgraded libkipi (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded libraw (0.18.0-1 -> 0.18.2-1)
[2017-03-22 01:31] [ALPM] upgraded libkdcraw (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded gwenview (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded harfbuzz-icu (1.4.2-1 -> 1.4.5-1)
[2017-03-22 01:31] [ALPM] installed hunspell-en_US (2017.01.22-2)
[2017-03-22 01:31] [ALPM] installed hunspell-en_GB (2017.01.22-2)
[2017-03-22 01:31] [ALPM] upgraded hunspell-en (2016.11.20-1 -> 2017.01.22-2)
[2017-03-22 01:31] [ALPM] upgraded hwloc (1.11.5-1 -> 1.11.6-1)
[2017-03-22 01:31] [ALPM] upgraded imagemagick (6.9.7.7-1 -> 6.9.8.2-1)
[2017-03-22 01:31] [ALPM] upgraded incidenceeditor (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:31] [ALPM] upgraded poppler-glib (0.51.0-1 -> 0.52.0-1)
[2017-03-22 01:31] [ALPM] upgraded potrace (1.13-1 -> 1.14-1)
[2017-03-22 01:31] [ALPM] upgraded inkscape (0.92.0-6 -> 0.92.1-1)
[2017-03-22 01:31] [ALPM] upgraded intel-tbb (2017_20161128-1 -> 2017_20170226-1)
[2017-03-22 01:31] [ALPM] upgraded iproute2 (4.9.0-1 -> 4.10.0-2)
[2017-03-22 01:31] [ALPM] upgraded jansson (2.9-1 -> 2.10-1)
[2017-03-22 01:32] [ALPM] upgraded jre7-openjdk-headless (7.u111_2.6.7-1 -> 7.u131_2.6.9-1)
[2017-03-22 01:32] [ALPM] upgraded jre7-openjdk (7.u111_2.6.7-1 -> 7.u131_2.6.9-1)
[2017-03-22 01:32] [ALPM] upgraded signon-kwallet-extension (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded signon-ui (0.17+15.10.20150810-2 -> 0.17+20150611-1)
[2017-03-22 01:32] [ALPM] upgraded kaccounts-integration (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kaccounts-providers (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kactivities-stats (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:32] [ALPM] upgraded kactivitymanagerd (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded kross (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:32] [ALPM] upgraded kalarmcal (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdepim-runtime (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kaddressbook (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kalarm (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kalgebra (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kplotting (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:32] [ALPM] upgraded kalzium (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libgphoto2 (2.5.11-1 -> 2.5.12-1)
[2017-03-22 01:32] [ALPM] upgraded kamera (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdeedu-data (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libkeduvocdocument (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kanagram (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kapman (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kapptemplate (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kate (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded katomic (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kblackbox (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kblocks (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kbounce (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kbreakout (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kbruch (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kcalc (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kcharselect (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kcolorchooser (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kcron (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kde-cli-tools (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded kde-dev-scripts (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kde-gtk-config (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded libao (1.2.0-1 -> 1.2.2-1)
[2017-03-22 01:32] [ALPM] upgraded kdeaccessibility-jovie (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdeaccessibility-kaccessible (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdeaccessibility-kmag (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdeaccessibility-kmousetool (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdeaccessibility-kmouth (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdebugsettings (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libkmahjongg (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kajongg (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kgoldrunner (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kigo (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kolf (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-konquest (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kreversi (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-ksirk (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-ksnakeduel (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kspaceduel (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-ksudoku (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-kubrick (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-lskat (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegames-palapeli (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libnl (3.2.29-1 -> 3.2.29-2)
[2017-03-22 01:32] [ALPM] upgraded kdegraphics-ksaneplugin (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegraphics-mobipocket (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libkexiv2 (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdegraphics-thumbnailers (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdemultimedia-juk (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdemultimedia-kmix (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdemultimedia-kscd (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdenetwork-filesharing (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdenetwork-kget (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdenetwork-kopete (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdenetwork-kppp (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdenetwork-zeroconf-ioslave (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded mlt (6.4.1-3 -> 6.4.1-4)
[2017-03-22 01:32] [ALPM] upgraded kdenlive (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded libktnef (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kdepim-addons (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:32] [ALPM] upgraded kjsembed (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:32] [ALPM] upgraded libksysguard (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded milou (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded kscreenlocker (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded kwin (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded plasma-integration (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:32] [ALPM] upgraded plasma-workspace (5.9.1-1 -> 5.9.3-2)
[2017-03-22 01:33] [ALPM] upgraded kdeplasma-addons (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdesdk-dev-utils (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdesdk-kcachegrind (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdesdk-thumbnailers (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdeutils-kremotecontrol (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdeutils-sweeper (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdewebdev-kfilereplace (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdewebdev-kimagemapeditor (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded tidy (5.2.0-1 -> 5.4.0-1)
[2017-03-22 01:33] [ALPM] upgraded kdewebdev-klinkstatus (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdewebdev-kommander (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdewebkit (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:33] [ALPM] upgraded kdf (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdialog (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdiamond (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kdoctools (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:33] [ALPM] upgraded keditbookmarks (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kfind (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kfloppy (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kfourinline (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kgamma5 (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kgeography (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kgpg (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded khangman (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded khelpcenter (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded khotkeys (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kig (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded killbots (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kinfocenter (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kiriki (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kiten (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kjumpingcube (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kleopatra (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded klettres (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded klickety (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded klines (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmahjongg (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmail-account-wizard (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded mbox-importer (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded libksieve (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded pim-sieve-editor (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded pim-storage-service-manager (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmail (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmenuedit (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmines (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kmplot (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded knavalbattle (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded knetwalk (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded knotes (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kollision (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded libksane (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kolourpaint (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded libkomparediff2 (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kompare (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded konqueror (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded konsole (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kontact (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded korganizer (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kpatience (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kpeople (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:33] [ALPM] upgraded kqtquickcharts (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded krdc (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded krfb (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kruler (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded libkscreen (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kscreen (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kshisen (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ksquares (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ksshaskpass (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kstars (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ksysguard (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded ksystemlog (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kteatime (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ktimer (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ktouch (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded ktuberling (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kturtle (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwallet-pam (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwalletmanager (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwave (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwayland-integration (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwordquiz (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwrite (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:33] [ALPM] upgraded kwrited (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-glibc (2.24-2 -> 2.25-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-gcc-libs (6.3.1-1 -> 6.3.1-2)
[2017-03-22 01:33] [ALPM] upgraded lib32-dbus (1.10.14-1 -> 1.10.16-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-util-linux (2.29.1-1 -> 2.29.2-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-e2fsprogs (1.43.3-1 -> 1.43.4-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-flac (1.3.1-2 -> 1.3.2-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-libgudev (230-2 -> 231-1)
[2017-03-22 01:33] [ALPM] upgraded libmikmod (3.3.9-1 -> 3.3.10-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-libx11 (1.6.4-1 -> 1.6.5-1)
[2017-03-22 01:33] [ALPM] upgraded lib32-libmikmod (3.3.9-1 -> 3.3.10-1)
[2017-03-22 01:33] [ALPM] upgraded libnm (1.6.0-4 -> 1.6.2-3)
[2017-03-22 01:33] [ALPM] upgraded libnm-glib (1.6.0-4 -> 1.6.2-3)
[2017-03-22 01:34] [ALPM] upgraded lib32-sqlite (3.16.2-1 -> 3.17.0-1)
[2017-03-22 01:34] [ALPM] upgraded lib32-libtasn1 (4.9-1 -> 4.10-1)
[2017-03-22 01:34] [ALPM] upgraded lib32-libnm-glib (1.6.0-1 -> 1.6.2-1)
[2017-03-22 01:34] [ALPM] upgraded lib32-wayland (1.12.0-1 -> 1.13.0-1)
[2017-03-22 01:34] [ALPM] installed lib32-libglvnd (0.2.999+g4ba53457-1)
[2017-03-22 01:34] [ALPM] upgraded lib32-mesa (13.0.4-1 -> 17.0.1-2)
[2017-03-22 01:34] [ALPM] upgraded lib32-nvidia-340xx-utils (340.101-1 -> 340.102-3)
[2017-03-22 01:34] [ALPM] upgraded lib32-v4l-utils (1.10.1-1 -> 1.12.3-1)
[2017-03-22 01:34] [ALPM] upgraded libdvbpsi (1:1.3.0-1 -> 1:1.3.1-1)
[2017-03-22 01:34] [ALPM] upgraded libfbclient (2.5.6.27020-2 -> 2.5.7.27050-1)
[2017-03-22 01:34] [ALPM] upgraded libmatroska (1.4.5-1 -> 1.4.7-1)
[2017-03-22 01:34] [ALPM] upgraded libnewt (0.52.19-2 -> 0.52.19-3)
[2017-03-22 01:34] [ALPM] warning: /etc/security/pwquality.conf installed as /etc/security/pwquality.conf.pacnew
[2017-03-22 01:34] [ALPM] upgraded libpwquality (1.3.0-1 -> 1.3.0-2)
[2017-03-22 01:34] [ALPM] upgraded libreoffice-fresh (5.3.0-2 -> 5.3.1-1)
[2017-03-22 01:34] [ALPM] upgraded libreoffice-fresh-en-GB (5.3.0-1 -> 5.3.1-1)
[2017-03-22 01:34] [ALPM] upgraded libreoffice-fresh-es (5.3.0-1 -> 5.3.1-1)
[2017-03-22 01:34] [ALPM] upgraded libupnp (1.6.20-1 -> 1.6.21-1)
[2017-03-22 01:35] [ALPM] upgraded linux-firmware (20161222.4b9559f-2 -> 20170309.695f2d6-1)
[2017-03-22 01:35] [ALPM] upgraded mkinitcpio (22-1 -> 23-1)
[2017-03-22 01:35] [ALPM] upgraded linux (4.9.8-1 -> 4.10.4-1)
[2017-03-22 01:35] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-03-22 01:35] [ALPM] upgraded linux-lts (4.4.48-1 -> 4.9.16-1)
[2017-03-22 01:35] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-03-22 01:35] [ALPM] upgraded lokalize (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:35] [ALPM] upgraded man-pages (4.09-1 -> 4.10-3)
[2017-03-22 01:35] [ALPM] upgraded marble-data (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:35] [ALPM] installed marble-common (16.12.3-1)
[2017-03-22 01:35] [ALPM] upgraded marble (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:35] [ALPM] upgraded mdadm (3.4-1 -> 4.0-1)
[2017-03-22 01:35] [ALPM] upgraded minuet (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:35] [ALPM] upgraded modemmanager-qt (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:35] [ALPM] upgraded nano (2.7.4-1 -> 2.7.5-1)
[2017-03-22 01:35] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/
filesystem: 755  package: 700
[2017-03-22 01:35] [ALPM] upgraded networkmanager (1.6.0-4 -> 1.6.2-3)
[2017-03-22 01:35] [ALPM] upgraded networkmanager-qt (5.30.0-1 -> 5.32.0-1)
[2017-03-22 01:35] [ALPM] upgraded nvidia-340xx (340.101-10 -> 340.102-5)
[2017-03-22 01:35] [ALPM-SCRIPTLET] In order to use nvidia module, reboot the system.
[2017-03-22 01:35] [ALPM] upgraded nvidia-340xx-lts (340.101-3 -> 340.102-5)
[2017-03-22 01:35] [ALPM] upgraded qscintilla-qt5 (2.9.4-1 -> 2.10-1)
[2017-03-22 01:35] [ALPM] upgraded openmpi (1.10.5-1 -> 1.10.6-1)
[2017-03-22 01:36] [ALPM] upgraded octave (4.2.0-1 -> 4.2.1-4)
[2017-03-22 01:36] [ALPM] upgraded qca-qt5 (2.1.1-7 -> 2.1.3-1)
[2017-03-22 01:36] [ALPM] upgraded okteta (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded okular (16.12.2-1 -> 16.12.3-2)
[2017-03-22 01:36] [ALPM] upgraded openresolv (3.8.1-1 -> 3.9.0-1)
[2017-03-22 01:36] [ALPM] upgraded oxygen (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2017-03-22 01:36] [ALPM] upgraded pacman-mirrorlist (20170201-1 -> 20170316-1)
[2017-03-22 01:36] [ALPM] upgraded parley (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded phonon-qt4-vlc (0.9.0-1 -> 0.9.1-1)
[2017-03-22 01:36] [ALPM] upgraded phonon-qt5-vlc (0.9.0-1 -> 0.9.1-1)
[2017-03-22 01:36] [ALPM] upgraded picmi (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded pim-data-exporter (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded pkcs11-helper (1.21-1 -> 1.22-1)
[2017-03-22 01:36] [ALPM] upgraded polkit-kde-agent (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded systemsettings (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] installed knetattach (5.9.3-4)
[2017-03-22 01:36] [ALPM] upgraded plasma-desktop (5.9.1-2 -> 5.9.3-4)
[2017-03-22 01:36] [ALPM] upgraded plasma-nm (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded plasma-workspace-wallpapers (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded plasma-pa (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded plasma-sdk (5.9.1-1 -> 5.9.3-2)
[2017-03-22 01:36] [ALPM] upgraded user-manager (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded sddm-kcm (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] upgraded powerdevil (5.9.1-1 -> 5.9.3-1)
[2017-03-22 01:36] [ALPM] installed archlinux-appstream-data (20170223-1)
[2017-03-22 01:36] [ALPM] installed kirigami2 (2.0.0-1)
[2017-03-22 01:36] [ALPM] installed discover (5.9.3-2)
[2017-03-22 01:36] [ALPM] upgraded plasma-meta (5.9-1 -> 5.9-2)
[2017-03-22 01:36] [ALPM] upgraded poxml (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded print-manager (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded python-appdirs (1.4.0-5 -> 1.4.3-1)
[2017-03-22 01:36] [ALPM] upgraded python-pyparsing (2.1.10-2 -> 2.2.0-1)
[2017-03-22 01:36] [ALPM] upgraded python-setuptools (1:34.1.1-1 -> 1:34.3.2-1)
[2017-03-22 01:36] [ALPM] upgraded python-chardet (2.3.0-3 -> 2.3.0-4)
[2017-03-22 01:36] [ALPM] upgraded python-sip (4.19-1 -> 4.19.1-1)
[2017-03-22 01:36] [ALPM] upgraded python-pyqt5 (5.7.1-3 -> 5.8-2)
[2017-03-22 01:36] [ALPM] upgraded qutebrowser (0.9.1-4 -> 0.10.1-1)
[2017-03-22 01:36] [ALPM] upgraded rocs (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded sed (4.3-1 -> 4.4-1)
[2017-03-22 01:36] [ALPM] upgraded spectacle (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded step (16.12.2-1 -> 16.12.3-2)
[2017-03-22 01:36] [ALPM] upgraded svgpart (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded t1lib (5.1.2-5 -> 5.1.2-6)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-accounts-kcm (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-approver (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-common-internals (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-auth-handler (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-call-ui (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-contact-list (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-contact-runner (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-desktop-applets (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-filetransfer-handler (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-integration-module (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-send-file (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded telepathy-kde-text-ui (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded umbrello (16.12.2-1 -> 16.12.3-1)
[2017-03-22 01:36] [ALPM] upgraded vim-runtime (8.0.0314-1 -> 8.0.0427-1)
[2017-03-22 01:36] [ALPM] upgraded vim (8.0.0314-1 -> 8.0.0427-1)
[2017-03-22 01:36] [ALPM] upgraded vulkan-icd-loader (1.0.39.0-1 -> 1.0.42.0-1)
[2017-03-22 01:36] [ALPM] upgraded webkit2gtk (2.14.4-1 -> 2.14.5-1)
[2017-03-22 01:36] [ALPM] upgraded xf86-video-nouveau (1.0.13-2 -> 1.0.14-1)
[2017-03-22 01:37] [ALPM] upgraded xfsprogs (4.9.0-1 -> 4.10.0-1)
[2017-03-22 01:37] [ALPM] upgraded zsh-completions (0.22.0-1 -> 0.23.0-2)
[2017-03-22 01:37] [ALPM] transaction completed
[2017-03-22 01:37] [ALPM] running '99-linux-lts.hook'...
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Starting build: 4.9.16-1-lts
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Starting build: 4.9.16-1-lts
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-22 01:37] [ALPM] running '99-linux.hook'...
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Starting build: 4.10.4-1-ARCH
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> Starting build: 4.10.4-1-ARCH
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2017-03-22 01:37] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2017-03-22 01:37] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-22 01:38] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-22 01:38] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-22 01:38] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-22 01:38] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2017-03-22 01:38] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-22 01:38] [ALPM] running 'fontconfig.hook'...
[2017-03-22 01:38] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2017-03-22 01:38] [ALPM] running 'glib-compile-schemas.hook'...
[2017-03-22 01:38] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2017-03-22 01:38] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-03-22 01:38] [ALPM] running 'lib32-fontconfig.hook'...
[2017-03-22 01:38] [ALPM] running 'systemd-hwdb.hook'...
[2017-03-22 01:38] [ALPM] running 'systemd-sysusers.hook'...
[2017-03-22 01:38] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-03-22 01:38] [ALPM] running 'systemd-update.hook'...
[2017-03-22 01:38] [ALPM] running 'texinfo-install.hook'...
[2017-03-22 01:38] [ALPM] running 'update-appstream-index.hook'...
[2017-03-22 01:38] [ALPM-SCRIPTLET] AppStream cache update completed successfully.
[2017-03-22 01:38] [ALPM] running 'update-ca-trust.hook'...
[2017-03-22 01:38] [ALPM] running 'update-desktop-database.hook'...
[2017-03-22 01:38] [ALPM] running 'update-mime-database.hook'...
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-alchemy'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cache'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-ascii'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-binary'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-table'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cdx'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cdxml'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-chem3d'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cif'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cml'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-daylight-smiles'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-dmol'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gamess-input'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gamess-output'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gaussian-input'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gaussian-log'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-genbank'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gulp'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-hin'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-inchi'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-inchi-xml'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-jcamp-dx'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-macromodel-input'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-molfile'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-rdfile'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-rxnfile'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-sdfile'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-tgf'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mmcif'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mol2'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-graph'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-input'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-out'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-car'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-hessian'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-mdf'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-msi'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1-binary'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1-xml'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-pdb'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-shelx'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-vmd'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-xyz'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'all/all'
[2017-03-22 01:38] [ALPM-SCRIPTLET] Unknown media type in type 'all/allfiles'
[2017-03-22 01:38] [ALPM] running 'xorg-mkfontdir.hook'...

where you can see that there is a switch from nvidia-340xx-libgl to libglvnd. Now, when I power on the computer, it gets stucked in the screen previous to SDDM (it was a black screen at the beginning, when I had propietary drivers).

If I try to see what's hapenning with SDDM,

$ systemctl status sddm.service
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Sun 2017-03-26 17:34:45 CEST; 3min 6s ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
  Process: 478 ExecStart=/usr/bin/sddm (code=dumped, signal=SEGV)
 Main PID: 478 (code=dumped, signal=SEGV)

Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):1:  bad "remove" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):2:  bad "add" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):1:  bad "remove" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):2:  bad "add" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):1:  bad "remove" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):2:  bad "add" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):1:  bad "remove" command line
Mar 26 17:34:45 ArchSony sddm[478]: /usr/bin/xauth: (stdin):2:  bad "add" command line
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Main process exited, code=dumped, status=11/SEGV
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Unit entered failed state.
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Failed with result 'core-dump'.
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Mar 26 17:34:45 ArchSony systemd[1]: Stopped Simple Desktop Display Manager.
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Start request repeated too quickly.
Mar 26 17:34:45 ArchSony systemd[1]: Failed to start Simple Desktop Display Manager.
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Unit entered failed state.
Mar 26 17:34:45 ArchSony systemd[1]: sddm.service: Failed with result 'core-dump'.

I get that, but I cannot understand what's happening.

I will post now which procedures I've tried (I've tested everything loading kernel linux and linux-lts, and nothing has worked).

Update the system

Pacman log:

[2017-03-25 17:07] [PACMAN] Running 'pacman -Syu'
[2017-03-25 17:07] [PACMAN] synchronizing package lists
[2017-03-25 17:07] [PACMAN] starting full system upgrade
[2017-03-25 17:18] [ALPM] transaction started
[2017-03-25 17:18] [ALPM] upgraded archlinux-keyring (20170104-1 -> 20170320-1)
[2017-03-25 17:18] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2017-03-25 17:18] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
[2017-03-25 17:18] [ALPM-SCRIPTLET] usr/bin/pacman-key: line 609: printf: write error: Broken pipe
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
[2017-03-25 17:18] [ALPM-SCRIPTLET] usr/bin/pacman-key: line 609: printf: write error: Broken pipe
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...
[2017-03-25 17:18] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2017-03-25 17:18] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
[2017-03-25 17:18] [ALPM-SCRIPTLET]   -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
[2017-03-25 17:18] [ALPM-SCRIPTLET] ==> Updating trust database...
[2017-03-25 17:18] [ALPM-SCRIPTLET] gpg: marginals needed: 3  completes needed: 1  trust model: pgp
[2017-03-25 17:18] [ALPM-SCRIPTLET] gpg: depth: 0  valid:   1  signed:   5  trust: 0-, 0q, 0n, 0m, 0f, 1u
[2017-03-25 17:18] [ALPM-SCRIPTLET] gpg: depth: 1  valid:   5  signed:  72  trust: 0-, 0q, 0n, 5m, 0f, 0u
[2017-03-25 17:18] [ALPM-SCRIPTLET] gpg: depth: 2  valid:  70  signed:  10  trust: 70-, 0q, 0n, 0m, 0f, 0u
[2017-03-25 17:18] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2017-09-07
[2017-03-25 17:18] [ALPM] upgraded binutils (2.28-1 -> 2.28.0-2)
[2017-03-25 17:18] [ALPM] upgraded tslib (1.7-1 -> 1.8-1)
[2017-03-25 17:18] [ALPM] upgraded bluedevil (1:5.9.3-1 -> 1:5.9.4-1)
[2017-03-25 17:18] [ALPM] upgraded kdecoration (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:18] [ALPM] upgraded breeze (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:18] [ALPM] upgraded breeze-gtk (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:18] [ALPM] upgraded discover (5.9.3-2 -> 5.9.4-1)
[2017-03-25 17:18] [ALPM] upgraded drkonqi (5.9.3-2 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded firefox (52.0.1-1 -> 52.0.1-2)
[2017-03-25 17:19] [ALPM] upgraded git (2.12.0-1 -> 2.12.1-1)
[2017-03-25 17:19] [ALPM] upgraded kactivitymanagerd (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kde-cli-tools (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kde-gtk-config (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded libksysguard (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded milou (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kscreenlocker (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kwin (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded plasma-integration (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kuiserver (5.9.3-2 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded plasma-workspace (5.9.3-2 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kdeplasma-addons (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kgamma5 (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded khotkeys (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kinfocenter (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kmenuedit (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded knetattach (5.9.3-4 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded libkscreen (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kscreen (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded ksshaskpass (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded ksysguard (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kwallet-pam (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kwayland-integration (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded kwrited (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:19] [ALPM] upgraded libsodium (1.0.11-1 -> 1.0.12-1)
[2017-03-25 17:19] [ALPM] upgraded libwbclient (4.5.6-2 -> 4.5.7-1)
[2017-03-25 17:20] [ALPM] upgraded linux (4.10.4-1 -> 4.10.5-1)
[2017-03-25 17:20] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-03-25 17:20] [ALPM] upgraded linux-lts (4.9.16-1 -> 4.9.17-1)
[2017-03-25 17:20] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-03-25 17:20] [ALPM] upgraded mlt (6.4.1-4 -> 6.4.1-5)
[2017-03-25 17:20] [ALPM] upgraded openvpn (2.4.0-2 -> 2.4.1-1)
[2017-03-25 17:20] [ALPM] upgraded oxygen (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded polkit-kde-agent (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded systemsettings (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded plasma-desktop (5.9.3-4 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] installed mobile-broadband-provider-info (20170310-1)
[2017-03-25 17:20] [ALPM] upgraded plasma-nm (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded plasma-pa (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded plasma-sdk (5.9.3-2 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded plasma-workspace-wallpapers (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded powerdevil (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded python-markupsafe (0.23-4 -> 1.0-1)
[2017-03-25 17:20] [ALPM] upgraded python2-numpy (1.12.0-1 -> 1.12.1-1)
[2017-03-25 17:20] [ALPM] upgraded sddm-kcm (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded smbclient (4.5.6-2 -> 4.5.7-1)
[2017-03-25 17:20] [ALPM] upgraded user-manager (5.9.3-1 -> 5.9.4-1)
[2017-03-25 17:20] [ALPM] upgraded youtube-dl (2017.03.20-1 -> 2017.03.24-1)
[2017-03-25 17:20] [ALPM] upgraded zsh (5.3.1-1 -> 5.3.1-2)
[2017-03-25 17:20] [ALPM] transaction completed
[2017-03-25 17:20] [ALPM] running '90-linux-lts.hook'...
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Starting build: 4.9.17-1-lts
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Starting build: 4.9.17-1-lts
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-25 17:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-25 17:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-25 17:21] [ALPM] running '90-linux.hook'...
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Starting build: 4.10.5-1-ARCH
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Starting build: 4.10.5-1-ARCH
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-25 17:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2017-03-25 17:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-25 17:21] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-03-25 17:21] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-03-25 17:21] [ALPM] running 'systemd-update.hook'...
[2017-03-25 17:21] [ALPM] running 'texinfo-install.hook'...
[2017-03-25 17:21] [ALPM] running 'update-desktop-database.hook'...
[2017-03-25 17:21] [ALPM] running 'update-mime-database.hook'...
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-alchemy'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cache'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-ascii'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-binary'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cactvs-table'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cdx'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cdxml'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-chem3d'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cif'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-cml'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-daylight-smiles'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-dmol'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gamess-input'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gamess-output'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gaussian-input'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gaussian-log'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-genbank'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-gulp'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-hin'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-inchi'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-inchi-xml'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-jcamp-dx'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-macromodel-input'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-molfile'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-rdfile'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-rxnfile'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-sdfile'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mdl-tgf'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mmcif'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mol2'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-graph'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-input'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-mopac-out'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-car'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-hessian'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-mdf'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-msi-msi'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1-binary'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-ncbi-asn1-xml'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-pdb'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-shelx'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-vmd'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'chemical/x-xyz'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'all/all'
[2017-03-25 17:21] [ALPM-SCRIPTLET] Unknown media type in type 'all/allfiles'
Removing propietary nvidia drivers

I removed propietary drivers just in case the problem was there (I had nouveau and nvidia drivers both installed).

[2017-03-25 17:49] [PACMAN] Running 'pacman -Rsc nvidia-340xx nvidia-340xx-lts nvidia-340xx-utils'
[2017-03-25 17:49] [ALPM] transaction started
[2017-03-25 17:49] [ALPM] removed lib32-nvidia-340xx-utils (340.102-3)
[2017-03-25 17:49] [ALPM] removed nvidia-340xx-lts (340.102-5)
[2017-03-25 17:50] [ALPM] removed nvidia-340xx (340.102-5)
[2017-03-25 17:50] [ALPM-SCRIPTLET] In order to use nvidia module, reboot the system.
[2017-03-25 17:50] [ALPM] removed nvidia-340xx-utils (340.102-8)
[2017-03-25 17:50] [ALPM] transaction completed
[2017-03-25 17:50] [ALPM] running 'systemd-update.hook'...
[2017-03-25 17:50] [ALPM] running 'update-desktop-database.hook'...
Reinstalling sddm and sddm-kcm

As sddm-kcm was upgraded in the update that broke sddm, I tried reinstalling it.

[2017-03-25 18:04] [PACMAN] Running 'pacman -S sddm sddm-kcm'
[2017-03-25 18:04] [ALPM] transaction started
[2017-03-25 18:04] [ALPM] reinstalled sddm (0.14.0-2)
[2017-03-25 18:04] [ALPM] reinstalled sddm-kcm (5.9.4-1)
[2017-03-25 18:04] [ALPM] transaction completed
[2017-03-25 18:04] [ALPM] running 'systemd-update.hook'...
Downgrading some packages

I tried downgrading only xorg

[2017-03-25 18:40] [PACMAN] Running 'pacman -U xorg-server-1.19.1-1-x86_64.pkg.tar.xz xorg-server-common-1.19.1-1-x86_64.pkg.tar.xz'
[2017-03-25 18:40] [ALPM] transaction started
[2017-03-25 18:40] [ALPM] downgraded xorg-server-common (1.19.3-1 -> 1.19.1-1)
[2017-03-25 18:40] [ALPM] downgraded xorg-server (1.19.3-1 -> 1.19.1-1)
[2017-03-25 18:40] [ALPM] transaction completed
[2017-03-25 18:40] [ALPM] running 'systemd-update.hook'...

and also all packages that I think are related with the problem (I downgraded more packages, e. g. linux, to satisfy all dependencies)

[2017-03-26 14:20] [PACMAN] Running 'pacman -U lib32-nvidia-340xx-libgl-340.101-1-x86_64.pkg.tar.xz nvidia-340xx-libgl-340.101-1-x86_64.pkg.tar.xz nvidia-340xx-utils-340.101-1-x86_64.pkg.tar.xz lib32-nvidia-340xx-utils-340.101-1-x86_64.pkg.tar.xz nvidia-340xx-340.101-10-x86_64.pkg.tar.xz nvidia-340xx-lts-340.101-3-x86_64.pkg.tar.xz linux-4.9.8-1-x86_64.pkg.tar.xz mesa-13.0.4-1-x86_64.pkg.tar.xz lib32-mesa-13.0.4-1-x86_64.pkg.tar.xz'
[2017-03-26 14:20] [ALPM] transaction started
[2017-03-26 14:20] [ALPM] removed lib32-libglvnd (0.2.999+g4ba53457-1)
[2017-03-26 14:20] [ALPM] removed libglvnd (0.2.999+g4ba53457-1)
[2017-03-26 14:20] [ALPM] installed nvidia-340xx-libgl (340.101-1)
[2017-03-26 14:20] [ALPM] downgraded nvidia-340xx-utils (340.102-8 -> 340.101-1)
[2017-03-26 14:20] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2017-03-26 14:20] [ALPM] downgraded lib32-nvidia-340xx-utils (340.102-3 -> 340.101-1)
[2017-03-26 14:20] [ALPM] installed lib32-nvidia-340xx-libgl (340.101-1)
[2017-03-26 14:20] [ALPM] downgraded linux (4.10.5-1 -> 4.9.8-1)
[2017-03-26 14:20] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-03-26 14:20] [ALPM] downgraded nvidia-340xx (340.102-5 -> 340.101-10)
[2017-03-26 14:20] [ALPM-SCRIPTLET] In order to use nvidia module, reboot the system.
[2017-03-26 14:20] [ALPM] downgraded nvidia-340xx-lts (340.102-5 -> 340.101-3)
[2017-03-26 14:20] [ALPM-SCRIPTLET] cat: /usr/lib/modules/extramodules-4.4-lts/version: No such file or directory
[2017-03-26 14:20] [ALPM-SCRIPTLET] depmod: ERROR: could not open directory /lib/modules/4.10.5-1-ARCH: No such file or directory
[2017-03-26 14:20] [ALPM-SCRIPTLET] depmod: FATAL: could not search modules: No such file or directory
[2017-03-26 14:21] [ALPM] downgraded mesa (17.0.1-2 -> 13.0.4-1)
[2017-03-26 14:21] [ALPM] downgraded lib32-mesa (17.0.1-2 -> 13.0.4-1)
[2017-03-26 14:21] [ALPM] transaction completed
[2017-03-26 14:21] [ALPM] running '99-linux.hook'...
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.8-1-ARCH
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.8-1-ARCH
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-26 14:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2017-03-26 14:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-26 14:21] [ALPM] running 'systemd-update.hook'...
[2017-03-26 14:21] [ALPM] running 'update-desktop-database.hook'...

and both as well (simultaneously xorg and all these last packages). Nothing worked.

Final state

I gave up yesterday and today I tried updating the system again (already without propietary drivers),

[2017-03-26 15:13] [PACMAN] Running 'pacman -Syu'
[2017-03-26 15:13] [PACMAN] synchronizing package lists
[2017-03-26 15:13] [PACMAN] starting full system upgrade
[2017-03-26 15:14] [ALPM] transaction started
[2017-03-26 15:14] [ALPM] upgraded tzdata (2017a-1 -> 2017b-1)
[2017-03-26 15:14] [ALPM] upgraded imagemagick (6.9.8.2-1 -> 6.9.8.3-1)
[2017-03-26 15:14] [ALPM] upgraded mesa (17.0.1-2 -> 17.0.2-2)
[2017-03-26 15:14] [ALPM] upgraded libglvnd (0.2.999+g4ba53457-1 -> 0.2.999+g4ba53457-2)
[2017-03-26 15:14] [ALPM] upgraded lib32-mesa (17.0.1-2 -> 17.0.2-1)
[2017-03-26 15:14] [ALPM] upgraded lib32-libglvnd (0.2.999+g4ba53457-1 -> 0.2.999+g4ba53457-2)
[2017-03-26 15:14] [ALPM] upgraded lib32-libpng (1.6.27-1 -> 1.6.29-1)
[2017-03-26 15:15] [ALPM] upgraded python2-psutil (5.2.0-1 -> 5.2.2-1)
[2017-03-26 15:15] [ALPM] transaction completed
[2017-03-26 15:15] [ALPM] running 'systemd-update.hook'...

but it didn't get fixed, so I started searching on the internet and found the bug https://bugs.archlinux.org/task/53374, which I think may be related, but I don't find anything useful there (and I'm not using propietary drivers anymore). I tried adding sddm user to the video group (that makes disappear the lines with 'xauth' in 'systemctl status sddm.service'), but everything else remains the same. I checked that /var/lib/sddm exists.

I don't know what else I can do to fix this, even downgrading.

Any help would be very appreciated. Thanks in advance.

Last edited by josealberto4444 (2017-04-23 14:57:39)

Offline

#2 2017-03-26 17:24:09

loqs
Member
Registered: 2014-03-06
Posts: 14,248

Re: [SOLVED] SDDM fails to load after switch to libglvnd

The output of

# coredumpctl info match

For the core dump sddm produced on the now updated system (see Core_dump#Examining_a_core_dump )

Offline

#3 2017-03-31 19:54:24

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

           PID: 318 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Sun 2017-03-26 15:00:57 CEST (5 days ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 76966b6736a9467caf618a84c6c6014d
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.76966b6736a9467caf618a84c6c6014d.318.1490533257000000000000.lz4 (inaccessible)
       Message: Process 318 (sddm) of user 0 dumped core.
                
                Stack trace of thread 318:
                #0  0x00007fb9bb7995d3 _ZN7QObject7connectEPKS_PKcS1_S3_N2Qt14ConnectionTypeE (libQt5Core.so.5)
                #1  0x0000000000434cb5 _ZN4SDDM4Auth7Private9setSocketEP12QLocalSocket (sddm)
                #2  0x0000000000436822 _ZN4SDDM4Auth12SocketServer19handleNewConnectionEv (sddm)
                #3  0x00007fb9bb792d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #4  0x00007fb9bbcb8bdf n/a (libQt5Network.so.5)
                #5  0x00007fb9bb792d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #6  0x00007fb9bb80d12e _ZN15QSocketNotifier9activatedEiNS_14QPrivateSignalE (libQt5Core.so.5)
                #7  0x00007fb9bb79f9c2 _ZN15QSocketNotifier5eventEP6QEvent (libQt5Core.so.5)
                #8  0x00007fb9bb76742b _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                #9  0x00007fb9bb7bc4fd n/a (libQt5Core.so.5)
                #10 0x00007fb9b7c3e5a7 g_main_context_dispatch (libglib-2.0.so.0)
                #11 0x00007fb9b7c3e810 n/a (libglib-2.0.so.0)
                #12 0x00007fb9b7c3e8bc g_main_context_iteration (libglib-2.0.so.0)
                #13 0x00007fb9bb7bc04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #14 0x00007fb9bb76589a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #15 0x00007fb9bb76dde4 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                #16 0x000000000041cab1 main (sddm)
                #17 0x00007fb9babbc511 __libc_start_main (libc.so.6)
                #18 0x000000000041cdaa _start (sddm)
                
                Stack trace of thread 325:
                #0  0x00007fb9bac7e67d poll (libc.so.6)
                #1  0x00007fb9b7c3e7a6 n/a (libglib-2.0.so.0)
                #2  0x00007fb9b7c3e8bc g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007fb9bb7bc04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #4  0x00007fb9bb76589a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #5  0x00007fb9bb587a73 _ZN7QThread4execEv (libQt5Core.so.5)
                #6  0x00007fb9bc560125 n/a (libQt5DBus.so.5)
                #7  0x00007fb9bb58c6d8 n/a (libQt5Core.so.5)
                #8  0x00007fb9ba9852e7 start_thread (libpthread.so.0)
                #9  0x00007fb9bac8854f __clone (libc.so.6)

           PID: 318 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Fri 2017-03-31 21:15:41 CEST (12min ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 019c66a358014b7fb1dc34e6d52717c5
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.019c66a358014b7fb1dc34e6d52717c5.318.1490987741000000000000.lz4 (inaccessible)
       Message: Process 318 (sddm) of user 0 dumped core.
                
                Stack trace of thread 318:
                #0  0x00007f4d246865d3 _ZN7QObject7connectEPKS_PKcS1_S3_N2Qt14ConnectionTypeE (libQt5Core.so.5)
                #1  0x0000000000434cb5 _ZN4SDDM4Auth7Private9setSocketEP12QLocalSocket (sddm)
                #2  0x0000000000436822 _ZN4SDDM4Auth12SocketServer19handleNewConnectionEv (sddm)
                #3  0x00007f4d2467fd49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #4  0x00007f4d24ba5bdf n/a (libQt5Network.so.5)
                #5  0x00007f4d2467fd49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #6  0x00007f4d246fa12e _ZN15QSocketNotifier9activatedEiNS_14QPrivateSignalE (libQt5Core.so.5)
                #7  0x00007f4d2468c9c2 _ZN15QSocketNotifier5eventEP6QEvent (libQt5Core.so.5)
                #8  0x00007f4d2465442b _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                #9  0x00007f4d246a94fd n/a (libQt5Core.so.5)
                #10 0x00007f4d20b2b5a7 g_main_context_dispatch (libglib-2.0.so.0)
                #11 0x00007f4d20b2b810 n/a (libglib-2.0.so.0)
                #12 0x00007f4d20b2b8bc g_main_context_iteration (libglib-2.0.so.0)
                #13 0x00007f4d246a904f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #14 0x00007f4d2465289a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #15 0x00007f4d2465ade4 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                #16 0x000000000041cab1 main (sddm)
                #17 0x00007f4d23aa9511 __libc_start_main (libc.so.6)
                #18 0x000000000041cdaa _start (sddm)
                
                Stack trace of thread 326:
                #0  0x00007f4d23b6b67d poll (libc.so.6)
                #1  0x00007f4d20b2b7a6 n/a (libglib-2.0.so.0)
                #2  0x00007f4d20b2b8bc g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f4d246a904f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #4  0x00007f4d2465289a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #5  0x00007f4d24474a73 _ZN7QThread4execEv (libQt5Core.so.5)
                #6  0x00007f4d2544d125 n/a (libQt5DBus.so.5)
                #7  0x00007f4d244796d8 n/a (libQt5Core.so.5)
                #8  0x00007f4d238722e7 start_thread (libpthread.so.0)
                #9  0x00007f4d23b7554f __clone (libc.so.6)

           PID: 407 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Fri 2017-03-31 21:15:41 CEST (13min ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 019c66a358014b7fb1dc34e6d52717c5
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.019c66a358014b7fb1dc34e6d52717c5.407.1490987741000000000000.lz4 (inaccessible)
       Message: Process 407 (sddm) of user 0 dumped core.
                
                Stack trace of thread 407:
                #0  0x00007f8f2a62c5d3 _ZN7QObject7connectEPKS_PKcS1_S3_N2Qt14ConnectionTypeE (libQt5Core.so.5)
                #1  0x0000000000434cb5 _ZN4SDDM4Auth7Private9setSocketEP12QLocalSocket (sddm)
                #2  0x0000000000436822 _ZN4SDDM4Auth12SocketServer19handleNewConnectionEv (sddm)
                #3  0x00007f8f2a625d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #4  0x00007f8f2ab4bbdf n/a (libQt5Network.so.5)
                #5  0x00007f8f2a625d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #6  0x00007f8f2a6a012e _ZN15QSocketNotifier9activatedEiNS_14QPrivateSignalE (libQt5Core.so.5)
                #7  0x00007f8f2a6329c2 _ZN15QSocketNotifier5eventEP6QEvent (libQt5Core.so.5)
                #8  0x00007f8f2a5fa42b _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                #9  0x00007f8f2a64f4fd n/a (libQt5Core.so.5)
                #10 0x00007f8f26ad15a7 g_main_context_dispatch (libglib-2.0.so.0)
                #11 0x00007f8f26ad1810 n/a (libglib-2.0.so.0)
                #12 0x00007f8f26ad18bc g_main_context_iteration (libglib-2.0.so.0)
                #13 0x00007f8f2a64f04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #14 0x00007f8f2a5f889a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #15 0x00007f8f2a600de4 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                #16 0x000000000041cab1 main (sddm)
                #17 0x00007f8f29a4f511 __libc_start_main (libc.so.6)
                #18 0x000000000041cdaa _start (sddm)
                
                Stack trace of thread 409:
                #0  0x00007f8f29b1167d poll (libc.so.6)
                #1  0x00007f8f26ad17a6 n/a (libglib-2.0.so.0)
                #2  0x00007f8f26ad18bc g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f8f2a64f04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #4  0x00007f8f2a5f889a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #5  0x00007f8f2a41aa73 _ZN7QThread4execEv (libQt5Core.so.5)
                #6  0x00007f8f2b3f3125 n/a (libQt5DBus.so.5)
                #7  0x00007f8f2a41f6d8 n/a (libQt5Core.so.5)
                #8  0x00007f8f298182e7 start_thread (libpthread.so.0)
                #9  0x00007f8f29b1b54f __clone (libc.so.6)

           PID: 433 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Fri 2017-03-31 21:15:42 CEST (15min ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 019c66a358014b7fb1dc34e6d52717c5
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.019c66a358014b7fb1dc34e6d52717c5.433.1490987742000000000000.lz4 (inaccessible)
       Message: Process 433 (sddm) of user 0 dumped core.
                
                Stack trace of thread 433:
                #0  0x00007f918bd7c5d3 _ZN7QObject7connectEPKS_PKcS1_S3_N2Qt14ConnectionTypeE (libQt5Core.so.5)
                #1  0x0000000000434cb5 _ZN4SDDM4Auth7Private9setSocketEP12QLocalSocket (sddm)
                #2  0x0000000000436822 _ZN4SDDM4Auth12SocketServer19handleNewConnectionEv (sddm)
                #3  0x00007f918bd75d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #4  0x00007f918c29bbdf n/a (libQt5Network.so.5)
                #5  0x00007f918bd75d49 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                #6  0x00007f918bdf012e _ZN15QSocketNotifier9activatedEiNS_14QPrivateSignalE (libQt5Core.so.5)
                #7  0x00007f918bd829c2 _ZN15QSocketNotifier5eventEP6QEvent (libQt5Core.so.5)
                #8  0x00007f918bd4a42b _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                #9  0x00007f918bd9f4fd n/a (libQt5Core.so.5)
                #10 0x00007f91882215a7 g_main_context_dispatch (libglib-2.0.so.0)
                #11 0x00007f9188221810 n/a (libglib-2.0.so.0)
                #12 0x00007f91882218bc g_main_context_iteration (libglib-2.0.so.0)
                #13 0x00007f918bd9f04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #14 0x00007f918bd4889a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #15 0x00007f918bd50de4 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                #16 0x000000000041cab1 main (sddm)
                #17 0x00007f918b19f511 __libc_start_main (libc.so.6)
                #18 0x000000000041cdaa _start (sddm)
                
                Stack trace of thread 434:
                #0  0x00007f918b26167d poll (libc.so.6)
                #1  0x00007f91882217a6 n/a (libglib-2.0.so.0)
                #2  0x00007f91882218bc g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f918bd9f04f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #4  0x00007f918bd4889a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #5  0x00007f918bb6aa73 _ZN7QThread4execEv (libQt5Core.so.5)
                #6  0x00007f918cb43125 n/a (libQt5DBus.so.5)
                #7  0x00007f918bb6f6d8 n/a (libQt5Core.so.5)
                #8  0x00007f918af682e7 start_thread (libpthread.so.0)
                #9  0x00007f918b26b54f __clone (libc.so.6)

           PID: 463 (ksplashqml)
           UID: 1000 (ja)
           GID: 1000 (ja)
        Signal: 6 (ABRT)
     Timestamp: Sat 2017-03-04 13:23:14 CET (3 weeks 6 days ago)
  Command Line: ksplashqml Breeze --pid
    Executable: /usr/bin/ksplashqml
 Control Group: /
         Slice: -.slice
       Boot ID: f780d40e2a7d49f3b6f7657357327e51
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.ksplashqml.1000.f780d40e2a7d49f3b6f7657357327e51.463.1488630194000000000000.lz4 (inaccessible)
       Message: Process 463 (ksplashqml) of user 1000 dumped core.
                
                Stack trace of thread 464:
                #0  0x00007fdf34f9904f raise (libc.so.6)
                #1  0x00007fdf34f9a47a abort (libc.so.6)
                #2  0x00007fdf34fd6c50 __libc_message (libc.so.6)
                #3  0x00007fdf34fdcfe6 malloc_printerr (libc.so.6)
                #4  0x00007fdf34fdd341 malloc_consolidate (libc.so.6)
                #5  0x00007fdf34fded2a _int_malloc (libc.so.6)
                #6  0x00007fdf34fe1796 __libc_calloc (libc.so.6)
                #7  0x00007fdf2e641259 n/a (libnvidia-tls.so.340.101)
                #8  0x00007fdf30192bf1 g_malloc0 (libglib-2.0.so.0)
                #9  0x00007fdf301aba05 g_slice_free1 (libglib-2.0.so.0)
                #10 0x00007fdf32187519 __nptl_deallocate_tsd.part.4 (libpthread.so.0)
                #11 0x00007fdf32188608 start_thread (libpthread.so.0)
                #12 0x00007fdf3504e7df __clone (libc.so.6)
                
                Stack trace of thread 463:
                #0  0x00007fdf357a1fde _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #1  0x00007fdf357a1ffd _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #2  0x00007fdf357a1fea _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #3  0x00007fdf357a1ffd _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #4  0x00007fdf357a1fea _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #5  0x00007fdf357a1ffd _ZN12QMapDataBase8freeTreeEP12QMapNodeBasei (libQt5Core.so.5)
                #6  0x00007fdf26254866 _ZN10QXcbScreenD1Ev (libQt5XcbQpa.so.5)
                #7  0x00007fdf26254899 _ZN10QXcbScreenD0Ev (libQt5XcbQpa.so.5)
                #8  0x00007fdf26248c47 _ZN14QXcbConnectionD2Ev (libQt5XcbQpa.so.5)
                #9  0x00007fdf26249119 _ZN14QXcbConnectionD0Ev (libQt5XcbQpa.so.5)
                #10 0x00007fdf2624aaa6 _ZN15QXcbIntegrationD1Ev (libQt5XcbQpa.so.5)
                #11 0x00007fdf2624aba9 _ZN15QXcbIntegrationD0Ev (libQt5XcbQpa.so.5)
                #12 0x00007fdf35e584b3 _ZN22QGuiApplicationPrivateD2Ev (libQt5Gui.so.5)
                #13 0x00007fdf35e58649 _ZN22QGuiApplicationPrivateD0Ev (libQt5Gui.so.5)
                #14 0x00007fdf35947db7 _ZN7QObjectD2Ev (libQt5Core.so.5)
                #15 0x00007fdf35915f56 _ZN16QCoreApplicationD2Ev (libQt5Core.so.5)
                #16 0x0000000000404bbe n/a (ksplashqml)
                #17 0x00007fdf34f86291 __libc_start_main (libc.so.6)
                #18 0x0000000000404c5a _start (ksplashqml)
                
                Stack trace of thread 466:
                #0  0x00007fdf3504548d poll (libc.so.6)
                #1  0x00007fdf3018d786 n/a (libglib-2.0.so.0)
                #2  0x00007fdf3018d89c g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007fdf3596904f _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                #4  0x00007fdf3591289a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                #5  0x00007fdf35734a73 _ZN7QThread4execEv (libQt5Core.so.5)
                #6  0x00007fdf36723125 n/a (libQt5DBus.so.5)
                #7  0x00007fdf357396d8 n/a (libQt5Core.so.5)
                #8  0x00007fdf32188454 start_thread (libpthread.so.0)
                #9  0x00007fdf3504e7df __clone (libc.so.6)

           PID: 463 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Fri 2017-03-31 21:15:43 CEST (15min ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 019c66a358014b7fb1dc34e6d52717c5
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.019c66a358014b7fb1dc34e6d52717c5.463.1490987743000000000000.lz4 (inaccessible)
       Message: Process 463 (sddm) of user 0 dumped core.
                
                Stack trace of thread 463:
                #0  0x00007f77b1f9cf7f n/a (libgpg-error.so.0)

           PID: 491 (sddm)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Fri 2017-03-31 21:15:43 CEST (15min ago)
  Command Line: /usr/bin/sddm
    Executable: /usr/bin/sddm
 Control Group: /system.slice/sddm.service
          Unit: sddm.service
         Slice: system.slice
       Boot ID: 019c66a358014b7fb1dc34e6d52717c5
    Machine ID: 5b3a5e66f17b43ecb73bb20a8643fdc2
      Hostname: ArchSony
       Storage: /var/lib/systemd/coredump/core.sddm.0.019c66a358014b7fb1dc34e6d52717c5.491.1490987743000000000000.lz4
       Message: Process 491 (sddm) of user 0 dumped core.
                
                Stack trace of thread 491:
                #0  0x00000000000007a0 n/a (n/a)

Also, I've realised that sometimes there is a message on boot that says that session-c?.scope fails (? is a number that changes, once it was a 6 and once a number 3). For the last one (number 3), I got these systemctl status messages:

● session-c3.scope - Session c3 of user sddm
   Loaded: loaded (/run/systemd/transient/session-c3.scope; transient; vendor preset: disabled)
Transient: yes
   Active: failed (Result: resources)

Mar 31 20:49:35 ArchSony systemd[1]: session-c3.scope: Failed to add PIDs to scope's control group: No such process
Mar 31 20:49:35 ArchSony systemd[1]: Failed to start Session c3 of user sddm.
Mar 31 20:49:35 ArchSony systemd[1]: session-c3.scope: Unit entered failed state.


● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Fri 2017-03-31 20:49:38 CEST; 3min 44s ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
  Process: 725 ExecStart=/usr/bin/sddm (code=dumped, signal=SEGV)
 Main PID: 725 (code=dumped, signal=SEGV)

Mar 31 20:49:37 ArchSony systemd[1]: sddm.service: Unit entered failed state.
Mar 31 20:49:37 ArchSony systemd[1]: sddm.service: Failed with result 'core-dump'.
Mar 31 20:49:37 ArchSony systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Mar 31 20:49:37 ArchSony systemd[1]: Stopped Simple Desktop Display Manager.
Mar 31 20:49:37 ArchSony systemd[1]: Started Simple Desktop Display Manager.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Main process exited, code=dumped, status=11/SEGV
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Unit entered failed state.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Failed with result 'core-dump'.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Mar 31 20:49:38 ArchSony systemd[1]: Stopped Simple Desktop Display Manager.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Start request repeated too quickly.
Mar 31 20:49:38 ArchSony systemd[1]: Failed to start Simple Desktop Display Manager.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Unit entered failed state.
Mar 31 20:49:38 ArchSony systemd[1]: sddm.service: Failed with result 'core-dump'.

If you need something more or if I've done something wrong (sorry), just tell me.

Thanks.

Offline

#4 2017-04-06 09:45:05

guest00
Member
Registered: 2016-06-21
Posts: 6

Re: [SOLVED] SDDM fails to load after switch to libglvnd

Try downgrade mesa, mesa-libgl, libglvnd from archive.archlinux.org

Offline

#5 2017-04-08 16:39:11

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

I tried downgrading mesa and mesa-libgl

[2017-04-08 17:31] [PACMAN] Running 'pacman -U https://archive.archlinux.org/packages/m/mesa-libgl/mesa-libgl-13.0.4-2-x86_64.pkg.tar.xz https://archive.archlinux.org/packages/l/lib32-mesa-libgl/lib32-mesa-libgl-13.0.4-2-x86_64.pkg.tar.xz mesa-13.0.4-1-x86_64.pkg.tar.xz lib32-mesa-13.0.4-1-x86_64.pkg.tar.xz'
[2017-04-08 17:32] [ALPM] transaction started
[2017-04-08 17:32] [ALPM] removed lib32-libglvnd (0.2.999+g4ba53457-2)
[2017-04-08 17:33] [ALPM] removed libglvnd (0.2.999+g4ba53457-2)
[2017-04-08 17:33] [ALPM] downgraded mesa (17.0.2-2 -> 13.0.4-1)
[2017-04-08 17:33] [ALPM] installed mesa-libgl (13.0.4-2)
[2017-04-08 17:33] [ALPM] downgraded lib32-mesa (17.0.2-1 -> 13.0.4-1)
[2017-04-08 17:33] [ALPM] installed lib32-mesa-libgl (13.0.4-2)
[2017-04-08 17:33] [ALPM] transaction completed
[2017-04-08 17:33] [ALPM] running 'systemd-update.hook'...

but it didn't work.

I also downgraded sddm-kcm

[2017-04-08 17:44] [PACMAN] Running 'pacman -U sddm-kcm-5.9.1-1-x86_64.pkg.tar.xz'
[2017-04-08 17:44] [ALPM] transaction started
[2017-04-08 17:44] [ALPM] downgraded sddm-kcm (5.9.4-1 -> 5.9.1-1)
[2017-04-08 17:44] [ALPM] transaction completed
[2017-04-08 17:44] [ALPM] running 'systemd-update.hook'...

but it didn't work either.

Then, I recreated sddm config file

# sddm --example-config > /etc/sddm.conf

and the problem still remained.

After that, I downgraded xorg-server

[2017-04-08 17:51] [PACMAN] Running 'pacman -U xorg-server-1.19.1-1-x86_64.pkg.tar.xz xorg-server-common-1.19.1-1-x86_64.pkg.tar.xz'
[2017-04-08 17:51] [ALPM] transaction started
[2017-04-08 17:51] [ALPM] downgraded xorg-server-common (1.19.3-1 -> 1.19.1-1)
[2017-04-08 17:51] [ALPM] downgraded xorg-server (1.19.3-1 -> 1.19.1-1)
[2017-04-08 17:51] [ALPM] transaction completed
[2017-04-08 17:51] [ALPM] running 'systemd-update.hook'...

and the problem was still the same.

Finally, I recreated the sddm conf file again

# sddm --example-config > /etc/sddm.conf

and it seemed to work. Sddm starts and I can start a plasma session, but after some seconds, the computer get completely frozen and I have to shut it down by holding the power button.

Any more ideas? I cannot understand why this doesn't get fixed downgrading.

Offline

#6 2017-04-08 16:57:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,423

Re: [SOLVED] SDDM fails to load after switch to libglvnd

There's nothing in your stack traces that directly imply an error of the graphic libraries. Do you have the intel microcode updates installed and configured to load? Some more info about your hardware would be nice, what's the output of

lspci -k

Last edited by V1del (2017-04-08 17:03:21)

Offline

#7 2017-04-08 17:39:36

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

Thanks for your quick reply.

V1del wrote:

There's nothing in your stack traces that directly imply an error of the graphic libraries. Do you have the intel microcode updates installed and configured to load?

I thought I had, but I hadn't. Now I have microcode updates correctly configured and microcode got updated in last boot, but the problem is still exactly the same.

V1del wrote:

Some more info about your hardware would be nice, what's the output of

lspci -k
$ lspci -k
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
	Subsystem: Sony Corporation Device 9040
	Kernel modules: intel_agp
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation G96M [GeForce 9600M GT] (rev a1)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: nouveau
	Kernel modules: nouveau
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: sky2
	Kernel modules: sky2
05:00.0 Network controller: Intel Corporation WiFi Link 5100
	Subsystem: Intel Corporation WiFi Link 5100 AGN
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
07:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: pata_jmicron
	Kernel modules: pata_jmicron, pata_acpi, ata_generic
09:03.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: firewire_ohci
	Kernel modules: firewire_ohci
09:03.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: sdhci-pci
	Kernel modules: sdhci_pci
09:03.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
	Subsystem: Sony Corporation Device 9040
	Kernel driver in use: r592
	Kernel modules: r592

Offline

#8 2017-04-09 09:39:29

karlospv94
Member
Registered: 2016-10-12
Posts: 94

Re: [SOLVED] SDDM fails to load after switch to libglvnd

I had the same problem than you with the same components. I tried downgrading all related to mesa with the same result. I finally downgraded nvidia and nvidia-utils and It works now!

Offline

#9 2017-04-09 10:48:59

loqs
Member
Registered: 2014-03-06
Posts: 14,248

Re: [SOLVED] SDDM fails to load after switch to libglvnd

karlospv94 wrote:

I tried downgrading all related to mesa with the same result. I finally downgraded nvidia and nvidia-utils and It works now!

That approach results in a partial upgrade.  The number of packages you would have to prevent from being upgraded will increase with time as new incompatible versions of mesa are released you would need to add all packages depending on mesa etc.
It also does not inform the maintainer there is an issue,  there appears to be no relevant bug reports open against sddm or libglvnd.

Offline

#10 2017-04-13 10:30:02

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

loqs wrote:
karlospv94 wrote:

I tried downgrading all related to mesa with the same result. I finally downgraded nvidia and nvidia-utils and It works now!

That approach results in a partial upgrade.  The number of packages you would have to prevent from being upgraded will increase with time as new incompatible versions of mesa are released you would need to add all packages depending on mesa etc.
It also does not inform the maintainer there is an issue,  there appears to be no relevant bug reports open against sddm or libglvnd.

I already tried to downgrade nvidia and it didn't work for me.

Of course it results in a partial upgrade, but it is a temporary solution (I would be able to test things and take a look to the forum without needing another computer, which is very hard for me). What would be your recommendation? It's not very useful to say "don't do a partial upgrade" without saying what should be done instead. Should I report this anywhere (you talked about bug reports)?

Offline

#11 2017-04-13 10:33:34

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

Today I upgraded the system (including mesa and lib32-mesa) and now I get

$ systemctl status sddm
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2017-04-13 12:08:15 CEST; 8min ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
 Main PID: 309 (sddm)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/sddm.service
           ├─309 /usr/bin/sddm
           └─326 /usr/lib/xorg-server/Xorg -nolisten tcp -auth /var/run/sddm/{4fc82550-afc3-4b4b-9a55-82ccce76e9a6} -background none -noreset -displayfd 18 vt1

Apr 13 12:08:15 ArchSony systemd[1]: Started Simple Desktop Display Manager.
Apr 13 12:08:17 ArchSony sddm[309]: Initializing...
Apr 13 12:08:18 ArchSony sddm[309]: Starting...
Apr 13 12:08:18 ArchSony sddm[309]: Adding new display on vt 1 ...
Apr 13 12:08:18 ArchSony sddm[309]: Display server starting...
Apr 13 12:08:18 ArchSony sddm[309]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{4fc82550-afc3-4b4b-9a55-82ccce76e9a6} -background none -noreset -displayfd 18 vt1
Apr 13 12:08:23 ArchSony sddm[309]: Running display setup script  "/usr/share/sddm/scripts/Xsetup"
Apr 13 12:08:23 ArchSony sddm[309]: Display server started.
Apr 13 12:08:23 ArchSony sddm[309]: Socket server starting...
Apr 13 12:08:23 ArchSony sddm[309]: Socket server started.
Apr 13 12:08:23 ArchSony sddm[309]: Greeter starting...
Apr 13 12:08:23 ArchSony sddm[309]: Adding cookie to "/var/run/sddm/{4fc82550-afc3-4b4b-9a55-82ccce76e9a6}"
Apr 13 12:08:23 ArchSony sddm-helper[392]: [PAM] Starting...
Apr 13 12:08:23 ArchSony sddm-helper[392]: [PAM] Authenticating...
Apr 13 12:08:23 ArchSony sddm-helper[392]: [PAM] returning.
Apr 13 12:08:23 ArchSony sddm-helper[392]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
Apr 13 12:08:24 ArchSony sddm[309]: Greeter session started successfully
Apr 13 12:08:25 ArchSony sddm[309]: Message received from greeter: Connect
Apr 13 12:08:29 ArchSony sddm[309]: Auth: sddm-helper exited with 7
Apr 13 12:08:29 ArchSony sddm[309]: Greeter stopped.

which seems to say that there isn't any problem with sddm, but the graphical interface doesn't start.

Offline

#12 2017-04-13 10:53:05

loqs
Member
Registered: 2014-03-06
Posts: 14,248

Re: [SOLVED] SDDM fails to load after switch to libglvnd

Apr 13 12:08:29 ArchSony sddm[309]: Auth: sddm-helper exited with 7

None zero exit codes by convention indicate an error.

Offline

#13 2017-04-13 11:05:46

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

loqs wrote:
Apr 13 12:08:29 ArchSony sddm[309]: Auth: sddm-helper exited with 7

None zero exit codes by convention indicate an error.

And how can I see what happened to sddm-helper?

Offline

#14 2017-04-13 11:31:22

loqs
Member
Registered: 2014-03-06
Posts: 14,248

Re: [SOLVED] SDDM fails to load after switch to libglvnd

https://github.com/sddm/sddm/blob/devel … Auth.h#L81

        enum HelperExitStatus {
            HELPER_SUCCESS = 0,
            HELPER_AUTH_ERROR,
            HELPER_SESSION_ERROR,
            HELPER_OTHER_ERROR
};

From my reading the exit codes should be 0 through to 3 yet the journal output from sddm indicates exit code 7.
Try one of the resources from https://github.com/sddm/sddm#resources to see if someone more knowledgeable about sddm understands it.

Offline

#15 2017-04-23 14:07:36

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

I updated on 2017-04-19 and the problem got almost fixed. Now, sddm and kde start, but desktop effects don't work. The window borders are sharp, there are no shadows, fades, transparencies, etc.

It get fixed if I go to System Settings > Display and Monitor > Compositor tab > Rendering Backend, and I switch that to another version of OpenGL (options are OpenGL 2.0 and OpenGL 3.1). It doesn't matter if you switch from 2.0 to 3.1 or vice versa, once you hit apply for the first time, desktop effects are back until you restart. You can then switch back to the OpenGL selected at the beginning and hit apply, everything will continue working. When you restart the computer (no matter if you leave OpenGL 2.0 or 3.1 selected), desktop effects are disabled again and you have to change again the backend.

I have absolutely no idea of what's happening or how to fix it. Any ideas?

Last edited by josealberto4444 (2017-04-23 14:10:48)

Offline

#16 2017-04-23 14:24:53

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,498
Website

Re: [SOLVED] SDDM fails to load after switch to libglvnd


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#17 2017-04-23 14:56:39

josealberto4444
Member
Registered: 2014-06-17
Posts: 14

Re: [SOLVED] SDDM fails to load after switch to libglvnd

Yep, it worked. Thanks!

Offline

Board footer

Powered by FluxBB