You are not logged in.

#1 2017-04-21 11:17:22

sixline
Member
From: Saudi Arabia
Registered: 2016-10-25
Posts: 2

gksu/gksudo not working

When I type gksu nautilus (or any application), the password screen appears but I cannot enter password as the password input field is not available. Please see the screenshot below:

https://c1.staticflickr.com/3/2917/3413 … e0bc_b.jpg

The text field is not clickable i.e. cursor doesnot appears when I click in it. Also, sudo returns:

[ali@alipc8100]: ~>$ sudo nautilus
[sudo] password for ali: 
No protocol specified
Unable to init server: Could not connect: Connection refused

(nautilus:2040): Gtk-WARNING **: cannot open display: :0
[ali@alipc8100]: ~>$ 

Mod note: Converted oversized image to url. See the CoC regarding acceptable image sizes. -- WorMzy

Last edited by WorMzy (2017-04-21 11:44:58)

Offline

#2 2017-04-21 12:04:34

sixline
Member
From: Saudi Arabia
Registered: 2016-10-25
Posts: 2

Re: gksu/gksudo not working

I sort of solved my problem from this thread: https://bbs.archlinux.org/viewtopic.php?id=221346.
I went into Nautilus/Files and enter in the location bar (open it with ctrl+L):
admin:///
A password prompt will open, and after entering your password, you can browse and edit everything with root rights. If you open now for example the /etc/default/grub file from Nautilus/Files, Gedit/Texteditor will ask you for your password again. Now you can edit this file with root rights.

This is a problem with wayland but I still want use gksu or sudo if that's possible. Hope any advance user can explain it better.

Offline

#3 2017-04-21 12:25:53

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 20,437
Website

Re: gksu/gksudo not working

You may want to watch this bug report:
https://bugs.archlinux.org/task/50314


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2018-02-28 07:59:45

freko247
Member
Registered: 2018-02-28
Posts: 1

Re: gksu/gksudo not working

I know this question was posted a long time ago, but I ran into the same problem and found an easy solution.

By adding the "--disable-grab" argument, I was able to type the password.

So full command I used was:

gksudo baobab --disable-grab

Last edited by freko247 (2018-02-28 08:01:52)

Offline

#5 2018-02-28 08:32:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,677

Re: gksu/gksudo not working

Thanks, for sharing, however since the original post specifically mentioned wayland, it's likely that that is irrelevant to the original issue.

Closing this old thread now.

Offline

Board footer

Powered by FluxBB