You are not logged in.

#1 2017-04-24 13:45:29

rking
Member
Registered: 2015-11-23
Posts: 16

gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

getting the following errors today on a pacman -Syu:

:: Replace kdegames-kajongg with extra/kajongg? [Y/n] y
:: Replace kdesdk-dev-utils with extra/kde-dev-utils? [Y/n] y
:: Replace kdesdk-kcachegrind with extra/kcachegrind? [Y/n] y
warning: ntp: local (4.2.8.p10-1) is newer than extra (4.2.8.p9-2)
warning: openimageio: local (1.7.13-1) is newer than community (1.7.10-2)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gstreamer0.10-good-plugins: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'

not sure how i got newer ntp and openimageio than is currently in the database, but if i have to i should be able to downgrade both if neccessary

not sure how to deal with the conflict and am looking for some help

thanks in advance

Last edited by rking (2017-04-24 14:31:31)

Offline

#2 2017-04-24 13:52:52

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,874

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

gstreamer0.10-good-plugins is no longer in the repos. Fix or remove your AUR stuff.

Offline

#3 2017-04-24 14:10:41

rking
Member
Registered: 2015-11-23
Posts: 16

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

had to remove plugins for gstreamer0.10 first, but it did solve the issue!

thanks

Offline

#4 2017-04-24 17:10:44

swipe
Member
Registered: 2017-02-23
Posts: 4

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

Offline

#5 2017-04-25 07:03:26

simeon
Member
Registered: 2012-03-06
Posts: 6

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

See also https://lists.archlinux.org/pipermail/a … html#28638

I'm glad the maintainers keep an eye on such things. Thanks for getting rid of unmaintained code!

Offline

#6 2017-04-25 07:25:19

marcvangend
Member
Registered: 2013-04-22
Posts: 20

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

@simeon that link doesn't seem to provide relevant information, did you mean https://lists.archlinux.org/pipermail/a … 28638.html ?

Offline

#7 2017-04-25 07:28:21

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 21,777
Website

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#8 2017-04-25 16:23:31

dosoe104
Member
Registered: 2017-04-25
Posts: 2

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

Hi!
I have the same problem, but I don't get what the solution you propose is. Is it uninstalling all packages that depend on gstreamer0.10-good-plugins and reinstalling them after update?
Dorian
PS: I'm new to Arch

Last edited by dosoe104 (2017-04-25 16:24:17)

Offline

#9 2017-04-25 17:03:39

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,874

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

No, it's by either getting rid of gstreamer0.10 completely (it's old and unmaintained, not much actually uses it), or by fixing the gstreamer0.10 packages so they depend on packages that actually exist.

Offline

#10 2017-04-25 17:36:49

dosoe104
Member
Registered: 2017-04-25
Posts: 2

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

It worked, thanks.

Offline

#11 2017-04-26 08:49:54

Aton
Member
Registered: 2013-04-02
Posts: 64

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

jasonwryan wrote:

Moving to AUR Issues...

You can run into the above error without ever having touched the AUR.
`Pacman & Package Upgrade Issues` would be a better place for this.

Offline

#12 2017-04-26 08:52:47

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 21,777
Website

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

Aton wrote:
jasonwryan wrote:

Moving to AUR Issues...

You can run into the above error without ever having touched the AUR.
`Pacman & Package Upgrade Issues` would be a better place for this.

The package is no longer in the official repos, therefore it is an AUR issue.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#13 2017-04-26 10:51:04

alu1
Member
Registered: 2014-05-16
Posts: 4

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

arch user for many years and this is the first time i've had to spend so long chasing down a dependency, so i include my fix if it helps anyone.

gstreamer0.10-good-plugins was a dependency of farstream-0.1, so couldn't be removed.  no idea where farstream-0.1 came from but i also had the main farstream package from the repo's.

pacman -Rsd farstream-0.1  /*NOT farstream*/
pacman -Rsd gstreamer0.10-good-plugins

fixed this issue for me, and removing wxgtk2.8/wxpython2.8 allowed me to remove gstreamer0.10 fully

Last edited by alu1 (2017-04-26 11:31:02)

Offline

#14 2017-04-26 14:01:30

noerion
Member
Registered: 2014-03-13
Posts: 1

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

alu1 wrote:
pacman -Rsd farstream-0.1  /*NOT farstream*/
pacman -Rsd gstreamer0.10-good-plugins

fixed this issue for me, and removing wxgtk2.8/wxpython2.8 allowed me to remove gstreamer0.10 fully


I know that I'm not officially running Arch Linux (Antergos) on this particular machine - I do have a long running pure Arch setup on another machine, however - but I wanted to post and say that this did fix it for me as well. Hope this solution helps others, as the steps in the AUR comments and even above here didn't work for me until this. Thanks for the find alu1!

Offline

#15 2017-04-26 20:42:50

Purgator
Member
Registered: 2016-03-02
Posts: 86

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

I have the same issue and honestly I don't really remember why I installed it.
If we remove this package, which one could replace it ?
Ty

EDIT : I removed it, I installed it explicitly. Let's see...
I'm gonna watch out aur comments

EDIT2 :
From aur :

Ralf_Mardorf wrote:

Edit the PKGBUILD. Change pkgrel= from 27 to 28. Change the makedepends= and depends= entries 'libsoup-gnome' to 'libsoup'. This way building gstreamer0.10-good and gstreamer0.10-good-plugins works, it also resolves the dependency issue, but I didn't test if it still works big_smile.

Last edited by Purgator (2017-04-27 07:46:30)

Offline

#16 2017-05-01 15:39:22

nilesOien
Member
From: Boulder, CO, USA
Registered: 2015-05-08
Posts: 20

Re: gstreamer-10-good-plugins : libsoup 2.58.0-1 breaks dependancy(SOLVED)

Thanks, alu1, your post really helped me!


-- "Make it as simple as possible, but no simpler" - Albert Einstein

Offline

Board footer

Powered by FluxBB