You are not logged in.

#1 2017-04-25 23:20:38

kthomas
Member
From: Washington State
Registered: 2017-04-25
Posts: 2

[SOLVED] Black Screen on Lenovo T450s with integrated graphics.

Hello everyone, I spent the better part of the weekend trying to install Arch on my T450s with integrated Intel graphics (no other GPU) and I was getting the dreaded black screen after the GRUB menu for the installation media.

Passing nomodeset and the other commonly suggested parameters was not working, it booted fine in compatibility mode but UFEI wasn't working (secure boot  was off). I tried dd, the Universal USB Installer, and another windows utility (I can't remember the name right now).

I found a suggestion to use the Rufus USB creator and ran that. Rufus has an option to change the partition table of the USB stick from MBR to GPT. I set that option when I put the image on the USB stick and it booted up perfectly without issue, so I'm going to assume that the partition table of the USB stick was the problem.

Most people had given up and installed Arch in compatibility mode and then converted it to UFEI later or they would install it by the bootstrapping method with another live distro that would work. This solution doesn't seem very well known so I wanted to share it for anybody else that is pulling their hair out over this problem.

The Arch community has been a huge asset for me no matter what distro I was having a problem in so I wanted to make this fix known. I am not an expert by any stretch of the imagination, just an enthusiast smile

Edit: I corrected some spelling/grammer errors above.

Last edited by kthomas (2017-04-25 23:23:09)

Offline

#2 2017-04-26 11:39:32

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,613

Re: [SOLVED] Black Screen on Lenovo T450s with integrated graphics.

The install iso is supposed to boot on both Bios and uefi systems, were you using latest version 2017.04.01 ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2017-04-26 17:37:29

kthomas
Member
From: Washington State
Registered: 2017-04-25
Posts: 2

Re: [SOLVED] Black Screen on Lenovo T450s with integrated graphics.

Yes, it was the 2017.04.01 version and I confirmed that the sha1sum's were a match.

Last edited by kthomas (2017-04-26 17:44:11)

Offline

Board footer

Powered by FluxBB