You are not logged in.

#1 2017-04-29 14:40:16

Balaji Sivaraman
Registered: 2013-10-06
Posts: 4

[SOLVED] Systemd-Boot "Linux Boot Manager" not displayed in UEFI

Hi all,

My setup:

CPU: Intel Core i5-4570 Haswell CPU
Motherboard: MSI Z87-G43
HDDs: Samsung SSD 840 120GB SSD running Windows 10, Samsung SSD 840 EVO 120GB SSD with Arch Linux April 2017 ISO installed on it. (Not booting.)

A bit of background: This exact same system with the exact same above setup had been running Arch Linux without issues till February 2017, at which point I had to uninstall it for various reasons. I decided to reinstall it to the same Samsung EVO SSD this week and the UEFI partition is not being listed during boot. (No changes to the actual system itself between Feb and April, except a Windows 10 upgrade.)

Steps I have taken:

  1. Checked whether Fast Boot, Secure Boot is disabled in BIOS and Windows 10. Checked that only UEFI boot is enabled in BIOS and not UEFI + Legacy, as suggested by some folks.

  2. Followed all instructions here to ensure that my UEFI variables are in order.

  3. Tried creating a manual entry in the boot manager by following these instructions. After creation, I can see that the entry is displayed properly before boot and Linux Boot Manager is also set as the first choice to boot, but it disappears on boot. This is an issue many have faced in the past. But never me on this system.

  4. Tried using various BCDEDIT configurations under Windows 10 to set the current UEFI application. (As suggested in this page: … oot_order)

    • bcdedit /set "{bootmgr}" path "\EFI\BOOT\BOOTX64.EFI" (This created a duplicate entry for Windows Boot Manager in my UEFI boot order that refuses to go away, but no matter which one I select, I am able to boot to Windows at least.)

    • bcdedit /set "{bootmgr}" path "\efi\systemd\systemd-bootX64.efi"

    • bcdedit /set "{fwbootmgr}" DEFAULT "{copied boot identifier}" (Along with creating the BATCH file as well.)

  5. Tried copying BOOTX64.efi to the place where Windows might look for it as suggested here: … mware_menu

  6. Tried installing GRUB instead of systemd-boot and faced the same issue. Everything worked fine until grub-mkconfig. I could see the entry using EFIBOOTMGR, but it was gone on reboot.

  7. Upgraded motherboard BIOS to the latest official provided by the manufacturer. This didn't help either. So I completely cleared CMOS by resetting the jumper and removing the battery as well. This did clear settings and NVRAM (I think), but it did not help with the Linux Boot Manager not appearing issue.

  8. Additionally when I upgraded my BIOS, there was an issue where Windows 10 would randomly refuse to boot as well. I thought I had screwed up my UEFI settings because of this. But moving my RAM around to other slots and clearing the UEFI helped with this. I am now able to consistently boot into Windows 10 for the time being.

I am right now completely out of options. I think I have tried every option suggested in the Arch Wiki, as well as some suggested through Google searches, but none of them work. More to the point, I am completely baffled as to how this suddenly started occurring without any system level changes, when everything worked a couple of months back.

Any help would be greatly appreciated? Thank you in advance.

Last edited by Balaji Sivaraman (2017-05-02 19:17:36)


#2 2017-05-02 19:19:16

Balaji Sivaraman
Registered: 2013-10-06
Posts: 4

Re: [SOLVED] Systemd-Boot "Linux Boot Manager" not displayed in UEFI

I am sorry for wasting all of your time. This turned out to be a "Protective MBR" issue that had plagued many users in the past. I just had to figure the magic search words that would lead Google to point me to this thread: (After following the `dd` command provided in that thread, I was able to boot again.)


Board footer

Powered by FluxBB