You are not logged in.

#1 2017-05-02 12:54:38

VinceNardelli
Member
From: London
Registered: 2017-03-12
Posts: 41

[SOLVED] Nvidia vs nvidia-dkms

Hello guys,
I have a question about Nvidia drivers. I installed Nvidia drivers and it's utilities.  However, I am having some problems with some games on steam (Deus ex, Bastion, Civ6).

Searching around I found out the existence of nvidia-dkms drivers. The wiki says they are dynamic kernel drivers. They are supposed to adapt on my current kernel.
I don't know if they are going to resolve my problems, but I was wondering if you could help me clearing up the difference between Nvidia and nvidia-dkms. Should I always install them?

Thanks in advance

Last edited by VinceNardelli (2017-05-02 22:01:47)

Offline

#2 2017-05-02 13:48:34

Omar007
Member
Registered: 2015-04-09
Posts: 368

Re: [SOLVED] Nvidia vs nvidia-dkms

You install 'nvidia' if you're only using the mainline kernel (the 'linux' package).
You install 'nvidia-lts' if you're only using the LTS kernel (the 'linux-lts' package).
Same for w/e other kernel package is available with an accompanying nvidia package.

You install 'nvidia-dkms' if you're using/compiling custom kernels that do not have an accompanying nvidia package.
There is no point or benefit to using 'nvidia-dkms' otherwise (such as in any of the above mentioned cases).

See also: https://wiki.archlinux.org/index.php/NVIDIA

Last edited by Omar007 (2017-05-02 13:52:35)

Offline

#3 2017-05-02 14:31:06

VinceNardelli
Member
From: London
Registered: 2017-03-12
Posts: 41

Re: [SOLVED] Nvidia vs nvidia-dkms

Ok, Thanks. So I shouldn't expect any difference in performance, or change in being able to launch DeusEx. Too bad lol .... I have to admit Arch and Steam aren't great friends...

Offline

#4 2017-05-02 17:04:02

Ropid
Member
Registered: 2015-03-09
Posts: 1,068

Re: [SOLVED] Nvidia vs nvidia-dkms

Your problem is that this Deus Ex game hangs when you try to start it? The Linux version of Deus Ex is done by Feral Interactive if I got that right. For their other games, you need to install a package "libopenssl-1.0-compat" from the AUR, then use the following as Launch Option for the game in the Steam client:

LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat:$LD_LIBRARY_PATH %command%

This works for me with Tomb Raider. The problem showed up one or two weeks ago because of an openssl-1.0 package update.

Offline

#5 2017-05-02 18:31:54

VinceNardelli
Member
From: London
Registered: 2017-03-12
Posts: 41

Re: [SOLVED] Nvidia vs nvidia-dkms

I tried installing that package, but it gives me this error: One or more PGP signatures could not be verified!

I went online and it seems I have to read and deeply understand what a PGP signature is and how to change it. Lol I started from Deus Ex and ended up going somewhere I can understand even less...
Please tell me all this wouldn't happen with Ubuntu...
And by the way, Civ5 works just fine! I just have to set a different Launch Option. Why is it different for Civ VI?

Last edited by VinceNardelli (2017-05-02 18:41:00)

Offline

#6 2017-05-02 21:37:28

Ropid
Member
Registered: 2015-03-09
Posts: 1,068

Re: [SOLVED] Nvidia vs nvidia-dkms

For those PGP signatures, edit (or create) a file ~/.gnupg/gpg.conf and make it look like this:

keyserver hkp://keys.gnupg.net
keyserver-options auto-key-retrieve

It should then automatically search and download keys and will then be able to check those signatures it complains about.

This was all not a problem until very recently. On Arch, Steam and games usually worked for me without any manual intervention needed with nvidia's drivers. I don't know if this new issue can be fixed through changes to the normal Arch packages, so it might be something that has to now be dealt with manually for these Feral Interactive games.

I have no idea about Civ VI. I didn't buy it (yet). I think I might wait for a bundle package after a bunch of expansions have been released for it.

Offline

#7 2017-05-02 22:01:03

VinceNardelli
Member
From: London
Registered: 2017-03-12
Posts: 41

Re: [SOLVED] Nvidia vs nvidia-dkms

Thanks a lot! Thanks to your kind help I fixed my game, learnt a new thing or two and who knows, hopefully in future the core Arch will contain this package.

I am glad I can play. Yet ... I wish this package was part of the game installed. Many thanks !

Offline

Board footer

Powered by FluxBB