You are not logged in.

#1 2017-05-14 12:21:42

mn
Member
Registered: 2017-05-14
Posts: 1

python2-backports.functools_lru_cache already exists in filesystem

Hello people from arch linux,

When I try to upgrade my system as follows

 sudo pacman -Syyu 

the following output is returned

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (2) libmm-glib-1.6.6-1  python2-backports.functools_lru_cache-1.4-1

Total Installed Size:  3.77 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                     [######################] 100%
(2/2) checking package integrity                   [######################] 100%
(0/2) loading package files                        [----------------------]   0%
(2/2) loading package files                        [######################] 100%
(2/2) checking for file conflicts                  [######################] 100%
error: failed to commit transaction (conflicting files)
python2-backports.functools_lru_cache: /usr/lib/python2.7/site-packages/backports/__init__.py exists in filesystem
python2-backports.functools_lru_cache: /usr/lib/python2.7/site-packages/backports/__init__.pyc exists in filesystem
Errors occurred, no packages were upgraded.

I followed the instructions on https://wiki.archlinux.org/index.php/Pa … 9.22_error and checked if the file was already owned by issuing the command

sudo pacman -Qo  /usr/lib/python2.7/site-packages/backports/__init__.py

which outputs

/usr/lib/python2.7/site-packages/backports/__init__.py is owned by python2-backports 1.0-1

I then tried removing this package, but unfortunately this would break some dependencies.

sudo pacman -Rs python2-backports
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: python2-backports.functools_lru_cache: removing python2-backports breaks dependency 'python2-backports'
:: python2-backports.shutil_get_terminal_size: removing python2-backports breaks dependency 'python2-backports'

Does any one know how to solve this issue?

Thanks in advance,
mn

Offline

#2 2017-05-14 12:49:46

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: python2-backports.functools_lru_cache already exists in filesystem

https://bugs.archlinux.org/task/54034

Incidentally, it is safe to `--ignore python2-backports.functools_lru_cache`, since none of the reverse-dependencies have been updated since python2-backports.functools_lru_cache itself.

Presumably everything will go back to normal soon. wink

Last edited by eschwartz (2017-05-14 12:52:52)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB